Bug 834318 - kernel 3.4.3-1.fc17.x86_64 fails to boot in fedora 17
kernel 3.4.3-1.fc17.x86_64 fails to boot in fedora 17
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
acpi first=3.4.0-1 regression-from=3.3
:
: 835124 835734 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 10:30 EDT by Ian Malone
Modified: 2012-07-27 05:52 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 05:13:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
picture of call trace (1.54 MB, image/jpeg)
2012-06-21 10:30 EDT, Ian Malone
no flags Details
pause_on_oops picture of call trace #1 (1.54 MB, image/jpeg)
2012-06-21 11:34 EDT, Ian Malone
no flags Details
pause_on_oops picture of call trace #2 (1.53 MB, image/jpeg)
2012-06-21 11:35 EDT, Ian Malone
no flags Details
acpidump output (133.57 KB, text/plain)
2012-06-21 11:36 EDT, Ian Malone
no flags Details
oops pic 1/2 (1.77 MB, image/jpeg)
2012-06-22 22:22 EDT, Alejandro Mota
no flags Details
oops pic 2/2 (1.84 MB, image/jpeg)
2012-06-22 22:22 EDT, Alejandro Mota
no flags Details
output from acpidump (366.62 KB, text/plain)
2012-06-22 22:23 EDT, Alejandro Mota
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 44171 None None None 2012-07-12 05:57:56 EDT

  None (edit)
Description Ian Malone 2012-06-21 10:30:09 EDT
Created attachment 593458 [details]
picture of call trace

Description of problem:
Kernel 3.4.3-1.fc17.x86_64 fails to boot (attaching picture of backtrace), the machine boots okay if the acpi=off parameter is given. The release kernel for F17 kernel-3.3.4-5.fc17.x86_64 boots okay.

Machine:
http://www.smolts.org/client/show/pub_1fa1c4e2-ef69-43f8-a0c4-d92703b7b633

Version-Release number of selected component (if applicable):
Kernel 3.4.3-1.fc17.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Turn machine on.
2. Watch grub start, then machine crash while attempting to boot.
3.
  
Actual results:
Hang.

Expected results:
Don't hang.

Additional info:
Comment 1 Josh Boyer 2012-06-21 10:45:39 EDT
Do the 3.4.0-1.fc17 or 3.4.2-1.fc17 kernels boot successfully?

Can you remove 'rhgb quiet' from the linux line in the grub.cfg  file and add 'pause_on_oops=30' and take another picture of the failure?  The top of the oops has scrolled off the screen.

Also, we might need the output of acpidump for this machine so if you could attach that it would be appreciated.
Comment 2 Ian Malone 2012-06-21 11:34:25 EDT
Created attachment 593486 [details]
pause_on_oops picture of call trace #1
Comment 3 Ian Malone 2012-06-21 11:35:13 EDT
Created attachment 593487 [details]
pause_on_oops picture of call trace #2
Comment 4 Ian Malone 2012-06-21 11:36:42 EDT
Created attachment 593488 [details]
acpidump output

Hi, all attachments requested. This is a fresh install of F17, so I haven't had the intermediate kernels to try, will get hold of them and test when I have time.
Comment 5 Ian Malone 2012-06-21 17:25:24 EDT
(In reply to comment #1)
> Do the 3.4.0-1.fc17 or 3.4.2-1.fc17 kernels boot successfully?
> 

No, fails for both.
Comment 6 Alejandro Mota 2012-06-22 22:22:08 EDT
Created attachment 593844 [details]
oops pic 1/2
Comment 7 Alejandro Mota 2012-06-22 22:22:33 EDT
Created attachment 593845 [details]
oops pic 2/2
Comment 8 Alejandro Mota 2012-06-22 22:23:00 EDT
Created attachment 593846 [details]
output from acpidump
Comment 9 Alejandro Mota 2012-06-22 22:26:05 EDT
I think I see the same problem on my work (Mac Pro with F16) and home (Mac Pro with F17) machines. Both fail to boot with kernels 3.4.x. Home machine:

http://www.smolts.org/client/show/pub_ad9b4a1d-1e8a-4963-b82f-03f609bd39b7

And I attach two pictures of the oops and the output from acpidump.
Comment 10 Josh Boyer 2012-06-25 13:51:17 EDT
*** Bug 835124 has been marked as a duplicate of this bug. ***
Comment 11 Josh Boyer 2012-06-25 13:57:11 EDT
Could you please test the stock 3.4 kernel here and let us know if it works.  That will narrow down whether it was something in 3.4 itself, or something added to a -stable update later.

http://koji.fedoraproject.org/koji/buildinfo?buildID=319920
Comment 12 Ian Malone 2012-06-25 17:14:34 EDT
Crashes on that kernel too.
Comment 13 Alejandro Mota 2012-06-25 23:43:24 EDT
The kernel:

kernel-3.4.0-1.fc18.x86_64

from

http://koji.fedoraproject.org/koji/buildinfo?buildID=319920

fails for me with the same oops.
Comment 14 Josh Boyer 2012-07-10 08:22:37 EDT
There are two things that can be done to help this bug along.

1) Someone with an impacted machine could email the upstream linux-acpi mailing list with the failure.  Upstream might ask you to try a newer kernel, so grabbing 3.5.0-rc6 from rawhide would be worth trying as well.

2) Performing a git bisect between the 3.3 and 3.4 kernels to see which commit caused this issue.
Comment 15 Ian Malone 2012-07-10 18:30:28 EDT
(In reply to comment #14)
> There are two things that can be done to help this bug along.
> 
> 1) Someone with an impacted machine could email the upstream linux-acpi
> mailing list with the failure.  Upstream might ask you to try a newer
> kernel, so grabbing 3.5.0-rc6 from rawhide would be worth trying as well.
> 

3.5.0-rc6 doesn't boot either. I'll try upstream.

> 2) Performing a git bisect between the 3.3 and 3.4 kernels to see which
> commit caused this issue.

This might be rather tricky on this machine (I think it might struggle to build the kernel), so I'll pursue option 1 first.
Comment 16 Ian Malone 2012-07-12 05:57:56 EDT
Apparently it's this bug, fix is committed and being back-ported to 3.4 too: https://bugzilla.kernel.org/show_bug.cgi?id=44171
See also http://marc.info/?l=linux-acpi&m=134208559227625&w=2
Comment 17 Josh Boyer 2012-07-12 13:13:08 EDT
(In reply to comment #16)
> Apparently it's this bug, fix is committed and being back-ported to 3.4 too:
> https://bugzilla.kernel.org/show_bug.cgi?id=44171
> See also http://marc.info/?l=linux-acpi&m=134208559227625&w=2

Excellent find.  I will create a scratch build with the mentioned patch for testing shortly.
Comment 18 Ian Malone 2012-07-12 13:23:23 EDT
I've confirmed that the patch works for me applied to 3.4.5-4.
Comment 19 Josh Boyer 2012-07-12 13:36:57 EDT
Please try this scratch kernel when it finishes building and let us know if it boots.  It contains a patch to fix an ACPICA regression in the 3.4 kernel.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4237073
Comment 20 Josh Boyer 2012-07-12 14:05:23 EDT
(In reply to comment #18)
> I've confirmed that the patch works for me applied to 3.4.5-4.

Excellent.  I have a query out to one other bug and I'll get this fixed up in Fedora git shortly.  If you'd like to still test the scratch build, that would also be appreciated.
Comment 21 Ian Malone 2012-07-12 16:47:43 EDT
Yes, the koji build works too, thanks for your help.
Comment 22 Josh Boyer 2012-07-12 16:52:57 EDT
Fixed in Fedora git.  Will be in the next update.  Many thanks for your help with this.
Comment 23 Josh Boyer 2012-07-13 08:47:34 EDT
*** Bug 835734 has been marked as a duplicate of this bug. ***
Comment 24 Fedora Update System 2012-07-17 08:42:36 EDT
kernel-3.4.5-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.4.5-2.fc17
Comment 25 Fedora Update System 2012-07-17 08:46:29 EDT
kernel-3.4.5-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.4.5-1.fc16
Comment 26 Fedora Update System 2012-07-19 04:57:14 EDT
Package kernel-3.4.5-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.4.5-1.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10764/kernel-3.4.5-1.fc16
then log in and leave karma (feedback).
Comment 27 Fedora Update System 2012-07-19 05:13:15 EDT
kernel-3.4.5-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 28 Fedora Update System 2012-07-24 07:12:59 EDT
kernel-3.4.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.4.6-1.fc16
Comment 29 Fedora Update System 2012-07-27 05:52:53 EDT
kernel-3.4.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.