Bug 835734 - Kernel crashes on Mac Pro
Kernel crashes on Mac Pro
Status: CLOSED DUPLICATE of bug 834318
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 839507 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 21:35 EDT by Andrew
Modified: 2012-07-13 08:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 839507 (view as bug list)
Environment:
Last Closed: 2012-07-13 08:47:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Photo of screen - kernel-PAE-3.4.4-4.f16 crashing on boot (747.98 KB, image/jpeg)
2012-07-12 18:59 EDT, Andrew
no flags Details
Photo of screen - kernel-PAE-3.4.4-5.5.f17 crashing just after boot (734.53 KB, image/jpeg)
2012-07-12 19:33 EDT, Andrew
no flags Details

  None (edit)
Description Andrew 2012-06-26 21:35:40 EDT
Description of problem:

kernel-PAE-3.4.2 crashes on boot.

Version-Release number of selected component (if applicable):

kernel-PAE-3.4.2-1.fc16.i686

How reproducible:

very

Steps to Reproduce:

1. Have a running f16 system on a Mac Pro

2. Do the kernel update

3. Reboot
  
Actual results:

computer can't boot

Expected results:

Fedora

Additional info:

I also tried installing the 3.4.4 kernel and got the same result. The latest kernel I can run is 3.3.8

The machine is a stock standard 2009 Mac Pro desktop computer. Fedora runs perfectly with every kernel up to and includidng 3.3.8. Any kernel after that won't boot.
Comment 1 Andrew 2012-06-26 23:49:55 EDT
Should have mentioned - when boot fails what's printed on the screen is a whole heap of numbers, ACPI PREPROCESSOR, some more numbers, then Kernel Panic!

Then system is dead.
Comment 2 Andrew 2012-07-05 20:20:34 EDT
No Response for this one?

It's not a critical issue, the Mac runs sweet on the older kernel but the bloke who owns it did the updates and I had to go around there and edit his grub.cfg for him and I just know that that's going to happen every time another kernel comes out.

Cheers,

Andrew.
Comment 3 Andrew 2012-07-12 03:02:36 EDT
Today I tried the kernel-PAE-3.4.4-4.fc16,

Same result, Mac pro can't boot under any kernel newer than 3.3.8

Can you help me out here? next time this guy does an update that includes a new kernel the last kernel that works will be automatically removed.

Is it possible to edit the severity of this bug because the severity has altered.

Cheers,

Andrew.
Comment 4 Dave Jones 2012-07-12 10:18:58 EDT
can you take a photo of those numbers ?
We need the backtrace to really figure out what's going on.

(don't worry about the severity field, we don't use it).
Comment 5 Dave Jones 2012-07-12 10:20:56 EDT
*** Bug 839507 has been marked as a duplicate of this bug. ***
Comment 6 Josh Boyer 2012-07-12 13:36:58 EDT
Please try this scratch kernel when it finishes building and let us know if it boots.  It contains a patch to fix an ACPICA regression in the 3.4 kernel.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4237073
Comment 7 Andrew 2012-07-12 18:59:39 EDT
Created attachment 597913 [details]
Photo of screen - kernel-PAE-3.4.4-4.f16 crashing on boot

Photo as requested by Dave Jones
Comment 8 Andrew 2012-07-12 19:33:33 EDT
Created attachment 597920 [details]
Photo of screen - kernel-PAE-3.4.4-5.5.f17 crashing just after boot

Hi Josh,

I tried the new scratch kernel as you suggested and at first I thought it was going to work, graphical boot right up to when it would open the desktop.

Then it dropped me back to this screen. Keyboard was responsive this time around but the only command it acceppted was CTRL ALT DEL.

I did notice that the scratch kernel was for F17 and I'm running F16, could that be the problem?

Cheers,

Andrew.
Comment 9 Andrew 2012-07-12 20:54:17 EDT
Hi Josh and Dave,

Did a bit of looking through the log files, I don't know what most of it means but when that F17 kernel failed to start the message was basically:

nVidia module not found
no screens found

Could this just be because of a mismatch between f16 and f17 kernel and modules?

I'd be happy to send you any of those logs, just let me know which ones. Dates and times might seem a bit funny to you though because my timezone is GMT+9:30,

Darwin, Australia.

To come so close to working, that kernel got me all excited.

I live in a remote community and most of the people out here are jack of both Windows and Mac. One keeps automatically installing viruses and spyware, the other's just too slow and useless, so there's been a fair bit of interest in Fedora since I've ben showing it around. There's only 200 people that live out here and already 7 of us are running your system, more are bound to follow soon.

For country people that have very little computer experience (some struggle even to send an email in Windows) to take so quickly to Fedora says that you blokes have definately got something right.

Cheers,

Andrew.
Comment 10 Josh Boyer 2012-07-13 08:47:34 EDT
(In reply to comment #8)
> Created attachment 597920 [details]
> Photo of screen - kernel-PAE-3.4.4-5.5.f17 crashing just after boot
> 
> Hi Josh,
> 
> I tried the new scratch kernel as you suggested and at first I thought it
> was going to work, graphical boot right up to when it would open the desktop.
> 
> Then it dropped me back to this screen. Keyboard was responsive this time
> around but the only command it acceppted was CTRL ALT DEL.

Actually the patch did work.  It got you past the actual crash from the photo in comment #7.

(In reply to comment #9)
> Hi Josh and Dave,
> 
> Did a bit of looking through the log files, I don't know what most of it
> means but when that F17 kernel failed to start the message was basically:
> 
> nVidia module not found
> no screens found
> 
> Could this just be because of a mismatch between f16 and f17 kernel and
> modules?

You're using the proprietary nVidia driver, so probably.

The next F16 kernel update will have the patch that fixed the original crash in it.  You'll need to sort out whatever is required to use the nVidia driver if you want to continue using that as we don't support it.

*** This bug has been marked as a duplicate of bug 834318 ***

Note You need to log in before you can comment on or make changes to this bug.