Bug 835304 - Fedora 17 cannot print to an HP Laserjet 1018 hosted on a PC with Win XP
Fedora 17 cannot print to an HP Laserjet 1018 hosted on a PC with Win XP
Status: CLOSED DUPLICATE of bug 611255
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 18:01 EDT by William Bader
Modified: 2012-06-26 10:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 05:29:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bz2 tar with the Fedora 14 files (31.09 KB, application/octet-stream)
2012-06-25 18:09 EDT, William Bader
no flags Details

  None (edit)
Description William Bader 2012-06-25 18:01:22 EDT
Description of problem:

I print from Linux to an HP 1018 that is plugged into a Win XP system.
It worked from Fedora 8 and 14, but I just updated to Fedora 17, and it no longer works.

cups on Fedora 17 provides two HP 1018 drivers, but neither works.
I ran "hp-plugin -i" to install the proprietary drivers.
The cups errors log shows lines like

D [25/Jun/2012:21:51:27 +0200] [Job 1] STATE: +hplip.plugin-error
D [25/Jun/2012:21:51:27 +0200] [Job 1] prnt/hpcups/HPCupsFilter.cpp 435: m_Job initialization failed with error = 48
D [25/Jun/2012:21:51:27 +0200] [Job 1] End of messages
D [25/Jun/2012:21:51:27 +0200] [Job 1] printer-state=3(idle)
D [25/Jun/2012:21:51:27 +0200] [Job 1] printer-state-message="/usr/lib/cups/filter/hpcups failed"
D [25/Jun/2012:21:51:27 +0200] [Job 1] printer-state-reasons=hplip.plugin-error

and

D [25/Jun/2012:21:56:33 +0200] [Job 2] Start rendering...
D [25/Jun/2012:21:56:33 +0200] [Job 2] Set job-printer-state-message to "Start rendering...", current level=INFO
D [25/Jun/2012:21:56:33 +0200] [Job 2] Processing page 1...
D [25/Jun/2012:21:56:33 +0200] [Job 2] Set job-printer-state-message to "Processing page 1...", current level=INFO
D [25/Jun/2012:21:56:33 +0200] [Job 2] Error: This module is designed to work with HP Printers only
D [25/Jun/2012:21:56:33 +0200] [Job 2] STATE: +hplip.plugin-error
D [25/Jun/2012:21:56:33 +0200] [Job 2] prnt/hpcups/HPCupsFilter.cpp 435: m_Job initialization failed with error = 48
D [25/Jun/2012:21:56:33 +0200] [Job 2] Connected using Kerberos...
D [25/Jun/2012:21:56:33 +0200] [Job 2] End of messages
D [25/Jun/2012:21:56:33 +0200] [Job 2] printer-state=3(idle)
D [25/Jun/2012:21:56:33 +0200] [Job 2] printer-state-message="/usr/lib/cups/filter/hpcups failed"
D [25/Jun/2012:21:56:33 +0200] [Job 2] printer-state-reasons=hplip.plugin-error
E [25/Jun/2012:22:01:34 +0200] [Job 2] Stopping unresponsive job!
W [25/Jun/2012:22:03:36 +0200] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/KONICA_MINOLTA/KOC451JX.ppd.gz!
W [25/Jun/2012:22:03:36 +0200] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp950c.ppd.gz!
W [25/Jun/2012:22:03:36 +0200] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp880c.ppd.gz!
W [25/Jun/2012:22:03:36 +0200] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp960s.ppd.gz!
W [25/Jun/2012:22:03:36 +0200] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp830c.ppd.gz!
W [25/Jun/2012:22:03:36 +0200] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp9100.ppd.gz!
W [25/Jun/2012:22:03:36 +0200] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp980c.ppd.gz!
W [25/Jun/2012:22:03:36 +0200] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp920c.ppd.gz!
W [25/Jun/2012:22:03:36 +0200] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp850c.ppd.gz!
W [25/Jun/2012:22:03:36 +0200] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Brother/BR5070DN_GPL.ppd.gz!
W [25/Jun/2012:22:04:28 +0200] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'g1018-Gray..' already exists
W [25/Jun/2012:22:04:28 +0200] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'g1018-RGB..' already exists
W [25/Jun/2012:22:04:28 +0200] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-g1018' already exists
W [25/Jun/2012:22:04:28 +0200] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'g1018-Gray..' already exists
W [25/Jun/2012:22:04:28 +0200] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'g1018-RGB..' already exists
W [25/Jun/2012:22:04:28 +0200] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-g1018' already exists
W [25/Jun/2012:22:04:29 +0200] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'g1018-Gray..' already exists
W [25/Jun/2012:22:04:29 +0200] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'g1018-RGB..' already exists
W [25/Jun/2012:22:04:29 +0200] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-g1018' already exists
W [25/Jun/2012:22:04:29 +0200] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'g1018-Gray..' already exists
W [25/Jun/2012:22:04:29 +0200] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'g1018-RGB..' already exists
W [25/Jun/2012:22:04:29 +0200] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-g1018' already exists
E [25/Jun/2012:22:08:54 +0200] [Job 4] Job stopped due to filter errors; please consult the error_log file for details.

Version-Release number of selected component (if applicable):

sony ~$ uname -a
Linux sony 3.4.3-1.fc17.x86_64 #1 SMP Mon Jun 18 19:53:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
sony ~$ rpm -qa | grep '^cups'
cups-libs-1.5.2-12.fc17.x86_64
cups-pk-helper-0.2.2-1.fc17.x86_64
cups-devel-1.5.2-12.fc17.x86_64
cups-libs-1.5.2-12.fc17.i686
cups-1.5.2-12.fc17.x86_64
sony ~$ rpm -qa | grep '^samba'
samba-common-3.6.5-86.fc17.1.x86_64
samba-3.6.5-86.fc17.1.x86_64
samba-client-3.6.5-86.fc17.1.x86_64

How reproducible:

Install an HP 1018 on a Windows XP system and share it.
Create a cups entry as a "Windows Printer via SAMBA" using either the "HP LaserJet 1018 hpijs, 3.12.4, requires proprietary plugin" or the other driver.


Steps to Reproduce:
1. create a printer for an HP 1018
2. print the test page
3.
  
Actual results:

cups gets errors and does not print anything.

Expected results:

The page prints.

Additional info:

It worked on Fedora 14 with the foomatic/foo2zjs driver.  "yum provides" on Fedora 17 did not find a package with those files, so I copied them from the Fedora 14 system.  After copying the files from Fedora 14, cups administration showed a third HP 1018 entry with the foomatic driver.  I selected it, and it worked.  I have listed the files below.  Can you please restore them to one of the printing packages?  Is there a third-party repository that I need to enable?

/usr/share/foomatic/db/source/printer/HP-LaserJet_1018.xml
/usr/share/cups/model/HP-LaserJet_1018.ppd.gz
/usr/bin/foo2zjs*
Comment 1 William Bader 2012-06-25 18:09:02 EDT
Created attachment 594304 [details]
bz2 tar with the Fedora 14 files

I added the files for reference and in case anyone needs the same work-around and doesn't have an older Fedora system to copy.  To get foo2zjs to run, I had to install jbigkit-libs.i686.
Comment 2 Jiri Popelka 2012-06-26 05:29:37 EDT
(In reply to comment #0)
> cups on Fedora 17 provides two HP 1018 drivers, but neither works.
> I ran "hp-plugin -i" to install the proprietary drivers.
> The cups errors log shows lines like
> D [25/Jun/2012:21:51:27 +0200] [Job 1] STATE: +hplip.plugin-error
> D [25/Jun/2012:21:51:27 +0200] [Job 1] prnt/hpcups/HPCupsFilter.cpp 435:
> m_Job initialization failed with error = 48
> printer-state-message="/usr/lib/cups/filter/hpcups failed"
> D [25/Jun/2012:21:51:27 +0200] [Job 1]
> printer-state-reasons=hplip.plugin-error

This claims that the proprietary plugin is not installed.
Could you change the driver to 'HP LaserJet 1018 hpcups'
and install the plugin once more ?

> It worked on Fedora 14 with the foomatic/foo2zjs driver.  "yum provides" on
> Fedora 17 did not find a package with those files, so I copied them from the
> Fedora 14 system. Is there a third-party
> repository that I need to enable?

Yes, you need to enable rpmfusion-free repository to install foo2zjs.

*** This bug has been marked as a duplicate of bug 611255 ***
Comment 3 William Bader 2012-06-26 10:31:31 EDT
Thanks!
I added the rpmfusion repositories with
 yum localinstall --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
and then I could run
  yum install foo2zjs
Then I re-ran
  hp-plugin -i
and it did more than it did last night including some downloads.
When I went into cups, I could see the new entries.
William

Note You need to log in before you can comment on or make changes to this bug.