Bug 835870 - Tab key behavior in dialogs is incorrect
Tab key behavior in dialogs is incorrect
Status: CLOSED DUPLICATE of bug 903558
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
unspecified
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Einav Cohen
Pavel Stehlik
ux
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 07:16 EDT by Itamar Heim
Modified: 2013-05-10 13:44 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-10 13:44:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Itamar Heim 2012-06-27 07:16:27 EDT
1. tab key should go over fields in the order they are displayed on the screen.
   (for example, add logical network from cluster does not)
2. tab ordering should be cyclic - today after a few tabs the cursor simply goes 
   away to some hidden tab.
3. tab should also allow moving to other panes in the dialog
(maybe track in another bug if too much work for this one)
Comment 1 Itamar Heim 2012-08-14 10:15:53 EDT
see bug 845996 as well
Comment 2 Einav Cohen 2012-08-27 07:47:55 EDT
(In reply to comment #1)
> see bug 845996 as well

This bug is about the "TAB" keyboard key.
bug 845996 is about moving between main tabs in the GUI.
Not sure how these two bugs are related.
Comment 3 Einav Cohen 2012-10-18 19:40:03 EDT
after discussing with Gilad: Too complicated for 3.1. pushing to rhevm_future.
Comment 4 Einav Cohen 2013-05-10 11:56:32 EDT
*** Bug 832769 has been marked as a duplicate of this bug. ***
Comment 5 Einav Cohen 2013-05-10 12:06:11 EDT
important information from duplicated bug 832769:

[By Juan]
"""
Apparently this is a known issue with GWT:

http://code.google.com/p/google-web-toolkit/issues/detail?id=2732
"""

There are also a couple of "merged" (related/duplicate?) issues:
https://code.google.com/p/google-web-toolkit/issues/detail?id=5263
https://code.google.com/p/google-web-toolkit/issues/detail?id=5231

in the last issue, it seems that there is no plan to fix it in the GWT infrastructure; this issue also lists a "workaround" (which is not really a workaround - it is actually "the correct way of doing things"), so maybe we need to do something similar.
Comment 6 Einav Cohen 2013-05-10 13:44:46 EDT

*** This bug has been marked as a duplicate of bug 903558 ***

Note You need to log in before you can comment on or make changes to this bug.