Bug 848130 - pulp-selinux failing to install on f17
pulp-selinux failing to install on f17
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: z_other (Show other bugs)
Master
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sayli Karmarkar
Preethi Thomas
: Triaged
: 864110 (view as bug list)
Depends On: 836087
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 13:42 EDT by Preethi Thomas
Modified: 2015-03-22 21:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-08 12:03:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2012-08-14 13:42:00 EDT
Description of problem:

pulp-selinux failing to install on f17 due to 

https://bugzilla.redhat.com/show_bug.cgi?id=836087



[root@pulp-master ~]# yum install pulp-selinux
Resolving Dependencies
--> Running transaction check
---> Package pulp-selinux.noarch 0:0.0.323-1.fc17 will be installed
--> Processing Dependency: policycoreutils-python for package: pulp-selinux-0.0.323-1.fc17.noarch
--> Processing Dependency: /usr/sbin/semanage for package: pulp-selinux-0.0.323-1.fc17.noarch
--> Running transaction check
---> Package policycoreutils-python.x86_64 0:2.1.11-18.fc17 will be installed
--> Processing Dependency: policycoreutils = 2.1.11-18.fc17 for package: policycoreutils-python-2.1.11-18.fc17.x86_64
--> Processing Dependency: setools-libs-python >= 3.3.7-14 for package: policycoreutils-python-2.1.11-18.fc17.x86_64
--> Processing Dependency: libsemanage-python >= 2.1.6-3 for package: policycoreutils-python-2.1.11-18.fc17.x86_64
--> Processing Dependency: audit-libs-python >= 2.1.3-4 for package: policycoreutils-python-2.1.11-18.fc17.x86_64
--> Processing Dependency: selinux-policy-devel for package: policycoreutils-python-2.1.11-18.fc17.x86_64
--> Processing Dependency: python-IPy for package: policycoreutils-python-2.1.11-18.fc17.x86_64
--> Processing Dependency: libselinux-python for package: policycoreutils-python-2.1.11-18.fc17.x86_64
--> Processing Dependency: libcgroup for package: policycoreutils-python-2.1.11-18.fc17.x86_64
--> Processing Dependency: /usr/bin/make for package: policycoreutils-python-2.1.11-18.fc17.x86_64
--> Running transaction check
---> Package audit-libs-python.x86_64 0:2.2.1-1.fc17 will be installed
---> Package libcgroup.x86_64 0:0.38-1.fc17 will be installed
---> Package libselinux-python.x86_64 0:2.1.10-3.fc17 will be installed
---> Package libsemanage-python.x86_64 0:2.1.6-3.fc17 will be installed
---> Package make.x86_64 1:3.82-9.fc17 will be installed
---> Package policycoreutils.x86_64 0:2.1.11-6.fc17 will be updated
---> Package policycoreutils.x86_64 0:2.1.11-18.fc17 will be an update
---> Package python-IPy.noarch 0:0.75-2.fc17 will be installed
---> Package selinux-policy-devel.noarch 0:3.10.0-145.fc17 will be installed
--> Processing Dependency: selinux-policy = 3.10.0-145.fc17 for package: selinux-policy-devel-3.10.0-145.fc17.noarch
---> Package setools-libs-python.x86_64 0:3.3.7-24.fc17 will be installed
--> Processing Dependency: setools-libs = 3.3.7-24.fc17 for package: setools-libs-python-3.3.7-24.fc17.x86_64
--> Processing Dependency: libsefs.so.4(VERS_4.0)(64bit) for package: setools-libs-python-3.3.7-24.fc17.x86_64
--> Processing Dependency: libseaudit.so.4(VERS_4.2)(64bit) for package: setools-libs-python-3.3.7-24.fc17.x86_64
--> Processing Dependency: libseaudit.so.4(VERS_4.1)(64bit) for package: setools-libs-python-3.3.7-24.fc17.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.4)(64bit) for package: setools-libs-python-3.3.7-24.fc17.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.3)(64bit) for package: setools-libs-python-3.3.7-24.fc17.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.2)(64bit) for package: setools-libs-python-3.3.7-24.fc17.x86_64
--> Processing Dependency: libpoldiff.so.1(VERS_1.3)(64bit) for package: setools-libs-python-3.3.7-24.fc17.x86_64
--> Processing Dependency: libpoldiff.so.1(VERS_1.2)(64bit) for package: setools-libs-python-3.3.7-24.fc17.x86_64
--> Processing Dependency: libapol.so.4(VERS_4.1)(64bit) for package: setools-libs-python-3.3.7-24.fc17.x86_64
--> Processing Dependency: libapol.so.4(VERS_4.0)(64bit) for package: setools-libs-python-3.3.7-24.fc17.x86_64
--> Processing Dependency: libsefs.so.4()(64bit) for package: setools-libs-python-3.3.7-24.fc17.x86_64
--> Processing Dependency: libseaudit.so.4()(64bit) for package: setools-libs-python-3.3.7-24.fc17.x86_64
--> Processing Dependency: libqpol.so.1()(64bit) for package: setools-libs-python-3.3.7-24.fc17.x86_64
--> Processing Dependency: libpoldiff.so.1()(64bit) for package: setools-libs-python-3.3.7-24.fc17.x86_64
--> Processing Dependency: libapol.so.4()(64bit) for package: setools-libs-python-3.3.7-24.fc17.x86_64
--> Running transaction check
---> Package selinux-policy.noarch 0:3.10.0-121.fc17 will be updated
--> Processing Dependency: selinux-policy = 3.10.0-121.fc17 for package: selinux-policy-targeted-3.10.0-121.fc17.noarch
--> Processing Dependency: selinux-policy = 3.10.0-121.fc17 for package: selinux-policy-targeted-3.10.0-121.fc17.noarch
---> Package selinux-policy.noarch 0:3.10.0-145.fc17 will be an update
---> Package setools-libs.x86_64 0:3.3.7-24.fc17 will be installed
--> Running transaction check
---> Package selinux-policy-targeted.noarch 0:3.10.0-121.fc17 will be updated
---> Package selinux-policy-targeted.noarch 0:3.10.0-145.fc17 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                   Arch     Version             Repository         Size
================================================================================
Installing:
 pulp-selinux              noarch   0.0.323-1.fc17      pulp-v2-testing    62 k
Installing for dependencies:
 audit-libs-python         x86_64   2.2.1-1.fc17        fedora             64 k
 libcgroup                 x86_64   0.38-1.fc17         fedora             53 k
 libselinux-python         x86_64   2.1.10-3.fc17       fedora            219 k
 libsemanage-python        x86_64   2.1.6-3.fc17        fedora             85 k
 make                      x86_64   1:3.82-9.fc17       fedora            413 k
 policycoreutils-python    x86_64   2.1.11-18.fc17      updates           361 k
 python-IPy                noarch   0.75-2.fc17         fedora             32 k
 selinux-policy-devel      noarch   3.10.0-145.fc17     updates           1.3 M
 setools-libs              x86_64   3.3.7-24.fc17       fedora            403 k
 setools-libs-python       x86_64   3.3.7-24.fc17       fedora            221 k
Updating for dependencies:
 policycoreutils           x86_64   2.1.11-18.fc17      updates           465 k
 selinux-policy            noarch   3.10.0-145.fc17     updates           187 k
 selinux-policy-targeted   noarch   3.10.0-145.fc17     updates           3.7 M

Transaction Summary
================================================================================
Install  1 Package  (+10 Dependent packages)
Upgrade             (  3 Dependent packages)

Total download size: 7.5 M
Is this ok [y/N]: y
Downloading Packages:
(1/14): audit-libs-python-2.2.1-1.fc17.x86_64.rpm        |  64 kB     00:00     
(2/14): libcgroup-0.38-1.fc17.x86_64.rpm                 |  53 kB     00:00     
(3/14): libselinux-python-2.1.10-3.fc17.x86_64.rpm       | 219 kB     00:00     
(4/14): libsemanage-python-2.1.6-3.fc17.x86_64.rpm       |  85 kB     00:00     
(5/14): make-3.82-9.fc17.x86_64.rpm                      | 413 kB     00:02     
(6/14): policycoreutils-2.1.11-18.fc17.x86_64.rpm        | 465 kB     00:00     
(7/14): policycoreutils-python-2.1.11-18.fc17.x86_64.rpm | 361 kB     00:00     
(8/14): pulp-selinux-0.0.323-1.fc17.noarch.rpm           |  62 kB     00:00     
(9/14): python-IPy-0.75-2.fc17.noarch.rpm                |  32 kB     00:00     
(10/14): selinux-policy-3.10.0-145.fc17.noarch.rpm       | 187 kB     00:00     
(11/14): selinux-policy-devel-3.10.0-145.fc17.noarch.rpm | 1.3 MB     00:00     
(12/14): selinux-policy-targeted-3.10.0-145.fc17.noarch. | 3.7 MB     00:01     
(13/14): setools-libs-3.3.7-24.fc17.x86_64.rpm           | 403 kB     00:00     
(14/14): setools-libs-python-3.3.7-24.fc17.x86_64.rpm    | 221 kB     00:00     
--------------------------------------------------------------------------------
Total                                           570 kB/s | 7.5 MB     00:13     
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : policycoreutils-2.1.11-18.fc17.x86_64                       1/17 
  Updating   : selinux-policy-3.10.0-145.fc17.noarch                       2/17 
  Installing : selinux-policy-devel-3.10.0-145.fc17.noarch                 3/17 
  Updating   : selinux-policy-targeted-3.10.0-145.fc17.noarch              4/17 
  Installing : setools-libs-3.3.7-24.fc17.x86_64                           5/17 
  Installing : setools-libs-python-3.3.7-24.fc17.x86_64                    6/17 
  Installing : libcgroup-0.38-1.fc17.x86_64                                7/17 
  Installing : audit-libs-python-2.2.1-1.fc17.x86_64                       8/17 
  Installing : libselinux-python-2.1.10-3.fc17.x86_64                      9/17 
  Installing : 1:make-3.82-9.fc17.x86_64                                  10/17 
  Installing : libsemanage-python-2.1.6-3.fc17.x86_64                     11/17 
  Installing : python-IPy-0.75-2.fc17.noarch                              12/17 
  Installing : policycoreutils-python-2.1.11-18.fc17.x86_64               13/17 
  Installing : pulp-selinux-0.0.323-1.fc17.noarch                         14/17 
Traceback (most recent call last):
  File "/usr/sbin/semanage", line 566, in <module>
    trans.finish()
  File "/usr/lib64/python2.7/site-packages/seobject.py", line 285, in finish
    self.commit()
  File "/usr/lib64/python2.7/site-packages/seobject.py", line 274, in commit
    semanage_set_reload(self.sh, self.reload)
TypeError: in method 'semanage_set_reload', argument 2 of type 'int'
  Cleanup    : selinux-policy-targeted-3.10.0-121.fc17.noarch             15/17 
  Cleanup    : selinux-policy-3.10.0-121.fc17.noarch                      16/17 
  Cleanup    : policycoreutils-2.1.11-6.fc17.x86_64                       17/17 
Non-fatal POSTTRANS scriptlet failure in rpm package pulp-selinux-0.0.323-1.fc17.noarch
  Verifying  : pulp-selinux-0.0.323-1.fc17.noarch                          1/17 
  Verifying  : python-IPy-0.75-2.fc17.noarch                               2/17 
  Verifying  : libsemanage-python-2.1.6-3.fc17.x86_64                      3/17 
  Verifying  : 1:make-3.82-9.fc17.x86_64                                   4/17 
  Verifying  : policycoreutils-python-2.1.11-18.fc17.x86_64                5/17 
  Verifying  : setools-libs-python-3.3.7-24.fc17.x86_64                    6/17 
  Verifying  : selinux-policy-devel-3.10.0-145.fc17.noarch                 7/17 
  Verifying  : selinux-policy-3.10.0-145.fc17.noarch                       8/17 
  Verifying  : policycoreutils-2.1.11-18.fc17.x86_64                       9/17 
  Verifying  : libselinux-python-2.1.10-3.fc17.x86_64                     10/17 
  Verifying  : audit-libs-python-2.2.1-1.fc17.x86_64                      11/17 
  Verifying  : libcgroup-0.38-1.fc17.x86_64                               12/17 
  Verifying  : selinux-policy-targeted-3.10.0-145.fc17.noarch             13/17 
  Verifying  : setools-libs-3.3.7-24.fc17.x86_64                          14/17 
  Verifying  : selinux-policy-targeted-3.10.0-121.fc17.noarch             15/17 
  Verifying  : selinux-policy-3.10.0-121.fc17.noarch                      16/17 
  Verifying  : policycoreutils-2.1.11-6.fc17.x86_64                       17/17 

Installed:
  pulp-selinux.noarch 0:0.0.323-1.fc17                                          

Dependency Installed:
  audit-libs-python.x86_64 0:2.2.1-1.fc17                                       
  libcgroup.x86_64 0:0.38-1.fc17                                                
  libselinux-python.x86_64 0:2.1.10-3.fc17                                      
  libsemanage-python.x86_64 0:2.1.6-3.fc17                                      
  make.x86_64 1:3.82-9.fc17                                                     
  policycoreutils-python.x86_64 0:2.1.11-18.fc17                                
  python-IPy.noarch 0:0.75-2.fc17                                               
  selinux-policy-devel.noarch 0:3.10.0-145.fc17                                 
  setools-libs.x86_64 0:3.3.7-24.fc17                                           
  setools-libs-python.x86_64 0:3.3.7-24.fc17                                    

Dependency Updated:
  policycoreutils.x86_64 0:2.1.11-18.fc17                                       
  selinux-policy.noarch 0:3.10.0-145.fc17                                       
  selinux-policy-targeted.noarch 0:3.10.0-145.fc17                              

Complete!
[root@pulp-master ~]# 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Sayli Karmarkar 2012-10-02 15:30:09 EDT
This is because of a bug in policycoreutil package in F17. See  https://bugzilla.redhat.com/show_bug.cgi?id=836087 for details. It seems to be fixed in policycoreutils-2.1.11-19.1.fc17.x86_64, but the package is not yet available in fedora updates.

$ rpm -q policycoreutils
policycoreutils-2.1.11-18.fc17.x86_64

$ sudo yum update policycoreutils
Loaded plugins: langpacks, presto, pulp-profile-update, refresh-packagekit
No Packages marked for Update
Comment 3 Sayli Karmarkar 2012-10-17 12:54:34 EDT
*** Bug 864110 has been marked as a duplicate of this bug. ***
Comment 4 Sayli Karmarkar 2012-11-12 01:53:30 EST
Tried with latest policycoreutils which fixes above mentioned blocker. Error mentioned in the original bug is gone, but still seeing POSTTRANS scriptlet failure when installing pulp-selinux. Install is successful. 


# yum install pulp-selinux
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package pulp-selinux.noarch 0:0.0.335-1.fc17 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================================================================
 Package                             Arch                          Version                               Repository                              Size
======================================================================================================================================================
Installing:
 pulp-selinux                        noarch                        0.0.335-1.fc17                        pulp-v2-testing                         67 k

Transaction Summary
======================================================================================================================================================
Install  1 Package

Total download size: 67 k
Installed size: 65 k
Is this ok [y/N]: y
Downloading Packages:
pulp-selinux-0.0.335-1.fc17.noarch.rpm                                                                                         |  67 kB     00:00     
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : pulp-selinux-0.0.335-1.fc17.noarch                                                                                                 1/1 
Non-fatal POSTTRANS scriptlet failure in rpm package pulp-selinux-0.0.335-1.fc17.noarch
  Verifying  : pulp-selinux-0.0.335-1.fc17.noarch                                                                                                 1/1 

Installed:
  pulp-selinux.noarch 0:0.0.335-1.fc17                                                                                                                

Complete!


I am not able to find any errors in logs -

 Nov 12 01:49:49 pulpserver-fedora17 dbus[445]: avc:  received policyload notice (seqno=10)
Nov 12 01:49:49 pulpserver-fedora17 dbus[587]: avc:  received policyload notice (seqno=10)
Nov 12 01:49:49 pulpserver-fedora17 dbus[587]: [system] Reloaded configuration
Nov 12 01:49:49 pulpserver-fedora17 dbus-daemon[587]: dbus[587]: avc:  received policyload notice (seqno=10)
Nov 12 01:49:49 pulpserver-fedora17 dbus-daemon[587]: dbus[587]: [system] Reloaded configuration
Nov 12 01:49:49 pulpserver-fedora17 kernel: [206710.899629] SELinux:  Permission wake_alarm in class capability2 not defined in policy.
Nov 12 01:49:49 pulpserver-fedora17 kernel: [206710.899631] SELinux:  Permission block_suspend in class capability2 not defined in policy.
Nov 12 01:49:49 pulpserver-fedora17 kernel: [206710.899634] SELinux: the above unknown classes and permissions will be allowed
Nov 12 01:49:49 pulpserver-fedora17 kernel: [206711.084886] SELinux:  Context system_u:object_r:pulp_cert_t:s0 became valid (mapped).
Nov 12 01:49:50 pulpserver-fedora17 dbus[445]: avc:  received policyload notice (seqno=11)
Nov 12 01:49:50 pulpserver-fedora17 dbus-daemon[587]: dbus[587]: avc:  received policyload notice (seqno=11)
Nov 12 01:49:50 pulpserver-fedora17 dbus[587]: avc:  received policyload notice (seqno=11)
Nov 12 01:49:50 pulpserver-fedora17 dbus-daemon[587]: dbus[587]: [system] Reloaded configuration
Nov 12 01:49:50 pulpserver-fedora17 dbus[587]: [system] Reloaded configuration
Nov 12 01:49:51 pulpserver-fedora17 yum[6082]: Installed: pulp-selinux-0.0.335-1.fc17.noarch
Comment 5 Sayli Karmarkar 2012-11-28 07:24:45 EST
Updated selinux to latest pulp layout. Installation and un-installation runs without any posttrans errors now.

[root@pulpserver-fedora17 ~]# yum install pulp-selinux-2.0.6-0.9.beta.git.25.f5d23d7.noarch.rpm
Loaded plugins: langpacks, presto, refresh-packagekit
Examining pulp-selinux-2.0.6-0.9.beta.git.25.f5d23d7.noarch.rpm: pulp-selinux-2.0.6-0.9.beta.git.25.f5d23d7.noarch
Marking pulp-selinux-2.0.6-0.9.beta.git.25.f5d23d7.noarch.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package pulp-selinux.noarch 0:2.0.6-0.9.beta.git.25.f5d23d7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================================================================
 Package                Arch             Version                                   Repository                                                    Size
======================================================================================================================================================
Installing:
 pulp-selinux           noarch           2.0.6-0.9.beta.git.25.f5d23d7             /pulp-selinux-2.0.6-0.9.beta.git.25.f5d23d7.noarch            65 k

Transaction Summary
======================================================================================================================================================
Install  1 Package

Total size: 65 k
Installed size: 65 k
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : pulp-selinux-2.0.6-0.9.beta.git.25.f5d23d7.noarch                                                                                  1/1 
  Verifying  : pulp-selinux-2.0.6-0.9.beta.git.25.f5d23d7.noarch                                                                                  1/1 

Installed:
  pulp-selinux.noarch 0:2.0.6-0.9.beta.git.25.f5d23d7                                                                                                 

Complete!
[root@pulpserver-fedora17 ~]#
Comment 6 Jeff Ortel 2013-02-05 15:57:12 EST
build: 2.1.0-0.3.alpha
Comment 7 Preethi Thomas 2013-02-28 17:24:56 EST
verified

pulp-selinux gets installed with pulp-server


[root@preethi ~]# rpm -q pulp-selinux
pulp-selinux-2.1.0-0.18.alpha.noarch
[root@preethi ~]# rpm -q pulp-server
pulp-server-2.1.0-0.18.alpha.noarch
[root@preethi ~]#
Comment 8 Preethi Thomas 2013-04-08 12:03:20 EDT
Pulp 2.1 released 


http://www.pulpproject.org/2013/04/05/pulp-2-1-0-released/

Note You need to log in before you can comment on or make changes to this bug.