Bug 837027 - Reference to "Pool" should be changed to "cloud resource zone"
Reference to "Pool" should be changed to "cloud resource zone"
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity low
: beta2
: ---
Assigned To: Matt Wagner
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 10:40 EDT by Rehana
Modified: 2012-12-04 10:12 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
"Pool Quota Used" displayed, which was an incorrect string translation for "Cloud Resource Zone Quota Used". This bug fix corrects the string translation and Cloud Engine correctly displays "Cloud Resource Zone Quota Used" where necessary.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:12:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Quota_used (206.84 KB, image/png)
2012-07-02 10:40 EDT, Rehana
no flags Details
pool (38.42 KB, image/png)
2012-09-25 08:59 EDT, Aziza Karol
no flags Details

  None (edit)
Description Rehana 2012-07-02 10:40:55 EDT
Created attachment 595750 [details]
Quota_used

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Login to conductor
2.Click on "default" CRZ

  
Actual results:
Observed that "Pool Quota Used " was displayed (PFA: Quota_used.png)

Expected results:
Should be changed to "Cloud resource zone quota used "


Additional info:
rpm -qa | grep aeolus
aeolus-configure-2.5.10-1.el6cf.noarch
aeolus-all-0.8.34-1.el6cf.noarch
aeolus-conductor-doc-0.8.34-1.el6cf.noarch
aeolus-conductor-daemons-0.8.34-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.3-2.el6_2.noarch
aeolus-conductor-0.8.34-1.el6cf.noarch
Comment 1 Rehana 2012-07-03 07:44:28 EDT
Observation 2:

Instance property also displays 'Pool' instead of 'cloud resource zone' (PFA:ss2.png)

Expected results:
Should be changed to "Cloud resource zone"

on

rpm -qa | grep aeolus
aeolus-configure-2.5.10-1.el6cf.noarch
aeolus-all-0.8.34-1.el6cf.noarch
aeolus-conductor-doc-0.8.34-1.el6cf.noarch
aeolus-conductor-daemons-0.8.34-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.3-2.el6_2.noarch
aeolus-conductor-0.8.34-1.el6cf.noarch
Comment 2 Dave Johnson 2012-09-17 16:03:16 EDT
reopened... still there with CFCE v1.1 2012-09-14.5 puddle

[root@hp-bl685cg6-01 data]# rpm -qa | grep aeolus | sort
aeolus-all-0.13.7-1.el6cf.noarch
aeolus-conductor-0.13.7-1.el6cf.noarch
aeolus-conductor-daemons-0.13.7-1.el6cf.noarch
aeolus-conductor-doc-0.13.7-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
Comment 3 Matt Wagner 2012-09-19 14:40:31 EDT
This is a series of things being done wrong.

Because it's string freeze, I'm going to do a quick-fix for this.

https://bugzilla.redhat.com/show_bug.cgi?id=858827 should be addressed post-1.1 as the "real" fix here.
Comment 5 Tzu-Mainn Chen 2012-09-19 16:47:44 EDT
Pushed to 1.1:

commit 4eea9f7aaf7a002419c8bfcb0b81774e9b608337
Author: Matt Wagner <matt.wagner@redhat.com>
Date:   Wed Sep 19 16:45:24 2012 -0400

    BZ 837027 - Pool to Cloud Resource Zone fix
    
    We were referencing a non-existent string, causing "Pool" to be
    displayed as a missing translation -- thus it didn't get converted
    to product names.
    
    The way we are joining these two strings rather than using a new
    string is broken but out of scope. I entered #858827 for that.
    
    This resolves https://bugzilla.redhat.com/show_bug.cgi?id=837027
    
    Signed-off-by: Tzu-Mainn Chen <tzumainn@redhat.com>
Comment 7 Aziza Karol 2012-09-25 08:47:43 EDT
Cloud Resource Zone Quota Used is displayed.

verified:
rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.2-1.el6cf.noarch
aeolus-conductor-doc-0.13.14-1.el6cf.noarch
aeolus-configure-2.8.7-1.el6cf.noarch
aeolus-all-0.13.14-1.el6cf.noarch
aeolus-conductor-0.13.14-1.el6cf.noarch
aeolus-conductor-daemons-0.13.14-1.el6cf.noarch
Comment 8 Aziza Karol 2012-09-25 08:58:57 EDT
Instance property still displays 'Pool' instead of 'cloud resource zone'.
see attached screnshot.

#rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.2-1.el6cf.noarch
aeolus-conductor-doc-0.13.14-1.el6cf.noarch
aeolus-configure-2.8.7-1.el6cf.noarch
aeolus-all-0.13.14-1.el6cf.noarch
aeolus-conductor-0.13.14-1.el6cf.noarch
aeolus-conductor-daemons-0.13.14-1.el6cf.noarch
Comment 9 Aziza Karol 2012-09-25 08:59:46 EDT
Created attachment 617016 [details]
pool
Comment 10 Tzu-Mainn Chen 2012-09-25 09:13:30 EDT
This is a separate issue; it should be tracked in a different BZ
Comment 11 Dave Johnson 2012-09-25 10:56:35 EDT
opened 860314 to track the issue in comment 8 & 9

verified per comment 7
Comment 13 errata-xmlrpc 2012-12-04 10:12:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.