Bug 837040 - upsdrvctl put in /sbin in nut update but nut-driver.service refers to /usr/sbin/upsdrvctl
upsdrvctl put in /sbin in nut update but nut-driver.service refers to /usr/sb...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nut (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
: 838192 839019 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 11:02 EDT by gdelx001
Modified: 2012-07-17 13:19 EDT (History)
5 users (show)

See Also:
Fixed In Version: nut-2.6.4-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 13:19:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gdelx001 2012-07-02 11:02:32 EDT
Description of problem:

Can't start nut ups monitoring after latest update because 
upsdrvctl was put in /sbin but nut-driver.service refers to /usr/sbin/upsdrvctl.

Version-Release number of selected component (if applicable):
2.6.4-1.fc16

How reproducible:
Imminently


Additional info:

Link from /usr/sbin/ to /sbin/upsdrvctl solves problem.  I assume that fixing the exec definition in /lib/systemd/system/nut-driver.service would work as well.
Comment 1 Michal Hlavinka 2012-07-02 11:24:56 EDT
Right, this path is generated build script, but it should be @driveexecdir@ instead of @SBINDIR@. This bug is in 
systemd/system/nut-driver.service
and
systemd/system-shutdown/nutshutdown


I'll fix that.
Comment 2 Fedora Update System 2012-07-02 11:54:30 EDT
nut-2.6.4-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/nut-2.6.4-2.fc16
Comment 3 Fedora Update System 2012-07-05 19:35:46 EDT
Package nut-2.6.4-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nut-2.6.4-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10277/nut-2.6.4-2.fc16
then log in and leave karma (feedback).
Comment 4 Michal Hlavinka 2012-07-16 08:10:27 EDT
*** Bug 838192 has been marked as a duplicate of this bug. ***
Comment 5 Michal Hlavinka 2012-07-16 08:17:14 EDT
*** Bug 839019 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2012-07-17 13:19:00 EDT
nut-2.6.4-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.