Bug 838654 - sanlock: fixes for vdsm
sanlock: fixes for vdsm
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sanlock (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: David Teigland
Yaniv Kaul
:
Depends On: 837095
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 13:35 EDT by David Teigland
Modified: 2014-07-01 08:00 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-18 15:19:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Teigland 2012-07-09 13:35:01 EDT
Description of problem:

There are a number of patches that have been added in the course of making sanlock work for vdsm.  They are all fairly minor, and I'd like to use this one bz for all of them:

8910c06 daemon: fix inquire lver
fee5d9c sanlock: WAIT flag for sanlock_inq_lockspace
85de31c daemon: fix add_lockspace that has been removed
f179f84 daemon: don't put struct space on stack
cffb305 daemon: skip setup_groups when no -U or -G
b6dc3c7 wdmd: load the softdog module when needed
6cead33 init: make explicit to run sanlock as root
e25453c sanlock/wdmd: use /var/log/subsys/file


There will be more sanlock updates like this as vdsm/sanlock integration moves further along.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 David Teigland 2012-07-09 14:05:40 EDT
*** Bug 832935 has been marked as a duplicate of this bug. ***
Comment 3 Yaniv Kaul 2012-07-09 16:34:07 EDT
Not sure what needs to be tested here.
CodeChange BZ perhaps?
Comment 4 David Teigland 2012-07-09 17:36:46 EDT
*** Bug 830848 has been marked as a duplicate of this bug. ***
Comment 5 David Teigland 2012-07-09 17:42:18 EDT
*** Bug 831906 has been marked as a duplicate of this bug. ***
Comment 6 David Teigland 2012-07-09 17:51:38 EDT
For testing:

8910c06 daemon: fix inquire lver
* Any pause/resume or migrate will test this. 

fee5d9c sanlock: WAIT flag for sanlock_inq_lockspace
85de31c daemon: fix add_lockspace that has been removed
f179f84 daemon: don't put struct space on stack
* these are all related to vdsm adding lockspaces, Federico has specifics

cffb305 daemon: skip setup_groups when no -U or -G
* sysconfig/sanlock SANLOCKOPTS="-w 0" (which is not supported)
* bz 831906 addresses this

b6dc3c7 wdmd: load the softdog module when needed
* start wdmd and sanlock without first loading a watchdog module
* bz 832935 addresses this

6cead33 init: make explicit to run sanlock as root
* use sanlock with leases on shared storage and nfs to test

e25453c sanlock/wdmd: use /var/log/subsys/file
* bz 830848 addresses this, includes steps to reproduce
Comment 7 David Teigland 2012-07-09 17:53:51 EDT
*** Bug 830736 has been marked as a duplicate of this bug. ***
Comment 8 David Teigland 2012-07-18 15:19:06 EDT
All the real bugs have their own bz's, so closing this consolidation bug.

Note You need to log in before you can comment on or make changes to this bug.