Bug 832935 - sanlock: softdog module should be loaded in case no watchdog driver was loaded
sanlock: softdog module should be loaded in case no watchdog driver was loaded
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sanlock (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: David Teigland
Rami Vaknin
: Reopened, ZStream
: 832056 (view as bug list)
Depends On:
Blocks: 773665 840955 906027
  Show dependency treegraph
 
Reported: 2012-06-18 04:41 EDT by Rami Vaknin
Modified: 2016-04-26 09:57 EDT (History)
9 users (show)

See Also:
Fixed In Version: sanlock-2.5-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:52:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rami Vaknin 2012-06-18 04:41:21 EDT
Version:
sanlock 2.3.1

wdmd service fails to start if it can find a watchdog device, hence sanlock service fails to start too since wdmd is its dependency.

It will be best to load the softdog module in case there is no loaded watchdog driver, as a dependency for wdmd service.

From /var/log/messages:
Jun 13 17:44:06 localhost sanlock[2682]: 2012-06-13 17:44:06+0300 112156 [2682]: wdmd connect failed for watchdog handling
Comment 1 Federico Simoncelli 2012-06-18 04:46:30 EDT
A fix has been proposed and committed upstream:

https://fedorahosted.org/pipermail/sanlock-devel/2012-June/000197.html

commit b6dc3c761c75a0411a607544a1b76955dbe9a1a7
Author: Federico Simoncelli <fsimonce@redhat.com>
Date:   Thu Jun 14 09:41:12 2012 +0000

    wdmd: load the softdog module when needed
    
    Signed-off-by: Federico Simoncelli <fsimonce@redhat.com>
Comment 3 David Teigland 2012-07-09 14:05:40 EDT

*** This bug has been marked as a duplicate of bug 838654 ***
Comment 4 David Teigland 2012-07-13 11:27:26 EDT
deconsolidating
Comment 6 David Teigland 2012-07-26 17:10:28 EDT
*** Bug 832056 has been marked as a duplicate of this bug. ***
Comment 7 Douglas Schilling Landgraf 2012-07-27 15:10:57 EDT
Hi David, 

      Which version of sanlock this bug has been fixed? 

Tested with the following packages and still occurs:
sanlock-lib-2.3-3.fc17.x86_64
sanlock-python-2.3-3.fc17.x86_64
libvirt-lock-sanlock-0.9.11.4-3.fc17.x86_64
sanlock-2.3-3.fc17.x86_64


Thanks!
Comment 8 Douglas Schilling Landgraf 2012-07-27 15:16:50 EDT
Sorry, I must say that I am using Fedora 17 (oVirt Node), do we have a bugzilla for fedora ?
Should I open a bz for Fedora?

Thanks
Douglas
Comment 9 David Teigland 2012-07-27 15:18:26 EDT
f17 is sanlock-2.4-2.fc17
http://koji.fedoraproject.org/koji/buildinfo?buildID=343839

rhel6 is sanlock-2.3-3.el6_3
https://brewweb.devel.redhat.com/buildinfo?buildID=223507
Comment 10 Douglas Schilling Landgraf 2012-07-27 15:37:36 EDT
Thanks David!
Comment 12 Rami Vaknin 2012-11-08 10:20:38 EST
Verified on RHEL6.3 with sanlock-2.5-1.el6.x86_64

I rmmod the softdog kernel module after stopping sanlock and wdmd services. The softdog kernel module was loaded automatically while stating the wdmd service.
Comment 13 Leonid Natapov 2012-12-17 09:59:26 EST
sanlock-2.6-2.el6.x86_64 same behavior as 2.5-1.
Comment 15 errata-xmlrpc 2013-02-21 03:52:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0530.html

Note You need to log in before you can comment on or make changes to this bug.