This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 840063 - sanlock: fix inquire lver
sanlock: fix inquire lver
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sanlock (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: David Teigland
Haim
: ZStream
Depends On:
Blocks: 841995 906027
  Show dependency treegraph
 
Reported: 2012-07-13 11:29 EDT by David Teigland
Modified: 2016-04-26 10:59 EDT (History)
4 users (show)

See Also:
Fixed In Version: sanlock-2.5-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:53:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Teigland 2012-07-13 11:29:46 EDT
Description of problem:

The lver returned from inquire was always 0.
Any pause/resume or migrate will hit this.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 David Teigland 2012-07-17 10:55:48 EDT
To validate, you need to either migrate or suspend/resume the vm.  Both of those operations would fail if the lver (leader version) is incorrect.

(At a less practical, micro level, you can run: sanlock client inquire -p <pid> where pid is the pid of a vm.  The output string ends with :<lver> which should be a positive integer, not 0.)
Comment 5 Leonid Natapov 2012-12-17 11:26:54 EST
sanlock-2.6-2.el6.x86_64. successfully migrated VMs.
Comment 7 errata-xmlrpc 2013-02-21 03:53:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0530.html

Note You need to log in before you can comment on or make changes to this bug.