Bug 84097 - DRM crash with i845G
Summary: DRM crash with i845G
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 102551 (view as bug list)
Depends On:
Blocks: 79578 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-02-12 04:21 UTC by Bill Nottingham
Modified: 2014-03-17 02:34 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-19 21:32:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config (3.06 KB, text/plain)
2003-02-12 04:21 UTC, Bill Nottingham
no flags Details

Description Bill Nottingham 2003-02-12 04:21:02 UTC
Start X. Switch VTs before it gets very far in initializing (say, when GDM is in
a busy state before it starts up.)

X crashes.

Errors in messages are:

[drm:i830_wait_ring] *ERROR* space: 131048 wanted 131064
[drm:i830_wait_ring] *ERROR* lockup

Comment 1 Bill Nottingham 2003-02-12 04:21:43 UTC
Created attachment 90020 [details]
XF86Config

Comment 2 Mike A. Harris 2003-02-14 23:10:29 UTC
Does this still happen Bill?

Comment 3 Bill Nottingham 2003-02-14 23:59:47 UTC
Yes.

Comment 4 Mike A. Harris 2003-02-21 20:37:07 UTC
I sent Arjan and Alan the latest DRM which might possibly fix this.  Assuming
the changes get into our kernel before final release, could you test them?

Arjan, if you add it in, please let us know what build to test.

Comment 5 Mike A. Harris 2003-02-24 10:18:52 UTC
Correction, these DRM changes did not get into the kernel, and wont be.

Intel DRI is broken and will remain broken in our final release.

Deferring for a future release of Red Hat Linux.

Comment 7 Bill Nottingham 2003-03-15 04:04:07 UTC
Don't have the machine in front of me. Owen, can you reproduce this on the final
relase? :)

Comment 8 Bill Nottingham 2003-07-28 22:37:26 UTC
This happens with i865 in Severn, FWIW.

Comment 9 Bill Nottingham 2003-08-18 01:34:47 UTC
*** Bug 102551 has been marked as a duplicate of this bug. ***

Comment 10 Mike A. Harris 2003-08-21 12:34:31 UTC
Dave, are you aware of this problem at all?  Started in 4.3.0, and occurs
aparently on most i830 and higher hardware aparently.

IMHO, it's kernel DRM bug from the messages.  Others say this only occurs
with the Red Hat kernel, not stock 4.3.0 DRM.  DRI-CVS DRM reportedly also
works.  Should I reassign to kernel for a DRM update?


Comment 13 Ben Hsu 2003-12-10 02:00:31 UTC
I have an 845 (I think 845G), and I saw this in Severn. It does not
happen in Yarrow. It does not reproduce with either the 2.6.0-test9
kernel from Arjan, nor the 2.4 kernel shipped default with Yarrow.

Comment 14 Mike A. Harris 2004-05-05 15:37:38 UTC
I believe this bug is now fixed with our latest kernel update in
rawhide.  Arjan has fixed several bugs in the i810/i830 DRM code,
which has many people reporting they no longer experience i8xx
lockups.  Bug #119311 has a bit more details about which specific
kernel to try.

Changing bug state to MODIFIED.  Please test and confirm wether the
problem is fixed or not, setting the bug to RAWHIDE if fixed, or
to ASSIGNED if it is still present.

Thanks in advance.

Comment 15 Bill Nottingham 2004-05-19 21:32:20 UTC
Closing. If it comes back, it should probably get a new bug report.


Note You need to log in before you can comment on or make changes to this bug.