Bug 841803 - [abrt] Zim-0.56-3.fc17: pageindex.py:604:do_drag_data_received:TypeError: 'NoneType' object is not iterable
[abrt] Zim-0.56-3.fc17: pageindex.py:604:do_drag_data_received:TypeError: 'No...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robin Lee
Fedora Extras Quality Assurance
abrt_hash:a1ead3d5032a4559deab679dbdb...
:
: 829768 895271 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 05:23 EDT by Robert Keersse
Modified: 2013-02-04 22:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-04 22:14:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 905226 None None None 2012-07-24 05:35:39 EDT

  None (edit)
Description Robert Keersse 2012-07-20 05:23:17 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python /usr/bin/zim
executable:     /usr/bin/zim
kernel:         3.4.4-5.fc17.x86_64
time:           vr 20 jul 2012 10:56:55 CEST
uid:            1000
username:       robert

backtrace:
:pageindex.py:604:do_drag_data_received:TypeError: 'NoneType' object is not iterable
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageindex.py", line 604, in do_drag_data_received
:    treepath, position = self.get_dest_row_at_pos(x, y)
:TypeError: 'NoneType' object is not iterable
:
:Local variables in innermost frame:
:info: 2
:dragcontext: <gtk.gdk.DragContext object at 0x2396f50 (GdkDragContext at 0x245a310)>
:selectiondata: <GtkSelectionData at 0x7ffff4864c60>
:self: <PageTreeView object at 0x7fbc7978fc80 (zim+gui+pageindex+PageTreeView at 0x22220c0)>
:source: <Path: Calendar:dedi>
:names: [u'Calendar:dedi']
:time: 41852870
:y: 214
:x: 75

smolt_data:
:
:
:General
:=================================
:UUID: 76362972-699b-4506-b771-6cf608998c82
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 5382.24
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2620M CPU @ 2.70GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 2701
:System Memory: 7870
:System Swap: 9919
:Vendor: LENOVO
:System: 4236NGG ThinkPad T420
:Form factor: Notebook
:Kernel: 3.4.4-5.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:7247:6058:8654) pci, None, PCI/ISA, QM67 Express Chipset Family LPC Controller
:(4480:59426:6058:8499) pci, sdhci-pci, BASE, MMC/SD Host Controller
:(32902:294:6058:8654) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:6058:8654) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:6058:8654) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:6058:8654) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7192:6058:8654) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 5
:(32902:7200:6058:8654) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:5378:6058:8654) pci, e1000e, ETHERNET, 82579LM Gigabit Network Connection
:(32902:7213:6058:8654) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7202:6058:8654) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:16952:32902:4369) pci, iwlwifi, NETWORK, Centrino Ultimate-N 6300 3x3 AGN
:(32902:7171:6058:8654) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7229:6058:8654) pci, serial, 16550_SERIAL, 6 Series/C200 Series Chipset Family KT Controller
:(32902:7206:6058:8654) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:6058:8654) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:6058:8654) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg-lv_root / ext4 4096 4096 7966676 5266106 4866746 1998848 1653793 1653793
:/dev/sda2 /boot ext4 1024 1024 508644 393085 367485 128016 127979 127979
:/dev/sda1 WITHHELD vfat 4096 4096 51145 51080 51080 0 0 0
:/dev/mapper/vg-lv_home /home ext4 4096 4096 47835961 27532815 25137884 11976704 11896939 11896939
:
Comment 1 Robin Lee 2012-07-24 05:34:26 EDT
*** Bug 829768 has been marked as a duplicate of this bug. ***
Comment 2 jibecfed 2012-10-04 14:23:17 EDT
moving a 1st level page as a subpage

Package: Zim-0.56-3.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 3 Robin Lee 2013-01-14 20:55:06 EST
*** Bug 895271 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2013-01-24 08:15:37 EST
Zim-0.59-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/Zim-0.59-1.fc17
Comment 5 Fedora Update System 2013-01-25 16:30:18 EST
Package Zim-0.59-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing Zim-0.59-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1478/Zim-0.59-1.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-02-04 22:14:57 EST
Zim-0.59-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.