Bug 842866 - Remove PyXML dep
Remove PyXML dep
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openstack-nova (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pádraig Brady
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 843176
  Show dependency treegraph
 
Reported: 2012-07-24 14:40 EDT by Toshio Ernie Kuratomi
Modified: 2016-01-04 09:40 EST (History)
17 users (show)

See Also:
Fixed In Version: openstack-nova-2012.2-0.5.f3.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 851687 (view as bug list)
Environment:
Last Closed: 2012-09-27 04:58:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshio Ernie Kuratomi 2012-07-24 14:40:40 EDT
Description of problem:
We're trying to remove PyXML from Fedora 18 due to it being dead upstream and having the dubious behaviour of replacing the python stdlib's xml module with its own code.  https://fedoraproject.org/wiki/User:Toshio/Remove_PyXML

I've taken a look at python-nova's use of PyXML and I think we can just remove the dep.  No documentation mentions a PyXML requirement.  The code uses xml.dom.minidom and xml.parsers.expat which are both present in the python stdlib and lxml which is in the python-lxml package.
Comment 1 Pádraig Brady 2012-07-24 15:43:36 EDT
cool, I'll remove that so (after doing my own checks)
Comment 2 Pádraig Brady 2012-09-27 04:58:38 EDT
This dependency is now removed in Fedora 17 and 18

Note You need to log in before you can comment on or make changes to this bug.