Bug 851687 - Remove PyXML dep
Remove PyXML dep
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-quantumclient (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alan Pevec
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 843176
  Show dependency treegraph
 
Reported: 2012-08-24 13:28 EDT by Alan Pevec
Modified: 2013-01-11 15:03 EST (History)
4 users (show)

See Also:
Fixed In Version: python-quantumclient-2.0-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 842866
Environment:
Last Closed: 2013-01-11 15:03:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Pevec 2012-08-24 13:28:56 EDT
My deps analysis script made me mindlessly introduce PyXML dep in the last quantumclient update http://pkgs.fedoraproject.org/cgit/python-quantumclient.git/commit/?id=9658a2a03c807b49f8665c6a6a1cfe92739e345e

Having a look at the code, it's the same situation like in Nova, only xml.dom.minidom is used in quantumclient.common.serializer so PyXML dep can be dropped.

+++ This bug was initially created as a clone of Bug #842866 +++

Description of problem:
We're trying to remove PyXML from Fedora 18 due to it being dead upstream and having the dubious behaviour of replacing the python stdlib's xml module with its own code.  https://fedoraproject.org/wiki/User:Toshio/Remove_PyXML
Comment 1 Toshio Ernie Kuratomi 2013-01-11 14:59:09 EST
Hi, I've opened an F19 feature to have PyXML removed from the distribution.  Would it be okay with you if I remove the Requires: PyXML from the quantumclient package and rebuild it for F19/rawhide?  If I don't hear back from you, I'll go ahead and do that after FUDCon (~ 1.5 weeks from now).
Comment 2 Toshio Ernie Kuratomi 2013-01-11 15:03:52 EST
Actually, I see that the dep was removed in 1:2.0-2.  Closing this bug fixed rawhide.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.