Bug 846724 - RFE: Pick up and use kickstart files from persistent storage on a usb key
RFE: Pick up and use kickstart files from persistent storage on a usb key
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 876032 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 10:17 EDT by Jóhann B. Guðmundsson
Modified: 2013-06-20 21:42 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 21:42:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2012-08-08 10:17:10 EDT
Description of problem:

The general use case is for administrator that need to go onside to clients to install/setup Fedora/RHEL. 

The idea in steps

1. Administrators creates an install usb key with persistent storage
2. Administrator creates and copy's the kick start file(s) to the persistent storage space on the usb key. 
3. Administrator goes on site and boots into the installer. 
4. Anaconda reads the content of the relevant persistent storage space and offers the administrator to choose kickstart file to install from withing the UI.

Although not tested I assume this works already with "ks" from the kernel command line with either ks=file:<path> or ks=hd:<dev>:<path> 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2012-11-13 09:14:46 EST
*** Bug 876032 has been marked as a duplicate of this bug. ***
Comment 2 satellitgo 2012-11-13 10:35:53 EST
will this work with f18 Anaconda Beta DVD? Has anyone written a wiki page on how to do this?
Comment 3 Andre Robatino 2013-05-08 13:34:56 EDT
Any idea when this will happen? At this point it would make sense to just dump floppy support and substitute usb keys.
Comment 4 Adam Williamson 2013-06-08 00:47:08 EDT
ks deployment from arbitrary mountable block devices is already supposed to work: see https://fedoraproject.org/wiki/Anaconda_Boot_Options#ks , "ks=hd:<dev>:<path> (dev = 'hda1', for example)".
Comment 5 Andre Robatino 2013-06-09 05:10:56 EDT
(In reply to Adam Williamson from comment #4)
> ks deployment from arbitrary mountable block devices is already supposed to
> work: see https://fedoraproject.org/wiki/Anaconda_Boot_Options#ks ,
> "ks=hd:<dev>:<path> (dev = 'hda1', for example)".

It seems to work with recent images: I have a thumb drive which is mounted as sdb4 which had a partial kickstart file ks.cfg, so I booted the 19 Final TC2 i386 DVD in a VirtualBox guest, using "inst.ks=hd:sdb4:/ks.cfg". The resulting behavior is exactly the same as that noted in bug 972265 and bug 972266, so it appears to work the same as if the kickstart file was downloaded. (It did NOT work when I booted the F18 DVD, so the support must be more recent.)

Note that most thumb drives are mounted as sdb1, mine was sdb4 due to being reformatted for USB-ZIP compatibility.
Comment 6 Brian Lane 2013-06-20 21:42:55 EDT
You should also be able to use the UUID or LABEL so that you don't need to know what device it showed up as.

Note You need to log in before you can comment on or make changes to this bug.