Bug 972265 - When using a kickstart that specifies nothing about repo, 'closest mirror' doesn't seem to be usable
When using a kickstart that specifies nothing about repo, 'closest mirror' do...
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All All
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: CommonBugs
: 948219 (view as bug list)
Depends On:
Blocks: fedora19rtt F21FinalFreezeException
  Show dependency treegraph
Reported: 2013-06-08 00:12 EDT by Adam Williamson
Modified: 2017-07-31 13:16 EDT (History)
12 users (show)

See Also:
Fixed In Version: anaconda-21.48.10-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2014-10-20 19:01:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
anaconda.log (20.78 KB, text/plain)
2013-06-08 00:17 EDT, Adam Williamson
no flags Details
program.log (45.17 KB, text/plain)
2013-06-08 00:18 EDT, Adam Williamson
no flags Details
ifcfg.log (573 bytes, text/plain)
2013-06-08 00:19 EDT, Adam Williamson
no flags Details
packaging.log (232.54 KB, text/plain)
2013-06-08 00:21 EDT, Adam Williamson
no flags Details
storage.log (214.46 KB, text/plain)
2013-06-08 00:22 EDT, Adam Williamson
no flags Details
syslog (120.87 KB, text/plain)
2013-06-08 00:22 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2013-06-08 00:12:56 EDT
Prompted by robatino, I did some testing with a really minimal kickstart. This one, in fact: http://www.happyassassin.net/ks/packages_only.ks . It contains only this:





how I'd expect that to behave is that the package selection specified would be used, but I could specify everything else interactively, just like a non-kickstart install.

It kinda works, but there are some quirks. This bug is one of them. The 'software source' (or whatever, I forget the name) spoke comes up with the warning triangle. If I go in and just try to use 'closest mirror' - just go in and leave again - it fails, anaconda.log shows "Error downloading package metadata..." (but this error isn't shown on the hub, it's just a generic error message). If I go in, change to some invalid URL (ftp://foo), leave, go back, switch to 'closest mirror', and leave again (a dodge that's cleared error conditions like this for me before), it still doesn't work (same error in anaconda.log). But if I pass a *valid* http URL - https://dl.fedoraproject.org/pub/fedora/linux/development/19/x86_64/os/ - it works. (I also have no obvious option to use the DVD itself if I boot from DVD).
Comment 1 Adam Williamson 2013-06-08 00:14:29 EDT
Attaching logs, but note they're a bit messy as I hit another bug with the installation destination spoke while doing this (which I'll report separately). I did the 'source' spoke first, though, so all the stuff relevant to this bug should be in the logs before I ever touched the 'installation destination' spoke.
Comment 2 Adam Williamson 2013-06-08 00:17:10 EDT
Created attachment 758420 [details]
Comment 3 Adam Williamson 2013-06-08 00:18:24 EDT
Created attachment 758421 [details]
Comment 4 Adam Williamson 2013-06-08 00:19:41 EDT
Created attachment 758422 [details]
Comment 5 Adam Williamson 2013-06-08 00:21:40 EDT
Created attachment 758423 [details]
Comment 6 Adam Williamson 2013-06-08 00:22:06 EDT
Created attachment 758424 [details]
Comment 7 Adam Williamson 2013-06-08 00:22:31 EDT
Created attachment 758425 [details]
Comment 8 Adam Williamson 2013-06-08 00:23:41 EDT
Note there are three zero-size files 'ks-script-9MkJPd.log', 'ks-script-F6I74t.log' and 'ks-script-G5mxUw.log' created.
Comment 9 Adam Williamson 2013-06-08 00:45:27 EDT
Proposing as Final FE at least (there's an argument for blocker, I guess...)
Comment 10 Adam Williamson 2013-06-10 13:53:35 EDT
Discussed at 2013-06-10 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-10/f19final-blocker-review-4.2013-06-10-16.01.log.txt . Accepted as a freeze exception: defining the behaviour in this area is a bit tricky and anaconda team may decide not to do anything or to do something 'unexpected' here, but assuming this is agreed to be behaviour that needs to be improved, we think it is worth doing that for F19 Final.
Comment 11 Andre Robatino 2013-07-16 00:31:45 EDT
Similar behavior with a single-line kickstart file specifying the timezone:

timezone America/New_York --isUtc

I'd like this to work so I can tell the installer to set the hardware clock to UTC even if Windows is detected (see bug 981793). BTW, I'm not sure if the correct syntax is --utc or --isUtc - I see --utc in the documentation, but --isUtc in an automatically generated kickstart file.
Comment 12 Andre Robatino 2013-07-16 02:52:30 EDT
Same result with a 1-byte ks file (the installer wouldn't start at all with a 0-byte file).
Comment 13 Steve Tyler 2013-07-27 15:48:05 EDT
(In reply to Andre Robatino from comment #12)
> Same result with a 1-byte ks file (the installer wouldn't start at all with
> a 0-byte file).

I can't reproduce the 0-byte kickstart file startup failure case with the F19 DVD:
1. $ touch ks-empty.cfg
2. $ ls -l ks-empty.cfg # verify that the file has read permissions
3. Initialize a disc image:
   $ qemu-img create f19-test-2.img 12G
4. Start the F19 installer DVD:
   $ qemu-kvm -m 4096 -hda f19-test-2.img -cdrom ~/xfr/fedora/F19/Fedora-19-x86_64-DVD.iso -vga std -boot menu=on
5. Append to kernel command line:

The installer displays the Welcome title and the language menu with English selected. I can tell that it is a kickstart install, because the menu item is at the top of the window, as expected, but it is partially obscured.

If you can reproduce, could you open a separate bug, so Adam doesn't start complaining about how messy his bug is getting ... :-)
Comment 14 Andre Robatino 2013-07-27 16:20:00 EDT
Filed https://bugzilla.redhat.com/show_bug.cgi?id=989133 . I used an http download ( http://robatino.fedorapeople.org/ks.cfg ). It has read permission and downloads fine using wget.
Comment 15 Mike Ruckman 2013-11-14 13:23:33 EST
Discussed in 2013-11-14 Blocker Review Meeting [1]. This was voted a AcceptedFreezeException. Kickstarts are expected to be used as partial configuration. It should be possible to configure manually the remaining pieces. Unless this has changed, this is an inconvenient bug and we would accept a patch after freeze if self-contained and safe.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-14/
Comment 16 Adam Williamson 2013-11-15 13:11:09 EST
This one goes more or less hand-in-glove with https://bugzilla.redhat.com/show_bug.cgi?id=972266 , bcl - just fyi.
Comment 17 David Shea 2014-10-13 10:39:11 EDT
*** Bug 948219 has been marked as a duplicate of this bug. ***
Comment 18 Fedora Update System 2014-10-15 09:07:38 EDT
anaconda-21.48.10-1.fc21 has been submitted as an update for Fedora 21.
Comment 19 Fedora Update System 2014-10-16 13:18:22 EDT
Package anaconda-21.48.10-1.fc21, pykickstart-1.99.63-2.fc21, python-blivet-0.61.5-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-21.48.10-1.fc21 pykickstart-1.99.63-2.fc21 python-blivet-0.61.5-1.fc21'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).
Comment 20 Fedora Update System 2014-10-20 19:01:37 EDT
anaconda-21.48.10-1.fc21, pykickstart-1.99.63-2.fc21, python-blivet-0.61.5-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Kyle Marek 2017-07-30 01:53:46 EDT
Problem appears again in Fedora 26 (maybe earlier?). I have to work around with https://pagure.io/fedora-kickstarts/blob/master/f/fedora-repo-not-rawhide.ks

Note You need to log in before you can comment on or make changes to this bug.