Bug 846943 - [abrt] xorg-x11-server-Xorg-1.12.2-4.fc17: Xorg server crashed
Summary: [abrt] xorg-x11-server-Xorg-1.12.2-4.fc17: Xorg server crashed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 17
Hardware: x86_64
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:41d776e8cd514936d8f33fe5afe...
: 832638 862739 870422 876278 880232 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-08-09 08:12 UTC by Lukas Bezdicka
Modified: 2012-12-07 14:52 UTC (History)
107 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-01 08:45:16 UTC
Type: ---


Attachments (Terms of Use)
File: usr_share_xorg_conf_d.tar.gz (1.55 KB, text/plain)
2012-08-09 08:12 UTC, Lukas Bezdicka
no flags Details
File: etc_X11_xorg_conf_d.tar.gz (382 bytes, text/plain)
2012-08-09 08:12 UTC, Lukas Bezdicka
no flags Details

Description Lukas Bezdicka 2012-08-09 08:12:50 UTC
Description of problem:


Version-Release number of selected component:
xorg-x11-server-Xorg-1.12.2-4.fc17

Additional info:
libreport version: 2.0.12
abrt_version:   2.0.11
kernel:         3.5.0-2.fc17.x86_64

backtrace:
:0: /usr/bin/Xorg (xorg_backtrace+0x36) [0x4650a6]
:1: /usr/bin/Xorg (0x400000+0x6a069) [0x46a069]
:2: /lib64/libpthread.so.0 (0x3e0da00000+0xefe0) [0x3e0da0efe0]
:3: /usr/lib64/xorg/modules/extensions/libglx.so (0x7f6e982cf000+0x44e84) [0x7f6e98313e84]
:4: /usr/lib64/xorg/modules/extensions/libdri2.so (0x7f6e97cb6000+0x1bcc) [0x7f6e97cb7bcc]
:5: /usr/lib64/xorg/modules/extensions/libdri2.so (0x7f6e97cb6000+0x1c28) [0x7f6e97cb7c28]
:6: /usr/bin/Xorg (TraverseTree+0x29) [0x45c259]
:7: /usr/lib64/xorg/modules/extensions/libdri2.so (DRI2SwapBuffers+0x17a) [0x7f6e97cb8caa]
:8: /usr/lib64/xorg/modules/extensions/libdri2.so (0x7f6e97cb6000+0x3f42) [0x7f6e97cb9f42]
:9: /usr/bin/Xorg (0x400000+0x3444a) [0x43444a]
:10: /usr/bin/Xorg (0x400000+0x23485) [0x423485]
:11: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x3e0d221735]
:12: /usr/bin/Xorg (0x400000+0x2375d) [0x42375d]

Comment 1 Lukas Bezdicka 2012-08-09 08:12:53 UTC
Created attachment 603201 [details]
File: usr_share_xorg_conf_d.tar.gz

Comment 2 Lukas Bezdicka 2012-08-09 08:12:55 UTC
Created attachment 603202 [details]
File: etc_X11_xorg_conf_d.tar.gz

Comment 3 Simone Deponti 2012-09-04 08:29:54 UTC
1. Logged into the system
2. Started a program (empathy)


Package: xorg-x11-server-Xorg-1.12.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 4 smanocch 2012-09-06 08:07:54 UTC
opening gnome-boxes

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 5 Flávio 2012-09-06 18:22:01 UTC
Eu estava efetuando o upload de um arquivo de vídeo para o Youtube. Como a transfência desse arquivo iria demorar alguns minutos, resolvi então iniciar o programa Empathy para iniciar um bate-pago. Ao executar tal programa, todo o meu ambiente de trabalho foi encerrado, sem nenhum mensagem de erro, e o Fedora reiniciou o ambiente gráfico solicitando a seleção de um usuário e senha. Após preencher todos os dados, o ambiente foi restaurado (vi que uma janela de console foi exibida rapidamente - cor preta estilo ms-dos) mas os programa havia sido finalizados.

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 6 jnyman 2012-09-07 00:12:24 UTC
Have a couple of programs running: I got Virt-Manager and Firefox Running. Then Start Empathy Messenger and xorgserver crashes.

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 7 Domenico Baiani 2012-09-07 11:08:40 UTC
I clicked on empathy icon (searched with shell) and the session closed immediately

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 8 Jani Heinonen 2012-09-10 03:54:13 UTC
* Clicked myself online on the menu at top right corner
* super + typed in empath + enter -> crash


Package: xorg-x11-server-Xorg-1.12.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 9 Russell Harrison 2012-09-11 18:15:00 UTC
I was entering a command in the run dialog that pops up after <ALT>-F2 in gnome-shell and right clicked in the text box to paste part of the command I wanted to run.  Gnome shell locked up and X crashed shortly after.

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 10 Calvin Smith 2012-09-11 18:30:51 UTC
Installed the Mailnag application and while trying to configure it and test it, X crashed. Not sure exactly what caused the problem, though. 

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 11 Marcel 2012-09-13 17:24:57 UTC
Crash juste after login in gnome 3 and starting empathy

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 12 D. Charles Pyle 2012-09-15 17:46:36 UTC
Launched Cheese. X crashed and forced a logoff. It has happened several times but since updates have not fixed it I am reporting the last two crashes.

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 13 Andrew Vagin 2012-09-16 14:31:06 UTC
Execute empaphy

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 14 mri 2012-09-17 14:44:03 UTC
I tried to access the "Online Accounts" Settings via the Status Menue in the Top-Right Corner. Suddenly x11 crashed and i had to re-log again.

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 15 Dan Young 2012-09-17 15:47:54 UTC
Started 'Documents' in GNOME Shell.

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 16 uozabaci 2012-09-22 18:37:55 UTC
when i click empathy...
Opera , Amarok was runing when system crashed...


Package: xorg-x11-server-Xorg-1.12.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 17 Simone Deponti 2012-09-25 07:54:32 UTC
Just after log in, GNOME had load correctly.

I went into the hot corner to activate the overlay and clicked on the Empathy icon.


Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 18 wedel 2012-09-25 09:20:32 UTC
Every once in a while my xorg-server crashes when I suspend-to-ram. When this happens, my laptop will not suspend. It just hangs up and I can't do anything about it than to hit the power butten to restart my system. 

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 19 abyss.7 2012-09-26 13:15:12 UTC
Did nothing extraordinal.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 20 wloptor 2012-09-26 13:28:21 UTC
Just i turn in on the computer and then in the screen appears this error.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 21 Nathan Erickson 2012-09-27 00:53:40 UTC
When I open Empithy by clicking the shortcut from my Gnome 3 default dock on a fresh boot I get logged out and I'm returned to the login screen. I've tried to correct the problem by removing my Empathy settings to see if there is a bad setting causing the issue. (mv ~/.config/Empathy /tmp) The problem still persists.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 22 pridon@gmail.com 2012-09-28 16:44:46 UTC
while starting the "Empathy" for gtalk. X restarted

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 23 joyner.kevin 2012-09-29 01:54:08 UTC
Using gnome 3 shell (with Faience theme). Pointed to hotcorner (top left), clicked into search box and began to type.  Shell crashed and I had to log back in.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 24 Rafael M. Ferreira 2012-09-29 18:10:37 UTC
This problem happened only once time, when I clicked to logout in the GNOME bar.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 25 Rafael M. Ferreira 2012-09-29 18:16:21 UTC
Sorry for my mistake. This problem doesn't occurred when I clicked to logout. It ocurred when I clicked to start Empathy.

Comment 26 Lukasz Jagiello 2012-09-30 21:32:03 UTC
Run Empathy

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 27 Benoît Marcelin 2012-10-03 06:23:28 UTC
# Start gnome session (gnome 3.4)
# Use some applications
# Open overlay one more time and click on an icon
# X crashes
# GDM shows up
# Trying opening a new sessions fail
# Kill all remaining user programs (gnome-keyring-daemon * 2)
# Try again => failed
# Restart the whole computer
# Now the session can be opened


Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 28 tabloid.adroit 2012-10-04 15:40:48 UTC
step1.  grub2-mkconfig -o /boot/grub2/grub.cfg
step2.  run empathy
step3.  then follows "can not open font True" on a blackscreen


Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 29 Michael Ekstrand 2012-10-05 00:45:46 UTC
Shortly after startup, crashed as I was trying to start a program via searching the overview.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 30 Marcel 2012-10-08 13:23:08 UTC
crash few seconds after gnome3 start when i clicked on all my applications i wanted to start :
chrome, firefox, thunderbird and in last "empathy" then it crash


Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 31 Alessio Arceri 2012-10-11 17:28:48 UTC
my system crashed after i start the update system

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 32 Christian K. da Cunha 2012-10-15 11:16:20 UTC
When i try to open the mixer while chrome browser are running some vid.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 33 tommy walker 2012-10-17 16:38:03 UTC
after restart the machine from suspend mode

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 34 Andy Gospodarek 2012-10-17 17:57:54 UTC
This appears to be working will a fully updated system.  Before the update yesterday gnome would log me out each time I opened empathy.

The system would quickly jump to a framebuffer console, display a vague message that seemed to be a font error (sorry I don't recall the exact sentence) and then return to the login screen.

Today it seems to be working just fine.  FYI I was using the nouveau driver if that made any difference.

I'm not sure that the version of the xserver matters, as I'm running the same as everyone else without any problems today.

$ rpm -qa | grep x11-server-Xorg
xorg-x11-server-Xorg-1.12.3-2.fc17.x86_64

I suspect my problem was specific to gnome.

Comment 35 Adam Jackson 2012-10-18 21:49:17 UTC
Please update to at least xorg-x11-server-1.12.3-2.fc17 and reopen if this is still reproduceable.

Comment 36 Adam Jackson 2012-10-18 21:49:48 UTC
Please update to at least xorg-x11-server-1.12.3-2.fc17 and reopen if this is still reproduceable.

Comment 37 Alberto Salvador Rivera 2012-10-19 13:48:51 UTC
Opening Empathy.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 39 Andy Gospodarek 2012-10-19 15:51:15 UTC
Reopening as I'm actually still seeing this when running the xserver version specified in comment #36.  It seems to be a conflict between certain web-pages being open in firefox and empathy running.

Comment 40 pridon@gmail.com 2012-10-20 10:37:40 UTC
while changing network settings

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 41 Simone Deponti 2012-10-20 13:25:07 UTC
Just logged in and clicked on the empathy icon

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 42 Gevorg 2012-10-20 14:33:22 UTC
had a number of libreoffice documents open, two browser windows, and a few files windows. tried to open system settings and boom.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 43 Dylan R. Semler 2012-10-20 20:07:05 UTC
After booting fedora, I opened chromium and did a google search.  I then clicked on the "windows logo" key on my keyboard.  I then typed "users" and clicked on a link to open the Users and Groups settings.  This caused X to immediately crash.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 44 Utku B. 2012-10-24 07:05:21 UTC
While I was using poedit, I clicked the cheese. Then I saw a ... font is not found message. The Gnome Login screen came.

I can't repeat the bug.

Thanks.


Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 45 metalfish 2012-10-24 11:55:31 UTC
I just ran Wireshark.
The only thing that comes in my mind that I have maybe modified my system is by using BleachBit


Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 46 Andy Gospodarek 2012-10-24 13:01:08 UTC
I had this happen again yesterday after loading a random web-page.  The only thing printed on the framebuffer screen was

"Unable to load font True"

I'll check the capitalization if I get it again and have the time to debug.

Comment 47 Julian Stecklina 2012-10-24 16:25:23 UTC
Clicked on Online Accounts in the Gnome menu.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 48 webseiten.designer 2012-10-28 17:22:23 UTC
Using gnome shell Extension empathy-menu (https://extensions.gnome.org/extension/259/empathy-menu/)
Clicked on "Chat" in user menu


Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 49 Lukasz Jagiello 2012-10-30 08:45:06 UTC
Run Empathy.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 50 Igor Vucenovic 2012-10-30 14:44:44 UTC
This problem was ocure when I try to click on System setings from menu (right top corner) Fedora 17

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 51 David Strauss 2012-10-31 00:02:43 UTC
Browsing Facebook in Chrome.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 52 David Strauss 2012-10-31 00:03:49 UTC
Actually, I think I was launching Empathy.

Comment 53 Andy Gospodarek 2012-10-31 05:10:29 UTC
Any chance anyone is looking a this?

Comment 54 Bob Rasey 2012-11-03 13:05:53 UTC
Typing in chat session in Empathy when X crashed. Crashed gracefully, though; gdm came right up.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 55 Pascal94 2012-11-04 11:29:32 UTC
just launched Empathy, while runing Boinc + VirtualBox + Firefox

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 56 Olivier Crête 2012-11-04 12:18:13 UTC
Starting GNOMe

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 57 Madison Kelly 2012-11-04 16:32:50 UTC
I think this just hit me hard. I was getting 6~10 crashes last night, so I powered off after a yum-y update. This morning when I powered up, abrtd was showing over 100 crashes a second. 

I could see that they were xorg related, but I couldn't even get one reported because it was hanging my system. I had to stop and disabled abrtd.service just to make it respond again. 

When abrtd finally stopped, I could see the number of crash reports was over 800 and /var/cache/abrt-di/ got to 2.5G. For now, I have to leave abrtd disabled just to use my system, so I am not sure what I can do from here to help. This is pretty critical for me now... This is my primary work laptop. =/

Comment 58 jibecfed 2012-11-06 11:01:53 UTC
I was in gnome contact, copying a phone number.
I pressed Super on my keyboard to reach Empathy.
It crashed at this moment : black screen and loggin screen.


Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 59 Martin Wilck 2012-11-06 14:50:32 UTC
I had clicked on "Sound Settings" in the Gnome panel when the GNOME shell crashed.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 60 pridon@gmail.com 2012-11-06 17:07:01 UTC
ufter update to 3.6.5 and first bootup , after first login to gnome 

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 61 Alessio Arceri 2012-11-07 22:00:50 UTC
the system is crashed after i run empaty

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 62 emmanuel.lesne 2012-11-11 15:01:33 UTC
Just installed

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 63 Vivien Didelot 2012-11-12 14:59:24 UTC
Some days ago, I tested several DEs and WMs (while using Gnome3). I installed KDE, Cinnamon, MATE, XFCE, etc. Since then I'm not able to change my status (available, ...).

Today I clicked the "Online Accounts" button in the top right menu, which makes X crash.
After reloging, I can click it, previous accounts are there, but I still can't change my status.

I think some DEs have messed up with some Gnome config files...


Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 64 Tadej Janež 2012-11-14 09:21:30 UTC
I resumed my laptop from hibernate, connected an external monitor and started reading emails.
Shortly afterwards, the X server crashed and I was welcomed with the login screen.


Package: xorg-x11-server-Xorg-1.12.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 65 Claudio Saavedra 2012-11-14 13:38:09 UTC
Opening Empathy from the gnome-shell. I am using two external screens.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 66 Simone Deponti 2012-11-15 09:03:51 UTC
Just logged into GNOME

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 67 ubek 2012-11-15 09:55:08 UTC
when running first time the cheese program

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 68 Erwan Legrand 2012-11-19 11:08:26 UTC
I launched empathy and the X server crahsed.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 70 Martin Wilck 2012-11-20 13:39:17 UTC
Is anyone looking into these traces?

I am wondering if they're actually all the same problem, or false duplicates created by abrt.

Comment 71 Rob 2012-11-24 02:14:21 UTC
1. start system settings
2. select desktop effects
3. select advanced top
4. change qt graphics system to native.


Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 72 vlakhadzhi 2012-11-24 10:42:41 UTC
x-server crashed after clicking on 'network' icon

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 73 Jason Brown 2012-11-25 09:03:49 UTC
restarted my computer after formatting a hard drive.
booted into gnome-shell
clicked on extension for empathy from user menu


Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 74 Gregory Wellington 2012-11-25 22:48:17 UTC
1. Unlocked screen in Gnome 3
2. Used hot corner 
3. Typed in em to bring up Empathy
4. Empathy launched
5. Xorg / Desktop crashed
6. Black screen with message about truetype font not found appeared (i.e. which appears during boot).
7. System recovered, Gnome login screen reappeared and was able to log back in. 


Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 75 Seb 2012-11-26 03:28:24 UTC
I just log in after a reboot to enable Virtualitsation in my bios. Gnome freezed and I got a kind of oops x message graphically. Before the reboot  I had installed some Gstreamer plugin and libvirtd-kvm. I reboot again and I'm now able to send this abrt report. 

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 76 Alex 2012-11-26 20:36:49 UTC
I clicked on the windows key followed by clicking on the "power" settings interface. I was then logged out at the blink of an eye.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 77 Amit Ugol 2012-11-27 09:24:26 UTC
latest telepathy on Fedora 17 64b (as of Nov-17-2012)
1. Start telepathy video chat with a gTalk client user - this fails as there is no video on both sides
2. gTalk user returns a video call - Telepathy crashes here (known issue id-812222)
3. restart telepathy from gnome-shell quick/favorite bar - this made Xorg server crash


Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 78 Fedora Update System 2012-11-28 17:24:39 UTC
xorg-x11-server-1.12.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.12.4-1.fc17

Comment 79 Adam Jackson 2012-11-28 19:44:26 UTC
*** Bug 832638 has been marked as a duplicate of this bug. ***

Comment 80 Adam Jackson 2012-11-28 19:44:35 UTC
*** Bug 870422 has been marked as a duplicate of this bug. ***

Comment 81 Adam Jackson 2012-11-28 19:44:42 UTC
*** Bug 876278 has been marked as a duplicate of this bug. ***

Comment 82 Adam Jackson 2012-11-28 19:44:49 UTC
*** Bug 880232 has been marked as a duplicate of this bug. ***

Comment 83 Aurimas Černius 2012-11-28 20:12:21 UTC
I launched Empathy, crash occurred about when it's window was supposed to appear.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 84 Fedora Update System 2012-11-29 03:59:33 UTC
Package xorg-x11-server-1.12.4-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-server-1.12.4-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19339/xorg-x11-server-1.12.4-1.fc17
then log in and leave karma (feedback).

Comment 85 Adam Jackson 2012-11-30 16:52:13 UTC
*** Bug 862739 has been marked as a duplicate of this bug. ***

Comment 86 Fedora Update System 2012-12-01 08:45:28 UTC
xorg-x11-server-1.12.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 87 Mark Salter 2012-12-07 14:52:05 UTC
I'm still experiencing the problem. There is no real pattern to the server crashing. My use case is fairly simple. I'll have a couple of gnome-terminals open along with emacs. A lot of times I get the crash while moving cursor from
emacs to a terminal or vice-versa. Another common crash point has been when resuming after sleep. Or so I thought. A while back, I disabled sleep on lid close and that seemed to help some.

For two days in a row, I got an X server crash first thing in the morning after opening the lid and logging in. The crash happens after hitting enter for the login but before the desktop comes up fully. After the crash, it seems to get in a loop of crashing and trying to restart and crashing... I get the notification at the bottom of the screen to ignore/report. I click report on the first one but can't make enough progress to actually get the dialog up. I see more notifications popping up and down at the bottom of the screen and the disk is being pounded on. I have let it run like this for a half hour or more and it is just stuck in the crash loop. I end up having to power off.

Usually after a power cycle, I avoid the crashes for a while but after the crash this morning I powered off, waited about 10 seconds and powered back on and experienced the server crash immediately after logging in. After a second power cycle, I logged in with no problem and am using the T520 to write this note.


Note You need to log in before you can comment on or make changes to this bug.