Bug 848884 - GRUB menu uneditable after text mode (minimal) installation (F18 Alpha TC3)
GRUB menu uneditable after text mode (minimal) installation (F18 Alpha TC3)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
: 853896 (view as bug list)
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-08-16 13:27 EDT by Paul W. Frields
Modified: 2012-09-12 14:36 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-11 21:08:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of KVM guest with broken GRUB (5.08 KB, image/png)
2012-08-21 08:26 EDT, Paul W. Frields
no flags Details
grub with qxl (179.93 KB, image/png)
2012-08-22 08:07 EDT, Kamil Páral
no flags Details

  None (edit)
Description Paul W. Frields 2012-08-16 13:27:02 EDT
Additional info:
1. Using text mode, installed F18 Alpha TC2 x86_64 from DVD ISO in a KVM guest on F17 x86_64 host (after working around bug 848841).
2. Minimal installation completes, reboot guest.
3. GRUB menu fails to find "fireworks.png" (expected), but then the GRUB menu that appears is illegible -- too small a window to see content, thus I can't edit.
Comment 1 Mads Kiilerich 2012-08-19 10:20:28 EDT
Please show a photo/screenshot of the illegible window.
Comment 2 Paul W. Frields 2012-08-21 08:26:54 EDT
Created attachment 605922 [details]
Screenshot of KVM guest with broken GRUB

Also marking this against F18Blocker, although I think this situation isn't covered in the current release criteria.
Comment 3 Paul W. Frields 2012-08-21 08:27:51 EDT
Issue is also present in TC3 by the way.
Comment 4 Mads Kiilerich 2012-08-21 10:21:59 EDT
I have a f18 in a f17 kvm and I don't see that problem. I got the impression that some other f18 testers also don't see it. How reproducible is the problem on other systems ... or is your system special in any way?

Your system seems to use a VIC-20 compatible resolution. Do /boot/grub2/grub.cfg or dmesg give a hint of some special video settings?
Comment 5 Paul W. Frields 2012-08-21 15:00:31 EDT
You're giving me too much credit. :-) I requested a stock x86_64 type machine (using Linux/F17 as the install target) in virt-manager.  The video type selected according to virt-manager was qxl, 64MB.

Unfortunately, because of the authconfig bug 848803 I can't log into the system to read the logs.  If there's a documented workaround I can use, let me know.
Comment 6 Paul W. Frields 2012-08-21 15:44:50 EDT
I tried changing the video type in virt-manager to 'vga'.  This made the GRUB menu viewable.  I was then able to edit the boot menu and boot into single user mode.
Comment 7 Adam Williamson 2012-08-21 19:06:07 EDT
that sounds like some kind of problem at the nexus of grub's modesetting capability, the qxl adapter in kvm, and possibly the lack of the theme background...

paul, if you fix up the fireworks.png bug (which is 840179, you just have to change 'fireworks.png' to 'background.png' and rebuild the grub config), do you get something usable, or do you just get the weird-looking grub with a background?
Comment 8 Mads Kiilerich 2012-08-21 19:40:39 EDT
I guess the theme would look strange in this video mode too, but I doubt the low resolution is caused by the theme bug.

The output of the grub2 command
  set pager=1
  vbeinfo
in the qxl mode and dmesg from the booted system would probably be interesting for those skilled in the art.
Comment 9 Kamil Páral 2012-08-22 08:07:52 EDT
Created attachment 606225 [details]
grub with qxl

The problem with qxl driver appears also with grub with fixed background (TC3).

Marking as Beta blocker.
Comment 10 Mads Kiilerich 2012-08-22 08:46:51 EDT
Ok, it seems like the problem here really is caused by 840179. Using a broken theme seriously mess everything up. Can you verify that the problem goes a way with
  sed -i 's,fireworks,background,' /boot/grub2/themes/system/theme.txt 
or the workaround in the latest fedora-logos?
Comment 11 Mads Kiilerich 2012-08-22 08:58:41 EDT
More precisely: It seems like the themes have a broken default font. In graphical mode the big ugly font is also used for the progress messages when loading the kernel and initrd. The advantage of having a working theme is that it doesn't use the ugly font that much.

The problem reported here is probably also caused by the VM VBE tables specifing a default resolution of 640x480.
Comment 12 Kamil Páral 2012-08-22 09:20:31 EDT
(In reply to comment #10)
> Ok, it seems like the problem here really is caused by 840179. Using a
> broken theme seriously mess everything up. Can you verify that the problem
> goes a way with
>   sed -i 's,fireworks,background,' /boot/grub2/themes/system/theme.txt 
> or the workaround in the latest fedora-logos?

Mads, in my comment #9 the background is working and fireworks.png is a symlink for background.png.
Comment 13 Paul W. Frields 2012-08-22 09:45:15 EDT
I think everyone else has already arrived at the same information, but the workaround in the latest theme (I was able to work around other pesky bugs and get to a more working-ish system) partially addresses the problem.  The default font being used is still large and awkward.
Comment 14 Mads Kiilerich 2012-08-22 09:48:37 EDT
(In reply to comment #12)
> Mads, in my comment #9 the background is working and fireworks.png is a
> symlink for background.png.

Yes, I agree the "default fixed with font" part of the themes is broken no matter if the graphical theme actually works or not.

There is no doubt the boot menu user experience shown by Paul's screenshot is a blocker. The boot menu user experience should however be fixed by the fedora-logos update.

The "edit" user experience shown by your screenshot (and Bug 850783) is still not fixed, but it could be considered slightly less serious.
Comment 15 Mads Kiilerich 2012-09-03 07:56:32 EDT
*** Bug 853896 has been marked as a duplicate of this bug. ***
Comment 16 xset1980 2012-09-04 04:06:01 EDT
With TC5 same bug, i attached a photo, but my bug report was modified by this.
Comment 17 Adam Williamson 2012-09-11 21:08:04 EDT
OK, let's attempt to inject some cleanliness here. Let's say this bug just covered the menu navigation, and that's fixed by fixing the theme, so close it. Let's have a different bug for the problem of a silly font being used in our default config, which makes the edit interface unusable on low-res displays, like VMs, and that's #850783. I'll close this bug and we can use 850783 for the font issue.
Comment 18 David Cantrell 2012-09-12 14:36:42 EDT
*** Bug 856277 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.