This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 849018 - rhnPackageCapability.version is too small for some packages
rhnPackageCapability.version is too small for some packages
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
541
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Martin Minar
: Patch
Depends On:
Blocks: 465198 819027 856128
  Show dependency treegraph
 
Reported: 2012-08-17 01:20 EDT by Nigel Jones
Modified: 2016-07-03 20:57 EDT (History)
6 users (show)

See Also:
Fixed In Version: satellite-schema-5.5.0.15-1-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 856128 (view as bug list)
Environment:
Last Closed: 2012-10-22 07:24:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to change rhnPackageCapability.version to 512 bytes wide (1.08 KB, patch)
2012-08-17 01:20 EDT, Nigel Jones
no flags Details | Diff

  None (edit)
Description Nigel Jones 2012-08-17 01:20:01 EDT
Created attachment 605078 [details]
Patch to change rhnPackageCapability.version to 512 bytes wide

Description of problem:
This arises from the same case as the Solaris bug 849011 however from a different source package.

It appears that some Solaris packages come with version strings exceeding 64 characters in length, and will fail in an 'rhnpush'.

rhnPackageEVR specifies version as 512 bytes, so I'm chosen to match that in this patch for consistancy.

How reproducible:
Always

Steps to Reproduce:
1. Attempt to 'rhnpush' attached mpm file to RHN Satellite
2. Watch /var/log/httpd/error_log
3.
  
Actual results:
Failure (SQLError: (12899, 'ORA-12899: value too large for column "RHNSAT"."RHNPACKAGECAPABILITY"."VERSION" (actual: 73, maximum: 64)\\n', 'insert into rhnPackageCapability (id, name, version) values (:id, :name, :version)'))

Expected results:
RHN Push to succeed and package to appear in Solaris channel.

Additional info:
Comment 4 Jan Pazdziora 2012-09-05 10:48:05 EDT
When doing 5.4 and/or 5.5 errata, we should consider also doing fix for bug 854686.
Comment 6 Jan Pazdziora 2012-09-05 10:59:31 EDT
Fixed in Spacewalk master, commits f89a70e86fa7344c1b0cc323a8f8173c99051800 and af4a153419204be2fcde71bbbed0d7289d723403 (the schema upgrade scripts).
Comment 9 Jan Pazdziora 2012-09-10 12:50:38 EDT
Fixed schema upgrade script in Spacewalk master, 2ed9809ff0914a0f409d680f75f700634f7a4d59.
Comment 13 errata-xmlrpc 2012-10-22 07:24:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1394.html

Note You need to log in before you can comment on or make changes to this bug.