This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 849707 - AttributeError: 'BTRFSVolumeDevice' object has no attribute 'isMagic'
AttributeError: 'BTRFSVolumeDevice' object has no attribute 'isMagic'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 862073 (view as bug list)
Depends On: 862742
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-08-20 12:24 EDT by Reartes Guillermo
Modified: 2013-01-24 05:04 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 17:19:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of the error (91.99 KB, image/png)
2012-08-20 12:24 EDT, Reartes Guillermo
no flags Details
anaconda logfile (239.73 KB, text/plain)
2012-08-20 12:24 EDT, Reartes Guillermo
no flags Details
anaconda storage log (109.43 KB, text/plain)
2012-08-20 12:26 EDT, Reartes Guillermo
no flags Details
miz04-install-log.txt (281.60 KB, text/plain)
2012-11-15 13:38 EST, IBM Bug Proxy
no flags Details
install-log1.txt (251.23 KB, image/png)
2012-11-15 13:39 EST, IBM Bug Proxy
no flags Details
install-log4.png (236.90 KB, image/png)
2012-11-15 13:39 EST, IBM Bug Proxy
no flags Details
File: ifcfg.log (687 bytes, text/plain)
2012-11-15 13:39 EST, IBM Bug Proxy
no flags Details
File: anaconda-tb (552.65 KB, text/plain)
2012-11-15 13:40 EST, IBM Bug Proxy
no flags Details
File: product (6 bytes, text/plain)
2012-11-15 13:40 EST, IBM Bug Proxy
no flags Details
File: type (9 bytes, text/plain)
2012-11-15 13:40 EST, IBM Bug Proxy
no flags Details
File: environ (761 bytes, text/plain)
2012-11-15 13:40 EST, IBM Bug Proxy
no flags Details
File: storage.log (221.24 KB, text/plain)
2012-11-15 13:41 EST, IBM Bug Proxy
no flags Details
File: version (8 bytes, text/plain)
2012-11-15 13:41 EST, IBM Bug Proxy
no flags Details
File: program.log (101.98 KB, text/plain)
2012-11-15 13:41 EST, IBM Bug Proxy
no flags Details
File: anaconda.log (4.59 KB, text/plain)
2012-11-15 13:42 EST, IBM Bug Proxy
no flags Details
File: syslog (174.19 KB, text/plain)
2012-11-15 13:42 EST, IBM Bug Proxy
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-11-15 13:42 EST, IBM Bug Proxy
no flags Details
File: packaging.log (1.25 KB, text/plain)
2012-11-15 13:42 EST, IBM Bug Proxy
no flags Details
File: cmdline_file (107 bytes, text/plain)
2012-11-15 13:43 EST, IBM Bug Proxy
no flags Details
File: release (24 bytes, text/plain)
2012-11-15 13:43 EST, IBM Bug Proxy
no flags Details
File: description (1.17 KB, text/plain)
2012-11-15 13:43 EST, IBM Bug Proxy
no flags Details

  None (edit)
Description Reartes Guillermo 2012-08-20 12:24:16 EDT
Created attachment 605732 [details]
screenshot of the error

Description of problem:

On this kvm guest, right after selecting "i accept my fate", anaconda
enters the main screen but it inmediately pressent the "unknown error" message.
Se attached screenshot.

Version-Release number of selected component (if applicable):
F18 TC3

Steps to Reproduce:
1. boot guest
2. accept your fate
3. bang!
  
Actual results:
nothing can be done

Expected results:
no error

Additional info:
Comment 1 Reartes Guillermo 2012-08-20 12:24:53 EDT
Created attachment 605734 [details]
anaconda logfile
Comment 2 Reartes Guillermo 2012-08-20 12:26:28 EDT
Created attachment 605737 [details]
anaconda storage log
Comment 3 Chris Lumens 2012-08-20 13:30:11 EDT
anaconda 18.6 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 725, in shouldClear
    if not (partition.isMagic or self.shouldClear(partition)):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 919, in getFreeSpace
    clearPartDisks=[disk.name])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 450, in _update_summary
    free_space = self.storage.getFreeSpace(disks=self.disks)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 438, in _initialize
    self._update_summary()
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 87, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'BTRFSVolumeDevice' object has no attribute 'isMagic'
Comment 4 Vratislav Podzimek 2012-08-24 05:14:44 EDT
(In reply to comment #0)
> Created attachment 605732 [details]
> screenshot of the error
> 
> Description of problem:
> 
> On this kvm guest, right after selecting "i accept my fate", anaconda
> enters the main screen but it inmediately pressent the "unknown error"
> message.
> Se attached screenshot.
Off topic:
Thanks for reporting bug. However, was there any reason why you didn't use the "Report Bug" button on the "unknown error" window for reporting this bug?
Comment 5 Reartes Guillermo 2012-08-24 18:51:37 EDT
> [...] was there any reason why you didn't use the "Report Bug" button on the "unknown error" window for reporting this bug?

The first bug i encountered, i tried but due to a further error, that feature failed. So assumed that it was not ready yet (maybe for alpha or beta). So basically it failed the first time and i did not bother.
Comment 6 Reartes Guillermo 2012-08-31 16:40:04 EDT
It still happens with anaconda 18.6.4 (pretc4-5). 
It seems tc4 became available recently.
Comment 7 Reartes Guillermo 2012-09-10 11:10:44 EDT
It still happens with anaconda 18.6.5 (pretc7-1).
Comment 8 Reartes Guillermo 2012-09-18 15:36:54 EDT
I propose it as a blocker, because nothing can be done if the error happens.
Comment 9 David Lehman 2012-09-19 10:36:36 EDT
The alpha has been released. This should be fixed in the first beta tree.
Comment 10 Adam Williamson 2012-09-26 14:13:16 EDT
Discussed at 2012-09-26 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-09-26/f18-beta-blocker-review-1.2012-09-26-16.03.log.txt . Accepted as a blocker per criterion "The installer must be able to complete an installation using the text, graphical and VNC installation interfaces" (or any of the 'must be able to complete an installation' criteria) in the case where there's an existing btrfs partition on any attached disk - that's our understanding of this bug, please advise if it's wrong.

Reartes, this is believed to be fixed in 18.8, which is available in the build at http://dl.fedoraproject.org/pub/alt/qa/18/20120920_postalpha-smoke1/ . Can you test with that build and check if it works OK? If it does, we can close this bug, as 18.8 went stable already.
Comment 11 Reartes Guillermo 2012-10-03 22:43:41 EDT
It no longer happens, it seems fixed. 
Sadly i get this instead:

Bug 862742 - TypeError: coercing to Unicode: need string or buffer, NoneType found 

That is with anaconda 18.11 (F18b TC1)
Comment 12 Adam Williamson 2012-10-04 14:48:42 EDT
Discussed at 2012-10-04 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-04/f18-beta-blocker-review-2.1.2012-10-04-16.00.log.txt .  We were going to set this to VERIFIED, but I just realized, we don't really know if it is - we don't know if 862742 happens before you would have hit this bug, or after. Are you sure that 862742 happens *after* you would have hit this bug otherwise, so we can say this is fixed? Or are you not sure of that, and we should wait until 862742 is fixed to be sure whether this one is really fixed?
Comment 13 Reartes Guillermo 2012-10-04 15:24:28 EDT
> [...] Are you sure that 862742 happens *after* you would have hit
> this bug otherwise [...]

No, i am not sure.

Previously the show stopped at the bug reported here.
Currently (beta tc1) the show stops at (Bug 862742).
Comment 14 David Lehman 2012-10-04 15:29:06 EDT
This one would happen after 862742.
Comment 15 Adam Williamson 2012-10-05 04:30:23 EDT
OK, so we can't say for sure whether this one's fixed, we'd better leave it till 862742 is addressed.
Comment 16 Reartes Guillermo 2012-10-09 20:28:55 EDT
Good news:
* I reached the main hub with F18b TC3


Bad news:
* I now get this: Bug 864718 - AttributeError: 'BTRFSVolumeDevice' object has no attribute 'isExtended'
Comment 17 Reartes Guillermo 2012-10-09 20:50:59 EDT
And this other too:
Bug 864721 - AttributeError: 'BTRFS' object has no attribute 'partitions'

But i definitive reach the main hub.
Comment 18 Adam Williamson 2012-10-10 01:24:37 EDT
Let's put this as VERIFIED, then, since you get past the point where you hit it.
Comment 19 Adam Williamson 2012-10-18 17:19:22 EDT
Since 18.14 went stable I believe we can close this now.
Comment 20 David Lehman 2012-11-15 13:26:07 EST
*** Bug 862073 has been marked as a duplicate of this bug. ***
Comment 21 IBM Bug Proxy 2012-11-15 13:38:51 EST
Created attachment 645808 [details]
miz04-install-log.txt
Comment 22 IBM Bug Proxy 2012-11-15 13:39:11 EST
Created attachment 645809 [details]
install-log1.txt
Comment 23 IBM Bug Proxy 2012-11-15 13:39:30 EST
Created attachment 645810 [details]
install-log4.png
Comment 24 IBM Bug Proxy 2012-11-15 13:39:45 EST
Created attachment 645811 [details]
File: ifcfg.log
Comment 25 IBM Bug Proxy 2012-11-15 13:40:00 EST
Created attachment 645812 [details]
File: anaconda-tb
Comment 26 IBM Bug Proxy 2012-11-15 13:40:19 EST
Created attachment 645813 [details]
File: product
Comment 27 IBM Bug Proxy 2012-11-15 13:40:37 EST
Created attachment 645814 [details]
File: type
Comment 28 IBM Bug Proxy 2012-11-15 13:40:55 EST
Created attachment 645815 [details]
File: environ
Comment 29 IBM Bug Proxy 2012-11-15 13:41:15 EST
Created attachment 645816 [details]
File: storage.log
Comment 30 IBM Bug Proxy 2012-11-15 13:41:30 EST
Created attachment 645817 [details]
File: version
Comment 31 IBM Bug Proxy 2012-11-15 13:41:49 EST
Created attachment 645818 [details]
File: program.log
Comment 32 IBM Bug Proxy 2012-11-15 13:42:04 EST
Created attachment 645819 [details]
File: anaconda.log
Comment 33 IBM Bug Proxy 2012-11-15 13:42:19 EST
Created attachment 645820 [details]
File: syslog
Comment 34 IBM Bug Proxy 2012-11-15 13:42:33 EST
Created attachment 645821 [details]
File: hashmarkername
Comment 35 IBM Bug Proxy 2012-11-15 13:42:48 EST
Created attachment 645822 [details]
File: packaging.log
Comment 36 IBM Bug Proxy 2012-11-15 13:43:05 EST
Created attachment 645823 [details]
File: cmdline_file
Comment 37 IBM Bug Proxy 2012-11-15 13:43:20 EST
Created attachment 645824 [details]
File: release
Comment 38 IBM Bug Proxy 2012-11-15 13:43:35 EST
Created attachment 645825 [details]
File: description
Comment 39 IBM Bug Proxy 2013-01-24 05:04:05 EST
------- Comment From maknayak@in.ibm.com 2013-01-24 09:54 EDT-------
Verfied with Fedroa18 PPC64 GA build, and this issue is fixed now.
No such issue got reproduced.

We can clsoe this bug now.

Thanks...
Manas

Note You need to log in before you can comment on or make changes to this bug.