This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 862742 - TypeError: coercing to Unicode: need string or buffer, NoneType found
TypeError: coercing to Unicode: need string or buffer, NoneType found
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:2d438b21921800123d092aa9b08...
:
: 862741 862883 (view as bug list)
Depends On:
Blocks: F18Beta/F18BetaBlocker 849707
  Show dependency treegraph
 
Reported: 2012-10-03 08:45 EDT by Jan Sedlák
Modified: 2012-10-18 17:25 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 17:25:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: ifcfg.log (641 bytes, text/plain)
2012-10-03 08:45 EDT, Jan Sedlák
no flags Details
File: anaconda-tb (181.77 KB, text/plain)
2012-10-03 08:46 EDT, Jan Sedlák
no flags Details
File: environ (865 bytes, text/plain)
2012-10-03 08:46 EDT, Jan Sedlák
no flags Details
File: type (9 bytes, text/plain)
2012-10-03 08:46 EDT, Jan Sedlák
no flags Details
File: storage.log (48.65 KB, text/plain)
2012-10-03 08:46 EDT, Jan Sedlák
no flags Details
File: version (2 bytes, text/plain)
2012-10-03 08:46 EDT, Jan Sedlák
no flags Details
File: program.log (13.88 KB, text/plain)
2012-10-03 08:46 EDT, Jan Sedlák
no flags Details
File: product (6 bytes, text/plain)
2012-10-03 08:46 EDT, Jan Sedlák
no flags Details
File: anaconda.log (2.67 KB, text/plain)
2012-10-03 08:46 EDT, Jan Sedlák
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-03 08:46 EDT, Jan Sedlák
no flags Details
File: cmdline_file (162 bytes, text/plain)
2012-10-03 08:46 EDT, Jan Sedlák
no flags Details
File: release (33 bytes, text/plain)
2012-10-03 08:46 EDT, Jan Sedlák
no flags Details
File: messages (88.93 KB, text/plain)
2012-10-03 08:46 EDT, Jan Sedlák
no flags Details
File: other involved packages (32 bytes, text/plain)
2012-10-03 08:46 EDT, Jan Sedlák
no flags Details

  None (edit)
Description Jan Sedlák 2012-10-03 08:45:56 EDT
Version-Release number of selected component:
anaconda-18.11-1.fc18.x86_64

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
kernel:         3.6.0-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.11 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/posixpath.py", line 133, in islink
:    st = os.lstat(path)
:  File "/usr/lib64/python2.7/posixpath.py", line 182, in ismount
:    if islink(path):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicelibs/btrfs.py", line 105, in list_subvolumes
:    if not os.path.ismount(mountpoint):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 4034, in listSubVolumes
:    subvols = btrfs.list_subvolumes(self.format._mountpoint)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1537, in handleBTRFSFormat
:    for subvol_dict in btrfs_dev.listSubVolumes():
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1664, in handleUdevDeviceFormat
:    self.handleBTRFSFormat(info, device)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1089, in addUdevDevice
:    self.handleUdevDeviceFormat(info, device)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1898, in _populate
:    self.addUdevDevice(dev)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1843, in populate
:    self._populate()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 466, in reset
:    self.devicetree.populate(cleanupOnly=cleanupOnly)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 96, in storageInitialize
:    storage.reset()
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 87, in run
:    threading.Thread.run(self, *args, **kwargs)
:TypeError: coercing to Unicode: need string or buffer, NoneType found
Comment 1 Jan Sedlák 2012-10-03 08:45:59 EDT
Created attachment 620827 [details]
File: ifcfg.log
Comment 2 Jan Sedlák 2012-10-03 08:46:01 EDT
Created attachment 620828 [details]
File: anaconda-tb
Comment 3 Jan Sedlák 2012-10-03 08:46:03 EDT
Created attachment 620829 [details]
File: environ
Comment 4 Jan Sedlák 2012-10-03 08:46:05 EDT
Created attachment 620830 [details]
File: type
Comment 5 Jan Sedlák 2012-10-03 08:46:08 EDT
Created attachment 620831 [details]
File: storage.log
Comment 6 Jan Sedlák 2012-10-03 08:46:10 EDT
Created attachment 620832 [details]
File: version
Comment 7 Jan Sedlák 2012-10-03 08:46:12 EDT
Created attachment 620833 [details]
File: program.log
Comment 8 Jan Sedlák 2012-10-03 08:46:14 EDT
Created attachment 620834 [details]
File: product
Comment 9 Jan Sedlák 2012-10-03 08:46:16 EDT
Created attachment 620835 [details]
File: anaconda.log
Comment 10 Jan Sedlák 2012-10-03 08:46:18 EDT
Created attachment 620836 [details]
File: hashmarkername
Comment 11 Jan Sedlák 2012-10-03 08:46:20 EDT
Created attachment 620837 [details]
File: cmdline_file
Comment 12 Jan Sedlák 2012-10-03 08:46:22 EDT
Created attachment 620838 [details]
File: release
Comment 13 Jan Sedlák 2012-10-03 08:46:25 EDT
Created attachment 620839 [details]
File: messages
Comment 14 Jan Sedlák 2012-10-03 08:46:27 EDT
Created attachment 620840 [details]
File: other involved packages
Comment 15 Jan Sedlák 2012-10-03 08:47:21 EDT
*** Bug 862741 has been marked as a duplicate of this bug. ***
Comment 16 Jan Sedlák 2012-10-03 08:48:05 EDT
See bug 862741 for additional info.
Comment 17 Jan Sedlák 2012-10-03 14:35:49 EDT
Proposing as beta blockerbug per alfa criterion: "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods"
Comment 18 Jesse Keating 2012-10-03 18:06:22 EDT
*** Bug 862883 has been marked as a duplicate of this bug. ***
Comment 19 Adam Williamson 2012-10-04 14:14:26 EDT
Discussed at 2012-10-04 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-04/f18-beta-blocker-review-2.1.2012-10-04-16.00.log.txt . 

The description from 862741: "I have installed Fedora 18 Beta using TC1 Desktop install on btrfs root partition. When I have rebooted into live DVD again, anaconda crashed. See attached log."

So basically, install to btrfs, then run the installer again, it'll barf trying to evaluate the existing install.

Accepted as a blocker per Alpha criterion "The installer must be able to complete an installation using automatic partitioning to any sufficiently large target disk, whether unformatted, empty, or containing any kind of existing data".
Comment 20 Fedora Update System 2012-10-05 16:55:15 EDT
anaconda-18.13-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.13-1.fc18
Comment 21 Alexander Ivanov 2012-10-08 13:23:31 EDT
1. Start "Install to Hard Drive" from Live CD

Package: anaconda-18.12-1.fc18.x86_64
OS Release: Fedora release 18 (Spherical Cow)
Comment 22 Fedora Update System 2012-10-08 20:21:26 EDT
anaconda-18.14-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.14-1.fc18
Comment 23 Fedora Update System 2012-10-09 13:20:59 EDT
Package anaconda-18.14-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.14-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15707/anaconda-18.14-1.fc18
then log in and leave karma (feedback).
Comment 24 Adam Williamson 2012-10-10 00:06:00 EDT
This should be fixed with Beta TC3 - https://dl.fedoraproject.org/pub/alt/stage/18-Beta-TC3/ . Can you please test and let us know? Thanks!
Comment 25 Chris Murphy 2012-10-10 00:45:02 EDT
Appears fixed in netinstall tc3 (anaconda-18.14-1.fc18)
Comment 26 Jan Sedlák 2012-10-10 10:09:04 EDT
Yep, this error is fixed, but I popped into bug 864721.
Comment 27 Adam Williamson 2012-10-10 19:54:29 EDT
Let's mark as VERIFIED then, thanks for testing.
Comment 28 Adam Williamson 2012-10-18 17:25:02 EDT
18.14 went stable, so closing.

Note You need to log in before you can comment on or make changes to this bug.