Bug 849805 - [abrt] cheese-3.4.2-3.fc17: Process /usr/bin/cheese was killed by signal 11 (SIGSEGV)
[abrt] cheese-3.4.2-3.fc17: Process /usr/bin/cheese was killed by signal 11 (...
Status: CLOSED DUPLICATE of bug 850505
Product: Fedora
Classification: Fedora
Component: cheese (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
abrt_hash:c682a53445e8b27a2d85cde944a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-20 20:09 EDT by D. Charles Pyle
Modified: 2012-08-22 05:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 05:29:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: event_log (16.19 KB, text/plain)
2012-08-20 20:09 EDT, D. Charles Pyle
no flags Details
File: backtrace (28.95 KB, text/plain)
2012-08-20 20:09 EDT, D. Charles Pyle
no flags Details
File: maps (66.77 KB, text/plain)
2012-08-20 20:09 EDT, D. Charles Pyle
no flags Details
File: dso_list (10.43 KB, text/plain)
2012-08-20 20:09 EDT, D. Charles Pyle
no flags Details
File: build_ids (4.16 KB, text/plain)
2012-08-20 20:10 EDT, D. Charles Pyle
no flags Details

  None (edit)
Description D. Charles Pyle 2012-08-20 20:09:49 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        cheese
comment:        Hans de Goede had me run the command: cheese& sleep 3; kill -11 %1 so as to troubleshoot Cheese in Fedora 17. He asked me to do this (https://bugzilla.redhat.com/show_bug.cgi?id=810429) because Cheese runs up all the CPU cycles, fills all RAM, and slams the hard drive's swap file--the same as User Accounts (user-accounts) does--when Hauppauge WinTV-HVR-1600 firmware is located in /usr/lib/firmware. It is impossible to get anything in ABRT under such circumstances and the system is unresponsive until the process is killed by the system.
crash_function: cheese_camera_device_add_format
executable:     /usr/bin/cheese
kernel:         3.5.2-1.fc17.x86_64
pid:            1765
remote_result:  NOTFOUND
time:           Mon 20 Aug 2012 05:58:00 PM MDT
uid:            1000
username:       dcpyle
var_log_messages: Aug 20 17:58:09 Illuminatus-1 abrt[1771]: Saved core dump of pid 1765 (/usr/bin/cheese) to /var/spool/abrt/ccpp-2012-08-20-17:58:00-1765 (474980352 bytes)
xsession_errors: 

backtrace:      Text file, 29643 bytes
build_ids:      Text file, 4264 bytes
dso_list:       Text file, 10677 bytes
event_log:      Text file, 16583 bytes
maps:           Text file, 68376 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/dcpyle/2

core_backtrace:
:3461310fc2ad69663f66c1f040de2446a7020130 0x86f5 - libcheese.so.3 -
:3461310fc2ad69663f66c1f040de2446a7020130 0x93e5 - libcheese.so.3 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x161e3 g_object_newv libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x16560 g_object_new_valist libgobject-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0x5935e g_initable_new_valist libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0x59459 g_initable_new libgio-2.0.so.0 -
:3461310fc2ad69663f66c1f040de2446a7020130 0x95e8 cheese_camera_device_new libcheese.so.3 -
:3461310fc2ad69663f66c1f040de2446a7020130 0xa0d4 cheese_camera_device_monitor_set_up_device libcheese.so.3 -
:3461310fc2ad69663f66c1f040de2446a7020130 0xa1bc - libcheese.so.3 -
:3461310fc2ad69663f66c1f040de2446a7020130 0xa1ff - libcheese.so.3 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x449ed g_list_foreach libglib-2.0.so.0 -
:3461310fc2ad69663f66c1f040de2446a7020130 0xa349 cheese_camera_device_monitor_coldplug libcheese.so.3 -
:3461310fc2ad69663f66c1f040de2446a7020130 0x789d cheese_camera_setup libcheese.so.3 -
:e1a2cf887c436ca480f4fd6dde0293a11ca390ba 0x16539 cheese_main_window_setup_camera [exe] -
:e1a2cf887c436ca480f4fd6dde0293a11ca390ba 0x17584 cheese_main_on_app_activate [exe] -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0xf664 g_closure_invoke libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x206d8 - libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x2866d g_signal_emit_valist libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x287c2 g_signal_emit libgobject-2.0.so.0 -
:e1a2cf887c436ca480f4fd6dde0293a11ca390ba 0x1722c - [exe] -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0x97ec8 g_application_run libgio-2.0.so.0 -
:e1a2cf887c436ca480f4fd6dde0293a11ca390ba 0x177b8 _vala_main [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=Illuminatus-1
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/run/user/dcpyle/keyring-cS9bje/gpg:0:1
:TERM=xterm
:SHELL=/bin/bash
:HISTSIZE=1000
:GJS_DEBUG_OUTPUT=stderr
:WINDOWID=35651589
:GNOME_KEYRING_CONTROL=/run/user/dcpyle/keyring-cS9bje
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:QT_GRAPHICSSYSTEM_CHECKED=1
:USER=dcpyle
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.htm=00;33:*.html=00;33:*.shtml=00;33:*.wpd=00;33:
:SSH_AUTH_SOCK=/run/user/dcpyle/keyring-cS9bje/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1149,unix/unix:/tmp/.ICE-unix/1149
:USERNAME=dcpyle
:PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/dcpyle/.local/bin:/home/dcpyle/bin
:MAIL=/var/spool/mail/dcpyle
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/dcpyle
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1145
:LANG=en_US.utf8
:KDE_IS_PRELINKED=1
:GDM_LANG=en_US.utf8
:KDEDIRS=/usr
:GDMSESSION=gnome
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:HOME=/home/dcpyle
:XDG_SEAT=seat0
:SHLVL=2
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=dcpyle
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-kEoS6pgpJc,guid=575954f3ce17c6abef9cca2800000047
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/dcpyle
:DISPLAY=:0
:QT_PLUGIN_PATH=/usr/lib64/kde4/plugins:/usr/lib/kde4/plugins
:CCACHE_HASHDIR=
:COLORTERM=gnome-terminal
:XAUTHORITY=/var/run/gdm/auth-for-dcpyle-p03RJy/database
:_=/usr/bin/cheese

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 31459                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       31459                31459                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/pts/0
:pos:	0
:flags:	0100002
:1:/dev/pts/0
:pos:	0
:flags:	0100002
:2:/dev/pts/0
:pos:	0
:flags:	0100002
:3:socket:[97191]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:socket:[97194]
:pos:	0
:flags:	02004002
:6:/dev/dri/card0
:pos:	0
:flags:	0100002
:7:socket:[97200]
:pos:	0
:flags:	02004002
:8:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:9:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:10:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:11:socket:[97265]
:pos:	0
:flags:	02004002
:12:anon_inode:inotify
:pos:	0
:flags:	02004000
:13:socket:[97371]
:pos:	0
:flags:	04002
:14:socket:[97372]
:pos:	0
:flags:	04002
:15:/dev/video1
:pos:	0
:flags:	0100002

smolt_data:
:
:
:General
:=================================
:UUID: 9db68083-879f-4439-af4b-6d88d79fef35
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 6383.52
:CPU Vendor: GenuineIntel
:CPU Model: Pentium(R) Dual-Core  CPU      E6700  @ 3.20GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 3203
:System Memory: 3954
:System Swap: 6015
:Vendor: Dell Inc.
:System: Inspiron 560 00
:Form factor: Desktop
:Kernel: 3.5.2-1.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:14902:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #3
:(32902:14916:4136:1081) pci, pcieport, PCI/PCI, 82801JI (ICH10 Family) PCI Express Root Port 3
:(32902:14882:4136:1081) pci, ahci, STORAGE, 82801JI (ICH10 Family) SATA AHCI Controller
:(32902:14912:4136:1081) pci, pcieport, PCI/PCI, 82801JI (ICH10 Family) PCI Express Root Port 1
:(32902:14870:4136:1081) pci, None, PCI/ISA, 82801JIR (ICH10R) LPC Interface Controller
:(4098:26814:4163:824) pci, radeon, VIDEO, Juniper [Radeon HD 5750 Series]
:(5361:23418:112:29764) pci, cx18, MULTIMEDIA_VIDEO, WinTV HVR-1600
:(32902:14910:4136:1081) pci, snd_hda_intel, MULTIMEDIA, 82801JI (ICH10 Family) HD Audio Controller
:(32902:14901:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #2
:(32902:14896:4136:1081) pci, i801_smbus, SERIAL, 82801JI (ICH10 Family) SMBus Controller
:(32902:9294:4136:1081) pci, None, PCI/PCI, 82801 PCI Bridge
:(4332:33128:4136:1081) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:(32902:14900:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #1
:(32902:14903:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #4
:(32902:14904:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #5
:(32902:11808:4136:1081) pci, None, HOST/PCI, 4 Series Chipset DRAM Controller
:(32902:11809:4136:1081) pci, pcieport, PCI/PCI, 4 Series Chipset PCI Express Root Port
:(4098:43608:4163:43608) pci, snd_hda_intel, MULTIMEDIA, Juniper HDMI Audio [Radeon HD 5700 Series]
:(32902:14906:4136:1081) pci, ehci_hcd, USB, 82801JI (ICH10 Family) USB2 EHCI Controller #1
:(32902:14908:4136:1081) pci, ehci_hcd, USB, 82801JI (ICH10 Family) USB2 EHCI Controller #2
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_illuminatus--1-lv_root / ext4 4096 4096 12643503 9362520 8720268 3211264 2812355 2812355
:/dev/sdb5 /boot ext4 1024 1024 495844 446058 420458 128016 127670 127670
:/dev/mapper/vg_illuminatus--1-lv_home /home ext4 4096 4096 6321751 6147698 5826572 1605632 1604560 1604560
:
Comment 1 D. Charles Pyle 2012-08-20 20:09:53 EDT
Created attachment 605799 [details]
File: event_log
Comment 2 D. Charles Pyle 2012-08-20 20:09:55 EDT
Created attachment 605800 [details]
File: backtrace
Comment 3 D. Charles Pyle 2012-08-20 20:09:57 EDT
Created attachment 605801 [details]
File: maps
Comment 4 D. Charles Pyle 2012-08-20 20:09:58 EDT
Created attachment 605802 [details]
File: dso_list
Comment 5 D. Charles Pyle 2012-08-20 20:10:00 EDT
Created attachment 605803 [details]
File: build_ids
Comment 6 D. Charles Pyle 2012-08-20 20:31:38 EDT
I now get a different message from dmesg than before. Before this it was something involving USB. Now it is as follows when the "Firmware for Conexant cx23418-based video capture devices" (package cx18-firmware-20080628-5) is present in /usr/lib/firmware:

$ dmesg | grep tainted
[  254.359309] Pid: 836, comm: Xorg Not tainted 3.5.2-1.fc17.x86_64 #1

If the above firmware is present in the above mentioned directory, crashes in Cheese and in User-Accounts happen that are so severe that ABRT cannot report the crashes. If I remove the firmware, both Cheese and User Accounts function perfectly.

This occurs in both Fedora 17 and LinuxMint 13, with the exception of User Accounts in LinuxMint 13, which User Accounts functions perfectly without crashes regardless of whether or not the Hauppauge firmware is present in /usr/lib/firmware.

I do not have to have the firmware in the folder for Kaffeine to make use of the card. Unfortunately, if I remove the firmware for any length of time more than a few minutes, I start seeing crashes in gnome-settings-daemon every few minutes. I cannot even stay logged on in a Cinnamon session for more than a few seconds without the firmware installed, meaning I cannot even send anything using ABRT.

Tuner card is a Hauppauge WinTV-HVR-1600, model 74041 LF rev. C6B2. These hard crashes did not occur until Fedora 17.
Comment 7 D. Charles Pyle 2012-08-20 20:48:09 EDT
Same problem as before. Trying to get a usable coredump.

backtrace_rating: 4
Package: cheese-3.4.2-3.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 8 D. Charles Pyle 2012-08-20 20:51:26 EDT
Got the following in the terminal window with directed command:

$ cheese& sleep 3; kill -11 %1
[2] 3058
Error: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
[1]-  Segmentation fault      (core dumped) cheese
[2]+  Exit 1                  cheese
bash: kill: %1: no such job

Unfortunately, coredump is too large to send via ABRT. At least, that is what ABRT tells me when I attempt it.
Comment 9 D. Charles Pyle 2012-08-20 21:54:13 EDT
One additional comment: This problem also affects Rawhide (Fedora 18). I have tested both Fedora 17 and Fedora 18 Rawhide and found the same problems with Cheese, User Accounts, and the Hauppauge cx18 firmware (and driver) mentioned above in comment 6 and in the link in comment 1.
Comment 10 Hans de Goede 2012-08-22 05:29:02 EDT

*** This bug has been marked as a duplicate of bug 850505 ***

Note You need to log in before you can comment on or make changes to this bug.