Bug 850505 - On some tv-cards Cheese goes into an infinite loop until oom
On some tv-cards Cheese goes into an infinite loop until oom
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cheese (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
abrt_hash:01a60db6af108e675fd1f7fc804...
:
: 849805 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 13:04 EDT by D. Charles Pyle
Modified: 2012-09-17 18:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-23 19:31:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (28.68 KB, text/plain)
2012-08-21 13:04 EDT, D. Charles Pyle
no flags Details
File: maps (66.91 KB, text/plain)
2012-08-21 13:04 EDT, D. Charles Pyle
no flags Details
File: dso_list (10.43 KB, text/plain)
2012-08-21 13:04 EDT, D. Charles Pyle
no flags Details
File: build_ids (4.16 KB, text/plain)
2012-08-21 13:04 EDT, D. Charles Pyle
no flags Details

  None (edit)
Description D. Charles Pyle 2012-08-21 13:04:10 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        cheese
crash_function: g_private_get_impl
executable:     /usr/bin/cheese
kernel:         3.5.2-1.fc17.x86_64
pid:            29264
pwd:            /home/dcpyle
remote_result:  NOTFOUND
time:           Tue 21 Aug 2012 10:56:00 AM MDT
uid:            1000
username:       dcpyle
xsession_errors: 

backtrace:      Text file, 29364 bytes
build_ids:      Text file, 4264 bytes
dso_list:       Text file, 10677 bytes
maps:           Text file, 68520 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/dcpyle/18

comment:
:I was asked to run 'cheese& sleep 6; kill -11 %1' again to see whether a more interesting backtrace could be generated by the cheese crashing.
:
:Whatever the situation is, it involves something that Cheese, User Accounts, and the Hauppauge cx18 driver and firmware have in common. Remove the firmware and both Cheese and User Accounts work without crashing. Install it and both crash in Fedora 17 and Fedora 18 Rawhide.
:
:On the other hand, something about User Accounts in LinuxMint 13/Ubuntu 12.04 is different as it will run without error with or without the firmware, while Cheese still will not. I'm thinking the user-accounts program or some associated library in Ubuntu's version of that user-accounts application holds the key to solving this problem because it is immune to it while Cheese still succumbs.

core_backtrace:
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x8334f - libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x83ab9 g_private_get libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x61651 g_slice_alloc libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x61bc6 g_slice_alloc0 libglib-2.0.so.0 -
:3461310fc2ad69663f66c1f040de2446a7020130 0x93cf - libcheese.so.3 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x161e3 g_object_newv libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x16560 g_object_new_valist libgobject-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0x5935e g_initable_new_valist libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0x59459 g_initable_new libgio-2.0.so.0 -
:3461310fc2ad69663f66c1f040de2446a7020130 0x95e8 cheese_camera_device_new libcheese.so.3 -
:3461310fc2ad69663f66c1f040de2446a7020130 0xa0d4 cheese_camera_device_monitor_set_up_device libcheese.so.3 -
:3461310fc2ad69663f66c1f040de2446a7020130 0xa1bc - libcheese.so.3 -
:3461310fc2ad69663f66c1f040de2446a7020130 0xa1ff - libcheese.so.3 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x449ed g_list_foreach libglib-2.0.so.0 -
:3461310fc2ad69663f66c1f040de2446a7020130 0xa349 cheese_camera_device_monitor_coldplug libcheese.so.3 -
:3461310fc2ad69663f66c1f040de2446a7020130 0x789d cheese_camera_setup libcheese.so.3 -
:e1a2cf887c436ca480f4fd6dde0293a11ca390ba 0x16539 cheese_main_window_setup_camera [exe] -
:e1a2cf887c436ca480f4fd6dde0293a11ca390ba 0x17584 cheese_main_on_app_activate [exe] -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0xf664 g_closure_invoke libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x206d8 - libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x2866d g_signal_emit_valist libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x287c2 g_signal_emit libgobject-2.0.so.0 -
:e1a2cf887c436ca480f4fd6dde0293a11ca390ba 0x1722c - [exe] -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0x97ec8 g_application_run libgio-2.0.so.0 -
:e1a2cf887c436ca480f4fd6dde0293a11ca390ba 0x177b8 _vala_main [exe] -

environ:
:XDG_VTNR=1
:SSH_AGENT_PID=28272
:XDG_SESSION_ID=18
:HOSTNAME=Illuminatus-1
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/run/user/dcpyle/keyring-EC1jMP/gpg:0:1
:TERM=xterm
:SHELL=/bin/bash
:HISTSIZE=1000
:GJS_DEBUG_OUTPUT=stderr
:WINDOWID=31457285
:GNOME_KEYRING_CONTROL=/run/user/dcpyle/keyring-EC1jMP
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:QT_GRAPHICSSYSTEM_CHECKED=1
:USER=dcpyle
:GST_DEBUG=cheese*:5,camerabin*:5
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.htm=00;33:*.html=00;33:*.shtml=00;33:*.wpd=00;33:
:SSH_AUTH_SOCK=/run/user/dcpyle/keyring-EC1jMP/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/28150,unix/unix:/tmp/.ICE-unix/28150
:USERNAME=dcpyle
:PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/dcpyle/.local/bin:/home/dcpyle/bin
:MAIL=/var/spool/mail/dcpyle
:DESKTOP_SESSION=cinnamon
:QT_IM_MODULE=xim
:PWD=/home/dcpyle
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=28146
:LANG=en_US.utf8
:KDE_IS_PRELINKED=1
:GDM_LANG=en_US.utf8
:KDEDIRS=/usr
:GDMSESSION=cinnamon
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/dcpyle
:SHLVL=2
:GST_DEBUG_NO_COLOR=1
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=dcpyle
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-11CPVZxBUh,guid=a531fd7ab25d8153bd1ec1b90000bd9e
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/dcpyle
:DISPLAY=:0
:QT_PLUGIN_PATH=/usr/lib64/kde4/plugins:/usr/lib/kde4/plugins
:GTK_IM_MODULE=gtk-im-context-simple
:CCACHE_HASHDIR=
:COLORTERM=gnome-terminal
:XAUTHORITY=/var/run/gdm/auth-for-dcpyle-0XcdCo/database
:_=/usr/bin/cheese

event_log:
:2012-08-21-11:02:42> Analyzing coredump 'coredump'
:2012-08-21-11:02:46  All debuginfo files are available
:2012-08-21-11:02:46  Generating backtrace
:2012-08-21-11:02:51  Backtrace is generated and saved, 29364 bytes
:2012-08-21-11:03:06> Element 'xsession_errors' saved
:2012-08-21-11:03:07> Smolt profile successfully saved

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 31459                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       31459                31459                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/pts/0
:pos:	0
:flags:	0100002
:1:/dev/pts/0
:pos:	0
:flags:	0100002
:2:/dev/pts/0
:pos:	0
:flags:	0100002
:3:socket:[1565686]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:socket:[1565689]
:pos:	0
:flags:	02004002
:6:/dev/dri/card0
:pos:	0
:flags:	0100002
:7:socket:[1566728]
:pos:	0
:flags:	02004002
:8:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:9:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:10:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:11:socket:[1566323]
:pos:	0
:flags:	02004002
:12:anon_inode:inotify
:pos:	0
:flags:	02004000
:13:socket:[1566788]
:pos:	0
:flags:	04002
:14:socket:[1566789]
:pos:	0
:flags:	04002
:15:/dev/video1
:pos:	0
:flags:	0100002

smolt_data:
:
:
:General
:=================================
:UUID: 9db68083-879f-4439-af4b-6d88d79fef35
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 6384.02
:CPU Vendor: GenuineIntel
:CPU Model: Pentium(R) Dual-Core  CPU      E6700  @ 3.20GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 3203
:System Memory: 3954
:System Swap: 6015
:Vendor: Dell Inc.
:System: Inspiron 560 00
:Form factor: Desktop
:Kernel: 3.5.2-1.fc17.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:14902:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #3
:(32902:14916:4136:1081) pci, pcieport, PCI/PCI, 82801JI (ICH10 Family) PCI Express Root Port 3
:(32902:14882:4136:1081) pci, ahci, STORAGE, 82801JI (ICH10 Family) SATA AHCI Controller
:(32902:14912:4136:1081) pci, pcieport, PCI/PCI, 82801JI (ICH10 Family) PCI Express Root Port 1
:(32902:14870:4136:1081) pci, None, PCI/ISA, 82801JIR (ICH10R) LPC Interface Controller
:(4098:26814:4163:824) pci, radeon, VIDEO, Juniper [Radeon HD 5750 Series]
:(5361:23418:112:29764) pci, cx18, MULTIMEDIA_VIDEO, WinTV HVR-1600
:(32902:14910:4136:1081) pci, snd_hda_intel, MULTIMEDIA, 82801JI (ICH10 Family) HD Audio Controller
:(32902:14901:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #2
:(32902:14896:4136:1081) pci, i801_smbus, SERIAL, 82801JI (ICH10 Family) SMBus Controller
:(32902:9294:4136:1081) pci, None, PCI/PCI, 82801 PCI Bridge
:(4332:33128:4136:1081) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:(32902:14900:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #1
:(32902:14903:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #4
:(32902:14904:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #5
:(32902:11808:4136:1081) pci, None, HOST/PCI, 4 Series Chipset DRAM Controller
:(32902:11809:4136:1081) pci, pcieport, PCI/PCI, 4 Series Chipset PCI Express Root Port
:(4098:43608:4163:43608) pci, snd_hda_intel, MULTIMEDIA, Juniper HDMI Audio [Radeon HD 5700 Series]
:(32902:14906:4136:1081) pci, ehci_hcd, USB, 82801JI (ICH10 Family) USB2 EHCI Controller #1
:(32902:14908:4136:1081) pci, ehci_hcd, USB, 82801JI (ICH10 Family) USB2 EHCI Controller #2
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_illuminatus--1-lv_root / ext4 4096 4096 12643503 8863271 8221019 3211264 2751804 2751804
:/dev/sdb5 /boot ext4 1024 1024 495844 445531 419931 128016 127669 127669
:/dev/mapper/vg_illuminatus--1-lv_home /home ext4 4096 4096 6321751 5304150 4983024 1605632 1603384 1603384
:

var_log_messages:
:Aug 20 17:58:09 Illuminatus-1 abrt[1771]: Saved core dump of pid 1765 (/usr/bin/cheese) to /var/spool/abrt/ccpp-2012-08-20-17:58:00-1765 (474980352 bytes)
:Aug 20 18:44:08 Illuminatus-1 abrt[3055]: Saved core dump of pid 3034 (/usr/bin/cheese) to /var/spool/abrt/ccpp-2012-08-20-18:43:45-3034 (1509961728 bytes)
:Aug 20 19:46:53 Illuminatus-1 yum[3649]: Installed: 2:cheese-libs-devel-3.4.2-3.fc17.x86_64
:Aug 21 10:36:06 Illuminatus-1 kernel: [49999.305319] cheese invoked oom-killer: gfp_mask=0x280da, order=0, oom_adj=0, oom_score_adj=0
:Aug 21 10:36:06 Illuminatus-1 kernel: [49999.306452] cheese cpuset=/ mems_allowed=0
:Aug 21 10:36:06 Illuminatus-1 kernel: [49999.307557] Pid: 29115, comm: cheese Not tainted 3.5.2-1.fc17.x86_64 #1
:Aug 21 10:36:06 Illuminatus-1 kernel: [49999.479952] [29115]  1000 29115  2550162   926483   0       0             0 cheese
:Aug 21 10:36:06 Illuminatus-1 kernel: [49999.481402] Out of memory: Kill process 29115 (cheese) score 926 or sacrifice child
:Aug 21 10:36:06 Illuminatus-1 kernel: [49999.482136] Killed process 29115 (cheese) total-vm:10200648kB, anon-rss:3705924kB, file-rss:8kB
:Aug 21 10:56:18 Illuminatus-1 abrt[29271]: Saved core dump of pid 29264 (/usr/bin/cheese) to /var/spool/abrt/ccpp-2012-08-21-10:56:00-29264 (1243484160 bytes)
Comment 1 D. Charles Pyle 2012-08-21 13:04:14 EDT
Created attachment 605988 [details]
File: backtrace
Comment 2 D. Charles Pyle 2012-08-21 13:04:15 EDT
Created attachment 605989 [details]
File: maps
Comment 3 D. Charles Pyle 2012-08-21 13:04:17 EDT
Created attachment 605990 [details]
File: dso_list
Comment 4 D. Charles Pyle 2012-08-21 13:04:18 EDT
Created attachment 605991 [details]
File: build_ids
Comment 5 Hans de Goede 2012-08-22 05:29:02 EDT
*** Bug 849805 has been marked as a duplicate of this bug. ***
Comment 6 Hans de Goede 2012-08-22 05:35:19 EDT
Hi,

Ok, so thanks to this backtrace, and the logs provided in bug 810429, it is now clear what is going on.

The cx18 tvcard driver is reporting that in capture at a minimum resolution of 0x0, which causes cheese to go into an infinite loop in cheese_camera_device_update_format_table(), until it runs out of memory.

An updated package (hopefully) fixing this is now building here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4413018

Once that has complete building, download the cheese and cheese-libs rpm for your architecture and then as root run:
rpm -Uvh cheese*.rpm

After that start cheese and the problem should be gone.

Regards,

Hans
Comment 7 Fedora Update System 2012-08-22 06:00:27 EDT
cheese-3.4.2-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/cheese-3.4.2-4.fc17
Comment 8 Fedora Update System 2012-08-22 06:02:32 EDT
cheese-3.5.5-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/cheese-3.5.5-1.fc18
Comment 9 Fedora Update System 2012-08-22 16:57:40 EDT
Package cheese-3.4.2-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cheese-3.4.2-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12472/cheese-3.4.2-4.fc17
then log in and leave karma (feedback).
Comment 10 D. Charles Pyle 2012-08-22 18:13:51 EDT
Installed the updates from koji (I didn't want to wait). Cheese now no longer crashes. I also noticed that System Settings | User Accounts loads correctly without crashing now, so whatever was fixed here helped to fix the other problem somehow.

Thanks again and two positive karma were left. I am about to restart my system to make sure the fix continues to work. I am pretty sure it will. :-)
Comment 11 Hans de Goede 2012-08-23 03:33:18 EDT
(In reply to comment #10)
> Installed the updates from koji (I didn't want to wait). Cheese now no
> longer crashes.

That is good news. Thanks for all the time you spend on helping debug this!

Note the fix has also been send upstream and is also committed there, so it should make it into other distros when they upgrade cheese too, see:
https://bugzilla.gnome.org/show_bug.cgi?id=682443

> I also noticed that System Settings | User Accounts loads
> correctly without crashing now, so whatever was fixed here helped to fix the
> other problem somehow.

That is because System Settings | User Accounts uses libcheese to access the webbam :)
Comment 12 D. Charles Pyle 2012-08-23 15:05:40 EDT
Regarding the cheese-libs, I figured as much when I saw that user-accounts stopped crashing and I realized that there was the option to take a picture directly from within user-accounts.

I enjoyed trying to figure this "show-stopper" out. I just wish I could remember my programming. Since the carbon momoxide poisoning, things have not come as easily to me as they used to do and I have forgotten most of my programming knowledge anyway. Thanks for helping me help you get this long-standing problem fixed. There are a lot of people who were affected by this but mostly did not report it so it could not be fixed.

Now maybe there will be less complaints about "cheese problems" now that this has been fixed.

There is one more annoyance that needs fixing but it is simply a matter of dependencies for the cheese effects that often do not work on a fresh install. Some effects don't work unless frei0r-plugins is also installed. After you fixed the original problem I noticed that certain effects weren't working and I was seeing errors in the terminal window about certain effects.

Installing frei0r-plugins stopped those error messages and all effects now are working without crashes. I had one that took out X.org and logged me off but I have not seen this since installing frei0r-plugins.

Thanks again.
Comment 13 Fedora Update System 2012-08-23 19:31:50 EDT
cheese-3.4.2-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Hans de Goede 2012-08-24 04:53:11 EDT
(In reply to comment #12)
> There is one more annoyance that needs fixing but it is simply a matter of
> dependencies for the cheese effects that often do not work on a fresh
> install. Some effects don't work unless frei0r-plugins is also installed.
> After you fixed the original problem I noticed that certain effects weren't
> working and I was seeing errors in the terminal window about certain effects.
> 
> Installing frei0r-plugins stopped those error messages and all effects now
> are working without crashes.

Ah, thanks for letting us know about the missing Requires, for F-17 I've added
it to cheese itself, but not yet done a build, as I expect there probably will be
a new build soon-ish for more bug-fixes.

For F-18 and rawhide, I've instead added the Requires to gnome-video-effects,
where it actually belongs.
Comment 15 Yanko Kaneti 2012-08-24 05:51:36 EDT
As the gnome-video-effects maintainer I don't think adding the dependencies to gnome-video-effects is the right thing to do here, that's why I didn't add them in the first place...
I think cheese should be checking the available gst filters and limit the list of available effects on runtime.
Comment 16 Hans de Goede 2012-08-24 06:08:29 EDT
Hi,

(In reply to comment #15)
> As the gnome-video-effects maintainer I don't think adding the dependencies
> to gnome-video-effects is the right thing to do here, that's why I didn't
> add them in the first place...
> I think cheese should be checking the available gst filters and limit the
> list of available effects on runtime.

First of all, sorry for pushing through changes to your package which you did not want, I did not expect
these changes to be controversial.

So I think we should answer 2 questions here:

1) Should cheese directly or indirectly Require the necessary plugins for all effects to work ?

2) Where do those Requires belong ?

To me, the answer to 1. is: yes. Yes, it is possible to make cheese not show effects which won't work due to missing plugins, but how will a normal end user (so not a techie) ever find out that there are more effects, and that he should do a "yum install frei0r-plugins" to get those?

The answer to 2 is somewhat harder. Since gnome-video-effects defines the pipelines for the effects, it knows exactly which plugins are needed, and as those may change over time, it makes sense to keep the Requires with the definitions of the pipelines, so that they can easily be updated. So, to me gnome-video-effects seems the right place for those Requires. But if you disagree I'm fine with moving them over to cheese.

Regards,

Hans
Comment 17 Yanko Kaneti 2012-08-24 06:33:43 EDT
Ideally the cheese effects list will only have the ones with already installed pipeline requirements. And there will be a "Get more.." button that will lead to an appstore like page for aditionall effects. 

I am not really going to work on any of this so I am not going to fret too much about the requirements you added. I'll contact you for transferring gnome-video-effects maintainership.
Comment 18 Fedora Update System 2012-09-17 18:22:35 EDT
cheese-3.5.5-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.