Bug 851230 - [abrt] util-linux-2.21.2-2.fc17: probe_ntfs: Process /usr/sbin/blkid was killed by signal 11 (SIGSEGV)
[abrt] util-linux-2.21.2-2.fc17: probe_ntfs: Process /usr/sbin/blkid was kill...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
abrt_hash:93420507deb75ee433963f731d2...
:
: 853719 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 10:27 EDT by D. Charles Pyle
Modified: 2013-02-01 09:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 09:43:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (17.18 KB, text/plain)
2012-08-23 10:27 EDT, D. Charles Pyle
no flags Details
File: coredump (412.00 KB, text/plain)
2012-08-23 10:27 EDT, D. Charles Pyle
no flags Details
File: var_log_messages (9.25 KB, text/plain)
2012-08-23 10:27 EDT, D. Charles Pyle
no flags Details
sda3.img file requested (3.00 MB, application/x-gzip)
2012-08-24 19:49 EDT, D. Charles Pyle
no flags Details
Debug text file (8.00 KB, application/octet-stream)
2012-08-24 20:04 EDT, D. Charles Pyle
no flags Details

  None (edit)
Description D. Charles Pyle 2012-08-23 10:27:45 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        blkid
crash_function: probe_ntfs
executable:     /usr/sbin/blkid
kernel:         3.5.2-3.fc17.x86_64
pid:            2819
pwd:            /root
remote_result:  NOTFOUND
time:           Thu 23 Aug 2012 01:38:00 AM MDT
uid:            0
username:       root

backtrace:      Text file, 17594 bytes
var_log_messages: Text file, 9477 bytes

build_ids:
:e7ffcbe93e2a666b0a7d79f50cf1c64d30da94ab
:ebc779125d37b2b0595730b6d78d477fe7b6bc53
:da0831cf9c551543fbc94e797a102a57a30e790f
:8cf5c11adfa4d5efb8d06e5d356eb4b0643e1680
:6ea05195018eb2e7efb545d3cbdec19ab3680ec4

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/dcpyle/2

comment:
:Ran blkid. Segfault resulted afterward. This happens all the time since two rounds of updates. I do not know the cause, however. The NTFS filesystem is clean. I have checked and rechecked it several times over the last couple days when the problem began. Yet, the following error occurs at the start of the boot sequence:
:
:udevd[115]: worker [218] terminated by signal 11 (segmentation fault)
:udevd[115]: worker [218] failed while handling '/devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/000:0/block/sda/sda3'
:
:The drive is, however, SATA running in AHCI mode. It is GPT partitioned and formatted but this has not been a problem before.

core_backtrace:
:8cf5c11adfa4d5efb8d06e5d356eb4b0643e1680 0x149de - libblkid.so.1 -
:8cf5c11adfa4d5efb8d06e5d356eb4b0643e1680 0x11d1e - libblkid.so.1 -
:8cf5c11adfa4d5efb8d06e5d356eb4b0643e1680 0x11ffb - libblkid.so.1 -
:8cf5c11adfa4d5efb8d06e5d356eb4b0643e1680 0xb394 blkid_do_safeprobe libblkid.so.1 -
:8cf5c11adfa4d5efb8d06e5d356eb4b0643e1680 0xd484 blkid_verify libblkid.so.1 -
:8cf5c11adfa4d5efb8d06e5d356eb4b0643e1680 0x74ab blkid_get_dev libblkid.so.1 -
:8cf5c11adfa4d5efb8d06e5d356eb4b0643e1680 0x778b - libblkid.so.1 -
:8cf5c11adfa4d5efb8d06e5d356eb4b0643e1680 0x8116 - libblkid.so.1 -
:8cf5c11adfa4d5efb8d06e5d356eb4b0643e1680 0x846d blkid_probe_all libblkid.so.1 -
:e7ffcbe93e2a666b0a7d79f50cf1c64d30da94ab 0x32d0 - [exe] -

dso_list:
:/usr/sbin/blkid util-linux-2.21.2-2.fc17.x86_64 (Fedora Project) 1345703502
:/usr/lib64/libblkid.so.1.1.0 libblkid-2.21.2-2.fc17.x86_64 (Fedora Project) 1345688903
:/usr/lib64/libc-2.15.so glibc-2.15-56.fc17.x86_64 (Fedora Project) 1345470819
:/usr/lib64/libuuid.so.1.3.0 libuuid-2.21.2-2.fc17.x86_64 (Fedora Project) 1345470838
:/usr/lib64/ld-2.15.so glibc-2.15-56.fc17.x86_64 (Fedora Project) 1345470819

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=Illuminatus-1
:SHELL=/bin/bash
:TERM=xterm
:HISTSIZE=1000
:QTDIR=/usr/lib64/qt-3.3
:QTINC=/usr/lib64/qt-3.3/include
:QT_GRAPHICSSYSTEM_CHECKED=1
:USER=root
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.htm=00;33:*.html=00;33:*.shtml=00;33:*.wpd=00;33:
:MAIL=/var/spool/mail/root
:PATH=/usr/lib64/qt-3.3/bin:/usr/lib64/ccache:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin
:PWD=/root
:LANG=en_US.UTF-8
:KDE_IS_PRELINKED=1
:KDEDIRS=/usr
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:SHLVL=1
:XDG_SEAT=seat0
:HOME=/root
:LOGNAME=root
:QTLIB=/usr/lib64/qt-3.3/lib
:CVS_RSH=ssh
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/dcpyle
:QT_PLUGIN_PATH=/usr/lib64/kde4/plugins:/usr/lib/kde4/plugins
:CCACHE_HASHDIR=
:XAUTHORITY=/root/.xautht3T9Z1
:_=/sbin/blkid

event_log:
:2012-08-23-08:26:08> Analyzing coredump 'coredump'
:2012-08-23-08:26:09  All debuginfo files are available
:2012-08-23-08:26:09  Generating backtrace
:2012-08-23-08:26:09  Backtrace is generated and saved, 17594 bytes
:2012-08-23-08:26:18> Smolt profile successfully saved

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 31451                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       31451                31451                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

maps:
:00400000-00407000 r-xp 00000000 fd:01 1209058                            /usr/sbin/blkid
:00606000-00607000 r--p 00006000 fd:01 1209058                            /usr/sbin/blkid
:00607000-00608000 rw-p 00007000 fd:01 1209058                            /usr/sbin/blkid
:01df9000-01e1a000 rw-p 00000000 00:00 0                                  [heap]
:7f7cc487f000-7f7cc4a2b000 r-xp 00000000 fd:01 1193052                    /usr/lib64/libc-2.15.so
:7f7cc4a2b000-7f7cc4c2b000 ---p 001ac000 fd:01 1193052                    /usr/lib64/libc-2.15.so
:7f7cc4c2b000-7f7cc4c2f000 r--p 001ac000 fd:01 1193052                    /usr/lib64/libc-2.15.so
:7f7cc4c2f000-7f7cc4c31000 rw-p 001b0000 fd:01 1193052                    /usr/lib64/libc-2.15.so
:7f7cc4c31000-7f7cc4c36000 rw-p 00000000 00:00 0 
:7f7cc4c36000-7f7cc4c3a000 r-xp 00000000 fd:01 1206969                    /usr/lib64/libuuid.so.1.3.0
:7f7cc4c3a000-7f7cc4e39000 ---p 00004000 fd:01 1206969                    /usr/lib64/libuuid.so.1.3.0
:7f7cc4e39000-7f7cc4e3a000 r--p 00003000 fd:01 1206969                    /usr/lib64/libuuid.so.1.3.0
:7f7cc4e3a000-7f7cc4e3b000 rw-p 00004000 fd:01 1206969                    /usr/lib64/libuuid.so.1.3.0
:7f7cc4e3b000-7f7cc4e5f000 r-xp 00000000 fd:01 1193717                    /usr/lib64/libblkid.so.1.1.0
:7f7cc4e5f000-7f7cc505e000 ---p 00024000 fd:01 1193717                    /usr/lib64/libblkid.so.1.1.0
:7f7cc505e000-7f7cc5061000 r--p 00023000 fd:01 1193717                    /usr/lib64/libblkid.so.1.1.0
:7f7cc5061000-7f7cc5062000 rw-p 00026000 fd:01 1193717                    /usr/lib64/libblkid.so.1.1.0
:7f7cc5062000-7f7cc5082000 r-xp 00000000 fd:01 1207059                    /usr/lib64/ld-2.15.so
:7f7cc524f000-7f7cc5253000 rw-p 00000000 00:00 0 
:7f7cc527f000-7f7cc5281000 rw-p 00000000 00:00 0 
:7f7cc5281000-7f7cc5282000 r--p 0001f000 fd:01 1207059                    /usr/lib64/ld-2.15.so
:7f7cc5282000-7f7cc5283000 rw-p 00020000 fd:01 1207059                    /usr/lib64/ld-2.15.so
:7f7cc5283000-7f7cc5284000 rw-p 00000000 00:00 0 
:7fffd9502000-7fffd9523000 rw-p 00000000 00:00 0                          [stack]
:7fffd955a000-7fffd955b000 r-xp 00000000 00:00 0                          [vdso]
:ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]

open_fds:
:0:/dev/pts/0
:pos:	0
:flags:	0100002
:1:/dev/pts/0
:pos:	0
:flags:	0100002
:2:/dev/pts/0
:pos:	0
:flags:	0100002
:3:/proc/partitions
:pos:	504
:flags:	0100000
:4:/dev/sda3
:pos:	3221229568
:flags:	0100000

smolt_data:
:
:
:General
:=================================
:UUID: 9db68083-879f-4439-af4b-6d88d79fef35
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 6383.97
:CPU Vendor: GenuineIntel
:CPU Model: Pentium(R) Dual-Core  CPU      E6700  @ 3.20GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 3203
:System Memory: 3954
:System Swap: 6015
:Vendor: Dell Inc.
:System: Inspiron 560 00
:Form factor: Desktop
:Kernel: 3.5.2-3.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Permissive
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:14902:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #3
:(32902:14916:4136:1081) pci, pcieport, PCI/PCI, 82801JI (ICH10 Family) PCI Express Root Port 3
:(32902:14882:4136:1081) pci, ahci, STORAGE, 82801JI (ICH10 Family) SATA AHCI Controller
:(32902:14912:4136:1081) pci, pcieport, PCI/PCI, 82801JI (ICH10 Family) PCI Express Root Port 1
:(32902:14870:4136:1081) pci, None, PCI/ISA, 82801JIR (ICH10R) LPC Interface Controller
:(4098:26814:4163:824) pci, radeon, VIDEO, Juniper [Radeon HD 5750 Series]
:(5361:23418:112:29764) pci, cx18, MULTIMEDIA_VIDEO, WinTV HVR-1600
:(32902:14910:4136:1081) pci, snd_hda_intel, MULTIMEDIA, 82801JI (ICH10 Family) HD Audio Controller
:(32902:14901:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #2
:(32902:14896:4136:1081) pci, i801_smbus, SERIAL, 82801JI (ICH10 Family) SMBus Controller
:(32902:9294:4136:1081) pci, None, PCI/PCI, 82801 PCI Bridge
:(4332:33128:4136:1081) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:(32902:14900:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #1
:(32902:14903:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #4
:(32902:14904:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #5
:(32902:11808:4136:1081) pci, None, HOST/PCI, 4 Series Chipset DRAM Controller
:(32902:11809:4136:1081) pci, pcieport, PCI/PCI, 4 Series Chipset PCI Express Root Port
:(4098:43608:4163:43608) pci, snd_hda_intel, MULTIMEDIA, Juniper HDMI Audio [Radeon HD 5700 Series]
:(32902:14906:4136:1081) pci, ehci_hcd, USB, 82801JI (ICH10 Family) USB2 EHCI Controller #1
:(32902:14908:4136:1081) pci, ehci_hcd, USB, 82801JI (ICH10 Family) USB2 EHCI Controller #2
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_illuminatus--1-lv_root / ext4 4096 4096 12643503 8629771 7987519 3211264 2734847 2734847
:/dev/sdb5 /boot ext4 1024 1024 495844 419100 393500 128016 127663 127663
:/dev/mapper/vg_illuminatus--1-lv_home /home ext4 4096 4096 6321751 5267107 4945981 1605632 1604368 1604368
:
Comment 1 D. Charles Pyle 2012-08-23 10:27:51 EDT
Created attachment 606621 [details]
File: backtrace
Comment 2 D. Charles Pyle 2012-08-23 10:27:53 EDT
Created attachment 606622 [details]
File: coredump
Comment 3 D. Charles Pyle 2012-08-23 10:27:56 EDT
Created attachment 606623 [details]
File: var_log_messages
Comment 4 D. Charles Pyle 2012-08-23 19:40:27 EDT
dmesg report for this error:

$ dmesg | grep udevd
[    1.815495] udevd[115]: starting version 182
[    2.490099] udevd[221]: segfault at 7f0894ece79c ip 00007f09006a99de sp 00007fff3dda4080 error 4 in libblkid.so.1.1.0[7f0900695000+24000]
[    7.318858] udevd[417]: starting version 182
[   11.676059] udevd[469]: segfault at 7f8b02e4027c ip 00007f8b6e4789de sp 00007fff124bf540 error 4 in libblkid.so.1.1.0[7f8b6e464000+24000]
Comment 5 Karel Zak 2012-08-24 14:05:58 EDT
D. Charles, would be possible to get the begin of the device /dev/sda3
? It seems like ntfs, but somehow uneatable for libblkid.

 # dd if=/dev/sda3 of=/root/sda3.img bs=1MiB count=10
 # gzip sda3.img

It would be also nice to see debug output from blkid:

 # LIBBLKID_DEBUG=0xffff blkid -p /dev/sd3 -o udev &> sda3.debug

Thanks for your report!
Comment 6 D. Charles Pyle 2012-08-24 19:49:36 EDT
Created attachment 606970 [details]
sda3.img file requested

Here is the image of the first part of /dev/sda3 you requested.

It is NTFS but the partition was created from within Mac OS X using BootCamp and formatted NTFS using the Windows 7 installer. It resides on a GPT partitioned hard drive, whereas Fedora 17 resides on a second hard disk drived partitioned MBR.

I'll upload the debugging output in a few moments.
Comment 7 D. Charles Pyle 2012-08-24 20:04:16 EDT
Created attachment 606971 [details]
Debug text file

Here is the debugging text file created with the third command provided. Hope it helps.

These disks are not RAID configured and I noticed that there was no entry for NTFS in the list of probings for file systems. Could that be significant?

One other thing: I recently switched to LinuxMint 13 temporarily so that I could try to find a solution to a problem I was having with Cheese and user-accounts. I did this before the two rounds of updates after reinstalling Fedora 17 cleanly.

I recently read about somebody that had corruption of their NTFS filesystems after using Ubuntu 12.04LTS (upon which LinuxMint 13 was built) and switched back to Windows 7 because of it.

Also, I had a similar problem to this above bug back in Fedora 15 and early Fedora 16 before updates fixed the problem and I had the use of this partition from boot. In spite of the problem I am able to mount it using the mount command but blkid seems not to like the same partition again. I am wondering if there isn't a regression somewhere but don't know.

In any case, I have run multiple utilities in both Windows and Linux to try to find the filesystem problem and fix it but none of the tools report any errors after chkdsk fixed a bunch of them after booting into Windows 7 after the Fedora 17 reinstall and updates.

Let me know if you need anything else.
Comment 8 D. Charles Pyle 2012-08-24 20:08:16 EDT
This happened when I ran LIBBLKID_DEBUG=0xffff blkid -p /dev/sda3 -o udev &> sda3.debug at the request of Karel Zak.

backtrace_rating: 4
Package: util-linux-2.21.2-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 9 D. Charles Pyle 2012-08-25 04:21:42 EDT
Here is information about the NTFS partitions from the Windows 7 side:

C:\Windows\system32>fsutil fsinfo ntfsinfo c:
NTFS Volume Serial Number :       0xb0f2fddef2fda92c
Version :                         3.1
Number Sectors :                  0x00000000deda3fff
Total Clusters :                  0x000000001bdb47ff
Free Clusters  :                  0x0000000012c23183
Total Reserved :                  0x00000000000007b0
Bytes Per Sector  :               512
Bytes Per Physical Sector :       512
Bytes Per Cluster :               4096
Bytes Per FileRecord Segment    : 1024
Clusters Per FileRecord Segment : 0
Mft Valid Data Length :           0x000000002c840000
Mft Start Lcn  :                  0x00000000000c0000
Mft2 Start Lcn :                  0x0000000000000002
Mft Zone Start :                  0x0000000001ca7f80
Mft Zone End   :                  0x0000000001cb47a0
RM Identifier:        961CA9D4-8A81-19E0-9777-AF841D75C60D

C:\Windows\system32>fsutil fsinfo ntfsinfo d:
NTFS Volume Serial Number :       0xb2de3c8ede3c4d3b
Version :                         3.1
Number Sectors :                  0x0000000068b907ff
Total Clusters :                  0x000000000d1720ff
Free Clusters  :                  0x000000000c4e5f03
Total Reserved :                  0x00000000000004b0
Bytes Per Sector  :               512
Bytes Per Physical Sector :       512
Bytes Per Cluster :               4096
Bytes Per FileRecord Segment    : 1024
Clusters Per FileRecord Segment : 0
Mft Valid Data Length :           0x000000000f900000
Mft Start Lcn  :                  0x00000000000c0000
Mft2 Start Lcn :                  0x0000000000000002
Mft Zone Start :                  0x000000000223b500
Mft Zone End   :                  0x0000000002247d20
RM Identifier:        4747E3E4-7D0F-19E0-83EA-B8AC6FE4F925

C:\Windows\system32>

Note:
Windows' C: = /dev/sda3 in Linux.
Windows' D: = /dev/sdb3 in Linux.
Comment 10 D. Charles Pyle 2012-09-03 00:09:54 EDT
I've been testing the new version of the files I compiled from the modified sources to which you referred me. I also found it useful enough to copy over into the respective locations where the original files were located.

Aside from the following error I see in dmesg...

$ dmesg | grep udev
[    1.763226] udevd[115]: starting version 182
[    2.423559] udevd[203]: segfault at 7f7a1d2a9a9c ip 00007f7a88aef9de sp 00007fff955b4a60 error 4 in libblkid.so.1.1.0[7f7a88adb000+24000]
[    6.767366] udevd[420]: starting version 182

...the new version of the util-linux files seems to have made things work again. I now can mount the partition using the link in the Devices section of the sidebar in Nautilus. I can copy and move files to and from the BOOTCAMP NTFS partition on the first hard drive like I used to do.

So far, I have seen no obvious signs of corruption of the partition data. I run chkdsk in read-only mode regularly to see if anything is found. So far, so good.

Thanks for helping me with this. Let me know if there is anything else I can do to help you help me and others.
Comment 11 D. Charles Pyle 2012-09-03 13:41:45 EDT
After a new kernel version and a couple other sets of updates I now see:

$ dmesg | grep udev
[    1.818604] udevd[115]: starting version 182
[    7.610723] udevd[420]: starting version 182

In other words, I no longer see a segfault where I did.
Comment 12 Karel Zak 2012-09-06 06:42:38 EDT
*** Bug 853719 has been marked as a duplicate of this bug. ***
Comment 13 Fedora Update System 2012-09-06 08:08:33 EDT
util-linux-2.22-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/util-linux-2.22-1.fc18
Comment 14 Fedora Update System 2012-09-17 18:00:56 EDT
util-linux-2.22-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.