Bug 851280 - Text stops drawing in fedora 17 gnome with Intel graphics
Text stops drawing in fedora 17 gnome with Intel graphics
Status: CLOSED DUPLICATE of bug 852210
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 12:34 EDT by James Rankin
Modified: 2013-07-29 01:04 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-05 18:49:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example of problem (70.07 KB, image/png)
2012-08-23 12:34 EDT, James Rankin
no flags Details
example 2 (121.40 KB, image/png)
2012-08-23 12:35 EDT, James Rankin
no flags Details
xorg log (68.33 KB, text/x-log)
2012-08-23 12:35 EDT, James Rankin
no flags Details
dmesg (76.51 KB, text/plain)
2012-08-23 12:35 EDT, James Rankin
no flags Details
Text corruption/missing text (117.51 KB, image/png)
2012-08-31 05:46 EDT, redhat-bugzilla
no flags Details

  None (edit)
Description James Rankin 2012-08-23 12:34:39 EDT
Created attachment 606647 [details]
example of problem

I do not know if this is really a problem related to Intel graphics or lies elsewhere in the stack. Please let me know what information I can provide to help determine the cause.

For several weeks now, I've noticed that my fedora 17 desktop stops drawing some items of text and UI buttons after being up for more than one day. I've attached two examples of what the problem looks like in Firefox, though this seems to occur in all applications.

Once text fails to draw, I can simply move the mouse cursor over the text to cause it to draw correctly. Sometimes the text stays visible, and sometimes is quickly disappears again.

Rebooting has, so far, been the only fix... though the problem reappears after the laptop is up for over a day. Coincidence or not, the problem has not occurred within one day of reboot.

With the most recent few instances of this problem, the laptop has not been suspended at all. It's been up and in a docking station with a DVI monitor the entire time.

I have a separate computer running an equally up to date F17 install on nvidia graphics, and it's never exhibited this problem.


Steps to Reproduce:
Using up to date F17 with Intel graphics, run laptop continually for more than one day and observe intermittent instances of text failing to draw on the screen
  

Currently using:
xorg-x11-drv-intel-2.20.1-1.fc17.x86_64
kernel-3.5.2-1.fc17.x86_64


00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
	Subsystem: Lenovo Device 215a
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 41
	Region 0: Memory at f2000000 (64-bit, non-prefetchable) [size=4M]
	Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Region 4: I/O ports at 1800 [size=8]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
		Address: fee0f00c  Data: 4171
	Capabilities: [d0] Power Management version 2
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [a4] PCI Advanced Features
		AFCap: TP+ FLR+
		AFCtrl: FLR-
		AFStatus: TP-
	Kernel driver in use: i915
Comment 1 James Rankin 2012-08-23 12:35:08 EDT
Created attachment 606648 [details]
example 2
Comment 2 James Rankin 2012-08-23 12:35:31 EDT
Created attachment 606649 [details]
xorg log
Comment 3 James Rankin 2012-08-23 12:35:50 EDT
Created attachment 606651 [details]
dmesg
Comment 4 redhat-bugzilla 2012-08-31 05:45:19 EDT
I can confirm the same issue on a Dell Latitude E4300 with Intel GMA X4500HD graphics.

My machine is usually in a docking station with 2 x DVI outputs running 2 x 1920x1080 monitors, and similarly to James I see the issue after usually some uptime, have seen the issue for the past few weeks, and restarting fixes the issue for a while.

I'm running Gnome Shell and restarting it or the X server doesn't help.

Kernel: 3.5.2-1.fc17.x86_64
xorg-x11-drv-intel-2.20.1-1fc17.x86_64
Comment 5 redhat-bugzilla 2012-08-31 05:46:37 EDT
Created attachment 608453 [details]
Text corruption/missing text
Comment 6 jeremiah.mans 2012-08-31 14:36:10 EDT
Same effect observed on an Lenovo T410s, when using an external monitor, using "duplicate display" mode of operation.  Extremely frustrating.
Comment 7 Jürgen Geuter 2012-09-07 07:31:44 EDT
Same problem with a Dell Latitude E5400 Laptop and an Intel Integrated Graphics card.
Comment 8 Eyal Edri 2012-09-09 04:01:17 EDT
I can confirm this happens also Lenovo T510 model on dual external monitors.
Comment 9 John Eckersberg 2012-09-12 13:43:27 EDT
This happens for me with a Lenovo T510, on docking station with one external DVI monitor.  Laptop lid is closed, so the external display is the only active screen.

I haven't noticed this behavior when using the laptop undocked and disconnected from external displays, but I can't be 100% sure it doesn't happen in that configuration.  I don't go undocked very often or for prolonged periods of time.
Comment 10 thohai 2012-09-24 11:17:22 EDT
Hi!

Same problem as described by the other users - on a Lenovo X201s with external 1920x1090 monitor. Connected via dockingstation display port (displayport->dvi adapter).

I have the graphics problems on both displays. Although in some cases moving the application (e.g. Thunderbird) from the big monitor to the laptop display fixed the problem.
Comment 11 Jon 2012-09-25 10:33:04 EDT
I also have this problem, it started about the same time as the first 3.5 kernel came out.  I have the Lenova T510 (intel graphics, same lspci post as the OP)

Kernel: Linux oz3 3.5.4-1.fc17.x86_64 #1 SMP Mon Sep 17 15:03:59 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
X driver: xorg-x11-drv-intel-2.20.8-1.fc17.x86_64
Comment 12 Havoc Pennington 2012-10-01 20:21:01 EDT
Also on T510. Using two monitors (external displayport and laptop panel) with a single X screen. It has to do with the kernel version. 3.4.4-5.fc17.i686.PAE works for me. Everything I've updated to after that (including latest, I updated and rebooted this morning) does not work for me: a little while after starting to use the desktop, text starts failing to repaint. It gets worse over time - at first it works, but text fails to render more and more often until things are completely unusable.
The laptop has an nvidia chip in it too, but it's disabled in BIOS; just using the intel.

xorg-x11-drv-intel-2.20.8-1.fc17.i686

kernel-PAE-3.5.4-2.fc17.i686  - broken
kernel-PAE-3.5.2-3.fc17.i686  - broken
kernel-PAE-3.4.4-5.fc17.i686  - works

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
        Subsystem: Lenovo Device 21d9
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 42
        Region 0: Memory at f8800000 (64-bit, non-prefetchable) [size=4M]
        Region 2: Memory at f0000000 (64-bit, prefetchable) [size=128M]
        Region 4: I/O ports at 1800 [size=8]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
                Address: fee0f00c  Data: 4179
        Capabilities: [d0] Power Management version 2
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [a4] PCI Advanced Features
                AFCap: TP+ FLR+
                AFCtrl: FLR-
                AFStatus: TP-
        Kernel driver in use: i915
Comment 13 Martin Kosek 2012-10-05 08:45:47 EDT
I also have this issue on my T510, docked and with external monitor connected. I am using 

lspci output:
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
	Subsystem: Lenovo Device 215a
	Flags: bus master, fast devsel, latency 0, IRQ 41
	Memory at f2000000 (64-bit, non-prefetchable) [size=4M]
	Memory at d0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 1800 [size=8]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [d0] Power Management version 2
	Capabilities: [a4] PCI Advanced Features
	Kernel driver in use: i915

packages version:
xorg-x11-drv-intel-2.20.8-1.fc17.x86_64
kernel-3.5.4-2.fc17.x86_64
gnome-shell-3.4.1-6.fc17.x86_64

Any updates on this issue? These rendering issues are really disturbing. A workaround would be very appreciated.
Comment 14 Havoc Pennington 2012-10-05 08:54:53 EDT
Martin, downgrading to kernel 3.4.4-5 works around it for me. (Fortunately, since the computer is not usable with this bug.)
Comment 15 Dave Airlie 2012-10-05 18:49:34 EDT
guys duplicate, please test the scratch kernel if its still around, trying to get intel to work it out.

*** This bug has been marked as a duplicate of bug 852210 ***
Comment 16 Martin Kosek 2012-10-10 02:54:39 EDT
(In reply to comment #14)
> Martin, downgrading to kernel 3.4.4-5 works around it for me. (Fortunately,
> since the computer is not usable with this bug.)

Thanks Havoc for this suggestion, this is what I did on my box. I will stick with 3.4.* kernels until this bug is resolved as it can be really annoying.

Note You need to log in before you can comment on or make changes to this bug.