Bug 852210 - [Arrandale] Text disappearing in Firefox and Terminal
[Arrandale] Text disappearing in Firefox and Terminal
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
: 851280 867249 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 17:25 EDT by Richard W.M. Jones
Modified: 2013-02-08 16:37 EST (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 869856 (view as bug list)
Environment:
Last Closed: 2012-12-20 10:12:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (184.64 KB, image/png)
2012-08-27 17:25 EDT, Richard W.M. Jones
no flags Details
Xorg.0.log (36.25 KB, text/x-log)
2012-08-27 17:25 EDT, Richard W.M. Jones
no flags Details
syslog with assert (17.67 KB, text/plain)
2012-11-05 02:16 EST, David Juran
no flags Details

  None (edit)
Description Richard W.M. Jones 2012-08-27 17:25:01 EDT
Created attachment 607348 [details]
Screenshot

Description of problem:

I don't have a way to reproduce this, and there's nothing significant
in the logs, but this laptop has got itself into a state where text
is disappearing all over the place, seemingly in all applications.
See the attached screenshot.

Version-Release number of selected component (if applicable):

[   180.629] Build Date: 08 August 2012  09:55:23AM
[   180.631] Build ID: xorg-x11-server 1.12.99.904-1.20120808.fc18 

How reproducible:

? Just once.

Steps to Reproduce:
1. Unknown.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Richard W.M. Jones 2012-08-27 17:25:48 EDT
Created attachment 607349 [details]
Xorg.0.log
Comment 2 Dave Airlie 2012-08-27 17:48:13 EDT
rpm -q xorg-x11-drv-intel please.
Comment 3 Richard W.M. Jones 2012-08-28 03:40:52 EDT
xorg-x11-drv-intel-2.20.2-1.fc18.x86_64
xorg-x11-server-Xorg-1.12.99.904-1.20120808.fc18.x86_64

Some other points covered on IRC last night:

 - Running XFCE.

 - Font antialising is set to Grayscale.

 - Compositor disabled.

 - Restart of the X server fixed the problem.

 - Same hardware runs F16/F17 just fine for over a year.
Comment 4 Honza 'thingie' Bartoš 2012-09-14 05:00:12 EDT
I have a similar (not sure if same) problem with an Intel Arrandale chipset graphics on both Fedora 17 and 18 on two different computers. Both have the same chipset. It does happen only after few hours of use. There is nothing interesting in the logs either.

Key difference is that it's happening only with 3.5 kernels and newer (3.6-rc on FC 18, even latest 3.6 checkout that I've compiled mysefl). It doesn't happen with the latest F17 3.4 kernel or any older, not even a long period of use without any restart (weeks).
Comment 5 Honza 'thingie' Bartoš 2012-09-14 05:01:07 EDT
I should have also added that I don't use XFCE, but default Gnome3 environment with compositing enabled.
Comment 6 Michal Ambroz 2012-09-17 06:41:59 EDT
Hello I have got the same issue (using default Gnome3 + gnome-shell). Fonts disappearing especially in firefox, thunderbird, gnome-terminal. It usually disappears or appears back when the part of the screen gets redrawn on some event like mouse-over or scroll with the page, resize a font on the webpage (ctrl+ ctrl-).

xorg-x11-server-Xorg-1.12.3-1.fc17.x86_64
xorg-x11-drv-intel-2.20.6-1.fc17.x86_64

I have tried now to downgrade back to xorg-x11-server-Xorg-1.12.0-2.fc17.x86_64 - I believe I was not seeing these issues before upgrade to latest Xorg server.

Michal Ambroz
Comment 7 Christoph Höger 2012-09-20 09:27:03 EDT
Same hier. This is a lenovo X201 with fedora 17 all stable updates.

If there is any particular log that could be helpful, let me know.
Comment 8 Dave Airlie 2012-09-20 17:20:24 EDT
I'm currently bisecting this but its a long process, since it takes so long to know the kernel is good.

Michael did the old server help?

I'm currently putting it down as a 3.4->3.5 kernel regression.
Comment 9 Michal Ambroz 2012-09-20 18:38:13 EDT
Hello Dale,
I have downgraded only xorg-x11-server-Xorg. The issue didn't re-appear since then (4+ days).

I am currently running kernel 3.5.3-1.fc17.x86_64 and I have not changed that part. The issue appeared on the same version of kernel so I would not say it is related.

Michal
Comment 10 Dave Airlie 2012-09-20 18:47:47 EDT
Michael so what server are you running now?
Comment 11 Honza 'thingie' Bartoš 2012-09-21 03:52:42 EDT
I've looked into last and yum history, it seems that it had happened for the first time in the early august ( :-) ) with the first 3.5 kernel f17 update, xorg and intel driver version back then were:

xorg-x11-server-Xorg 1.12.2-4.fc17.x86_64
xorg-x11-drv-intel 2.20.1-1.fc17.x86_64

I haven't tried to downgrade them, but booting 3.4 kernel have always helped (running 3.4.6-2.fc17.x86_64 right now).

It's also happening with my F18 alpha system, but I don't have access to it right now.
Comment 12 Christoph Höger 2012-09-21 05:53:42 EDT
I am pretty confident the issue appeared first after I was back from a conference. That was around the 6th of september. I did not update the x server since then. Relevant yum.log lines:

[choeger@elrond modim]$ sudo egrep "(xorg)|(kernel)" /var/log/yum.log | grep Sep
Sep 06 13:47:44 Updated: xorg-x11-drv-intel-2.20.5-1.fc17.x86_64
Sep 06 13:47:45 Updated: kernel-headers-3.5.3-1.fc17.x86_64
Sep 06 13:48:15 Installed: kernel-devel-3.5.3-1.fc17.x86_64
Sep 06 13:49:00 Installed: kernel-3.5.3-1.fc17.x86_64
Sep 10 11:52:42 Updated: xorg-x11-drv-intel-2.20.6-1.fc17.x86_64

So for me it seems to be either the intel driver (does it still do alot nowadays?) or the kernel itself.
Comment 13 Honza 'thingie' Bartoš 2012-09-28 08:14:42 EDT
Tried with 3.6-rc7 and recent F17 Xorg and drv-intel updates, worked well for two days, but eventually fonts have started to fall apart again.
Comment 14 Dave Airlie 2012-10-03 01:17:48 EDT
http://kojipkgs.fedoraproject.org/scratch/airlied/task_4553682/

I've built a scratch kernel with a workaround from intel guys, its a hack just to narrow down things, I can't reproduce here with this patch in place, but it might just be luck at this point.
Comment 15 Dave Airlie 2012-10-03 04:48:16 EDT
Michael,

what hw are you running on? can you attach an Xorg log please.

Dave.
Comment 16 Dave Airlie 2012-10-03 05:21:01 EDT
also guys how much RAM have you got in these machines?
Comment 17 Richard W.M. Jones 2012-10-03 05:55:31 EDT
This bug has not happened to me since I reported it (I
use the machine 24/7).  However FWIW the machine has 8 GB
of RAM.

$ free -m
             total       used       free     shared    buffers     cached
Mem:          7762       3966       3796          0        647       1298
-/+ buffers/cache:       2021       5741
Swap:         5823         82       5741
Comment 18 Michal Ambroz 2012-10-03 13:55:58 EDT
Hi Dave,
Sorry - I am not able to reproduce the issue since I downgraded the Xorg to fc17 release version so I might not be able to help to narrow it down.

I have even tried last week to upgrade to latest Xorg and kernel in FC17 - not able to reproduce the error:
kernel-3.5.4-2.fc17.x86_64
xorg-x11-drv-intel-2.20.8-1.fc17.x86_64
xorg-x11-server-Xorg-1.12.3-2.fc17.x86_64

(In reply to comment #16)
> also guys how much RAM have you got in these machines?
4G

(In reply to comment #15)
> what hw are you running on? can you attach an Xorg log please.
I have got notebook HP EliteBook 6930p with integrated Intel GPU, using dualhead (notebook LCD + external DVI connected monitor)

$ lspci |grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

/var/log/Xorg.0.log
[    78.682] (--) intel(0): Integrated Graphics Chipset: Intel(R) GM45

Best regards
Michal Ambroz
Comment 19 Dave Airlie 2012-10-05 18:49:34 EDT
*** Bug 851280 has been marked as a duplicate of this bug. ***
Comment 20 James Rankin 2012-10-07 11:47:09 EDT
Dave, I can reproduce this within a couple days on F17 whenever I'm on a DVI monitor (via docking station) *and* when I'm on any 3.5 kernel. I've never seen this issue on any 3.4 kernels.

Do you want me to try one of the kernels in comment 14?
Comment 21 Dave Airlie 2012-10-07 20:45:13 EDT
James,

yes please try that kernel.
Comment 22 Kamil Páral 2012-10-08 08:23:38 EDT
This might be another duplicate: bug 848099
Comment 23 James Rankin 2012-10-12 21:30:24 EDT
I'm three days on this new kernel (3.5.5-1.bz852210.fc17.x86_64) now, and the problem has not occurred. In the previous 3.5 kernels, the problem always happened when I have the laptop in a DVI docking station for more than a day. I'll continue using this kernel and will report back if the problem does appear.
Comment 24 Christoph Höger 2012-10-16 07:46:43 EDT
It just happened again on 3.6.1 (attached to a docking station via display link).

I tried to switch to a different VT and got this:

[18668.743604] WARNING: at drivers/gpu/drm/i915/intel_display.c:1394 assert_pch_hdmi_disabled+0xb8/0xf0 [i915]()
[18668.743605] Hardware name: 3323REG
[18668.743606] IBX PCH hdmi port still using transcoder B
[18668.743646] Modules linked in: fuse rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack ip6table_filter ip6_tables snd_hda_codec_hdmi snd_hda_codec_conexant snd_hda_intel snd_hda_codec snd_hwdep snd_seq qcserial usb_wwan snd_seq_device snd_pcm ecryptfs arc4 uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core encrypted_keys videodev iwldvm snd_page_alloc e1000e snd_timer coretemp mei iTCO_wdt media iTCO_vendor_support mac80211 lpc_ich iwlwifi mfd_core btusb bluetooth i2c_i801 kvm trusted intel_ips tpm tpm_bios microcode cfg80211 uinput thinkpad_acpi snd soundcore rfkill crc32c_intel ghash_clmulni_intel wmi i915 video i2c_algo_bit drm_kms_helper drm i2c_core
[18668.743650] Pid: 904, comm: Xorg Not tainted 3.6.1-1.fc17.x86_64 #1
[18668.743651] Call Trace:
[18668.743660]  [<ffffffff8105b84f>] warn_slowpath_common+0x7f/0xc0
[18668.743663]  [<ffffffff8105b946>] warn_slowpath_fmt+0x46/0x50
[18668.743684]  [<ffffffffa0094058>] assert_pch_hdmi_disabled+0xb8/0xf0 [i915]
[18668.743703]  [<ffffffffa009694c>] ironlake_crtc_disable+0x24c/0x7b0 [i915]
[18668.743711]  [<ffffffff812e31f1>] ? vsnprintf+0x461/0x600
[18668.743730]  [<ffffffffa0096f3e>] ironlake_crtc_dpms+0x8e/0xa0 [i915]
[18668.743749]  [<ffffffffa0092118>] intel_crtc_dpms+0x48/0x140 [i915]
[18668.743768]  [<ffffffffa009a735>] intel_crtc_disable+0x35/0xb0 [i915]
[18668.743777]  [<ffffffffa0065825>] drm_helper_disable_unused_functions+0x115/0x170 [drm_kms_helper]
[18668.743785]  [<ffffffffa006711a>] drm_crtc_helper_set_config+0x91a/0xb00 [drm_kms_helper]
[18668.743793]  [<ffffffffa0064f12>] drm_fb_helper_set_par+0x82/0x100 [drm_kms_helper]
[18668.743797]  [<ffffffff8131b605>] fb_set_var+0x1a5/0x470
[18668.743802]  [<ffffffff81091179>] ? try_to_wake_up+0x1d9/0x2c0
[18668.743807]  [<ffffffff81327f91>] fbcon_blank+0x1e1/0x2e0
[18668.743812]  [<ffffffff81396e96>] do_unblank_screen+0xb6/0x1f0
[18668.743817]  [<ffffffff8138c4c5>] complete_change_console+0x65/0xf0
[18668.743820]  [<ffffffff8138d74c>] vt_ioctl+0x11fc/0x1300
[18668.743833]  [<ffffffffa0014fe2>] ? drm_ioctl+0xf2/0x580 [drm]
[18668.743837]  [<ffffffff810ef730>] ? call_rcu_bh+0x20/0x20
[18668.743842]  [<ffffffff81382118>] tty_ioctl+0x258/0xb50
[18668.743847]  [<ffffffff8161e17c>] ? do_page_fault+0x1bc/0x4b0
[18668.743851]  [<ffffffff811a0bc9>] do_vfs_ioctl+0x99/0x580
[18668.743855]  [<ffffffff811a1149>] sys_ioctl+0x99/0xa0
[18668.743858]  [<ffffffff816226e9>] system_call_fastpath+0x16/0x1b
[18668.743860] ---[ end trace fddc7b996825e5f1 ]---
Comment 25 James Rankin 2012-10-19 11:54:23 EDT
This problem just reappeared on the 3.5.5-1.bz852210.fc17.x86_64 kernel, though it's much less severe so far. I'm having small amounts of text in xchat disappear when I mouse over them.
Comment 26 James Rankin 2012-10-23 18:28:43 EDT
I tried the new 3.6.2-4.fc17.x86_64 kernel, and the problem definitely exists, and may even be worse than before. I literally can't see this text as I'm typing it out.
Comment 27 Josh Boyer 2012-10-24 08:28:51 EDT
Dave believes this is fixed with commit 504c7267a1e84b157cbd7e9c1b805e upstream.  I've added that to the fedora kernel on F16-F18.
Comment 28 Diego 2012-10-31 05:09:50 EDT
(In reply to comment #27)
> Dave believes this is fixed with commit 504c7267a1e84b157cbd7e9c1b805e
> upstream.  I've added that to the fedora kernel on F16-F18.

Is there any Fedora kernel packages including that commit? Which is (or will be) the first kernel release including that commit?
Comment 29 Diego 2012-10-31 05:13:07 EDT
(In reply to comment #28)
> (In reply to comment #27)
> > Dave believes this is fixed with commit 504c7267a1e84b157cbd7e9c1b805e
> > upstream.  I've added that to the fedora kernel on F16-F18.
> 
> Is there any Fedora kernel packages including that commit? Which is (or will
> be) the first kernel release including that commit?

Ok, found by myself Fedora kernel 3.6.4 has it:
http://koji.fedoraproject.org/koji/buildinfo?buildID=363032
Comment 30 Fedora Update System 2012-10-31 22:11:58 EDT
kernel-3.6.5-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.6.5-2.fc18
Comment 31 Fedora Update System 2012-11-01 01:53:11 EDT
Package kernel-3.6.5-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.6.5-2.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17413/kernel-3.6.5-2.fc18
then log in and leave karma (feedback).
Comment 32 Fedora Update System 2012-11-01 09:24:15 EDT
kernel-3.6.5-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.6.5-2.fc16
Comment 33 David Juran 2012-11-02 04:37:32 EDT
*** Bug 867249 has been marked as a duplicate of this bug. ***
Comment 34 David Juran 2012-11-05 02:12:49 EST
For what it matters, running kernel-3.6.5-2.fc16, I got the same traceback w Christoph reported in comment 24 when resuming from suspend (or possibly suspending) Excerpt from syslog attached
Comment 35 David Juran 2012-11-05 02:16:21 EST
Created attachment 638348 [details]
syslog with assert
Comment 36 Knut Stolze 2012-11-07 04:04:40 EST
Is there a fix for FC17 available/necessary?
Comment 37 Martin Kosek 2012-11-07 04:15:38 EST
(In reply to comment #36)
> Is there a fix for FC17 available/necessary?

I use kernel-3.6.5-1.fc17.x86_64 and I no longer experience this issue (yay!).
Comment 38 Knut Stolze 2012-11-09 06:06:39 EST
Same here; I only would like to make sure...
Comment 39 Fedora Update System 2012-12-20 10:12:06 EST
kernel-3.6.5-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 40 gordon 2013-02-08 16:03:42 EST
fedora 18
kernel-3.7.5-201.fc18.x86_64
xorg-x11-server-Xorg-1.13.2-1.fc18.x86_64
gnome-3 fallback mode

Just installed latest updates and am now seeing/not-seeing text in firefox and thunderbird. Text simply disappears. Scroll "disappeared" text off screen and back will usually restore the text for a time. Another symptom is corrupted text (becoming blocks or weird characters) and input fields turning colors, like black or blue. Gnome-Terminal seems unaffected.
Comment 41 gordon 2013-02-08 16:37:27 EST
fedora 18
kernel-3.7.4-204.fc18.x86_64

booted to old kernel. been playing around for 30 minutes and have not been able to reproduce the problem. maybe it is a kernel thing.

Note You need to log in before you can comment on or make changes to this bug.