Bug 852577 - rename failures with multiple clients
rename failures with multiple clients
Status: CLOSED DUPLICATE of bug 828701
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Anand Avati
Sudhir D
:
Depends On: 828701
Blocks: 858486
  Show dependency treegraph
 
Reported: 2012-08-28 21:13 EDT by Vidya Sakar
Modified: 2015-09-01 19:05 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 828701
: 858486 (view as bug list)
Environment:
Last Closed: 2012-11-07 07:24:10 EST
Type: Bug
Regression: ---
Mount Type: fuse
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-08-28 21:13:22 EDT
+++ This bug was initially created as a clone of Bug #828701 +++

Description of problem: With 2 fuse clients, trying to rename a directory from 2nd  client and then renaming it back to the old name from the 1st client fails. 

mkdir -p /mnt/gluster1/h1;
mv /mnt/gluster2/h1 /mnt/gluster2/h2;
mv /mnt/gluster1/h2 /mnt/gluster/h1;


Ran this script in a loop, and was able to reproduce it easily


Version-Release number of selected component (if applicable): 3.3.0qa45


How reproducible: Often

  
Actual results:

Rename fails with ENOENT 


Expected results:

Shouldn't error out


Additional info:

By mounting the fuse client with --entry-timeout=0 and --attribute-timeout=0 and setting the md-cache timeout to 0, this issue wasn't seen.
Comment 2 Amar Tumballi 2012-11-07 07:24:10 EST
dependent bug closed as 'not a bug'

*** This bug has been marked as a duplicate of bug 828701 ***

Note You need to log in before you can comment on or make changes to this bug.