Bug 856852 - [Configure] button in network spoke doesn't work in RC3 for wireless connection "Intel Corporation Centrino Ultimate-N 6300"
[Configure] button in network spoke doesn't work in RC3 for wireless connecti...
Status: CLOSED DUPLICATE of bug 855526
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 20:35 EDT by Tom Lane
Modified: 2013-07-02 23:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 05:29:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (2.08 KB, text/plain)
2012-09-12 20:35 EDT, Tom Lane
no flags Details
ifcfg.log (687 bytes, text/plain)
2012-09-12 20:36 EDT, Tom Lane
no flags Details
syslog (149.09 KB, text/plain)
2012-09-12 20:36 EDT, Tom Lane
no flags Details

  None (edit)
Description Tom Lane 2012-09-12 20:35:22 EDT
Created attachment 612294 [details]
anaconda.log

Description of problem:
In the anaconda network setup screen, I can select a wireless interface and even select the network I want to connect to from the drop-down box, but the Configure... button does nothing, so I can't actually use the network.  (This network requires both a password and manual IP address selection, and I can't enter either.)

Version-Release number of selected component (if applicable):
whatever is in TC6

How reproducible:
100%

Steps to Reproduce:
see above

Additional info:
There is a similar bug being discussed at bz #852792, but I was told to file this separately on the grounds of seeing different messages in VT1.  What I'm seeing is

** (anaconda:655): WARNING **: Device activation failed: (1) Creating object for path '/org/freedesktop/NetworkManager/ActiveConnection/0' failed in libnm-glib.

as well as three occurrences of

** (anaconda:655): WARNING **: async_got_type: could not read properties for /org/freedesktop/NetworkManager/ActiveConnection/0: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist

and then the same for .../ActiveConnection/1, and if I let it sit then another set of the same messages will pop up every few minutes, with increasing connection numbers /2, /3, etc.

I'm attaching some log files as requested in https://bugzilla.redhat.com/show_bug.cgi?id=852792#c14 ... but note that these are taken from a trial with the pre-rc3 compose mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=852792#c24, not TC6.  The behavior doesn't seem to have changed any :-(
Comment 1 Tom Lane 2012-09-12 20:36:05 EDT
Created attachment 612295 [details]
ifcfg.log
Comment 2 Tom Lane 2012-09-12 20:36:47 EDT
Created attachment 612296 [details]
syslog
Comment 3 Adam Williamson 2012-09-17 20:19:06 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=851207 had that same 'get with signature ss' message. May not be related otherwise, but felt worth noticing. Tom, could you confirm you still have trouble with RC3 (Alpha final)?
Comment 4 Tom Lane 2012-09-17 20:53:35 EDT
(In reply to comment #3)
> Tom, could you confirm you still have trouble with RC3 (Alpha final)?

I pulled down the 18-Alpha-RC3.1 netinst.iso, which seems to be a little bit newer, and it still acts just the same.  The anaconda line number is 668 now, but the messages look the same otherwise.

Poking at it a bit more, I discovered that I *could* pull up the configuration dialog for the wired-Ethernet port --- it's just wireless that's no go.  So that makes it possibly a hardware-specific problem.  I'm testing on a ThinkPad T510 (standard Red Hat corporate issue from a couple years back).  The network hub setup page reports that wlan0 is "Intel Corporation Centrino Ultimate-N 6300".  I've not seen any problems with this gear in the last several Fedora releases.
Comment 5 Adam Williamson 2012-09-17 21:00:20 EDT
I said RC3 for a reason. RC3.1 is a dead spin, we are not shipping it. But this test should be valid with both, IIRC what's in RC3.1.
Comment 6 Radek Vykydal 2012-09-20 05:29:58 EDT
It is not hw dependent, marking as a duplicate of bug #855526 which is proposed for Beta Blocker. Thank you for the logs.

*** This bug has been marked as a duplicate of bug 855526 ***

Note You need to log in before you can comment on or make changes to this bug.