Bug 853330 - [abrt] yum-3.4.3-23.fc17: yumRepo.py:1587:_retrieveMD:RepoError: Caching enabled and local cache: /var/tmp/yum-soul-ohX_iR/x86_64/17/fedora/eda1f9b2d7da63ef28865a5d3d3c9ec8de8f10f8c101f07fea4fb8835c94c514-primary.sqlite.bz2 does not match checksum
[abrt] yum-3.4.3-23.fc17: yumRepo.py:1587:_retrieveMD:RepoError: Caching enab...
Status: CLOSED DUPLICATE of bug 809469
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:b1ab465c419fc481b69d04f2f35...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 01:18 EDT by Great.Soul
Modified: 2014-01-21 18:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-05 09:50:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Great.Soul 2012-08-31 01:18:58 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python -t /usr/share/yum-cli/completion-helper.py -d 0 -C list available ecli
executable:     /usr/share/yum-cli/completion-helper.py
kernel:         3.3.4-5.fc17.x86_64
time:           Thu 23 Aug 2012 09:17:32 PM HKT
uid:            1000
username:       soul

backtrace:
:yumRepo.py:1587:_retrieveMD:RepoError: Caching enabled and local cache: /var/tmp/yum-soul-ohX_iR/x86_64/17/fedora/eda1f9b2d7da63ef28865a5d3d3c9ec8de8f10f8c101f07fea4fb8835c94c514-primary.sqlite.bz2 does not match checksum
:
:Traceback (most recent call last):
:  File "/usr/share/yum-cli/completion-helper.py", line 81, in <module>
:    main(sys.argv[1:])
:  File "/usr/share/yum-cli/completion-helper.py", line 77, in main
:    base.doCommands()
:  File "/usr/share/yum-cli/cli.py", line 485, in doCommands
:    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
:  File "/usr/share/yum-cli/completion-helper.py", line 44, in doCommand
:    patterns=[get_pattern(extcmds)])
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2660, in doPackageLists
:    avail = self.pkgSack.returnNewestByNameArch(patterns=patterns,
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1003, in <lambda>
:    pkgSack = property(fget=lambda self: self._getSacks(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 767, in _getSacks
:    self.repos.populateSack(which=repos)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 294, in populateSack
:    sack.populate(repo, mdtype, callback, cacheonly)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 175, in populate
:    db_fn = repo._retrieveMD(mydbtype)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1587, in _retrieveMD
:    "Caching enabled and local cache: %s does not match checksum" % local
:RepoError: Caching enabled and local cache: /var/tmp/yum-soul-ohX_iR/x86_64/17/fedora/eda1f9b2d7da63ef28865a5d3d3c9ec8de8f10f8c101f07fea4fb8835c94c514-primary.sqlite.bz2 does not match checksum
:
:Local variables in innermost frame:
:e: URLGrabError(-1, 'Metadata file does not match checksum')
:r_base: None
:self: <yum.yumRepo.YumRepository object at 0x1dff050>
:thisdata: <yum.repoMDObject.RepoData instance at 0x1e064d0>
:mdtype: 'primary_db'
:fname: 'eda1f9b2d7da63ef28865a5d3d3c9ec8de8f10f8c101f07fea4fb8835c94c514-primary.sqlite.bz2'
:remote: 'repodata/eda1f9b2d7da63ef28865a5d3d3c9ec8de8f10f8c101f07fea4fb8835c94c514-primary.sqlite.bz2'
:local: '/var/tmp/yum-soul-ohX_iR/x86_64/17/fedora/eda1f9b2d7da63ef28865a5d3d3c9ec8de8f10f8c101f07fea4fb8835c94c514-primary.sqlite.bz2'
:retrieve_can_fail: False

smolt_data:
:
:
:General
:=================================
:UUID: f0d3be38-3746-4074-8603-c5b201881305
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 4585.39
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 2301
:System Memory: 3908
:System Swap: 5951
:Vendor: LENOVO
:System: 4180CC7 ThinkPad T420
:Form factor: Notebook
:Kernel: 3.5.2-3.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:7247:6058:8654) pci, None, PCI/ISA, QM67 Express Chipset Family LPC Controller
:(32902:7202:6058:8654) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:7190:6058:8654) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:6058:8654) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:6058:8654) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(4318:4183:6058:8654) pci, nvidia, VIDEO, N/A
:(32902:7192:6058:8654) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 5
:(32902:7200:6058:8654) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:5378:6058:8654) pci, e1000e, ETHERNET, 82579LM Gigabit Network Connection
:(4318:3592:6058:8654) pci, snd_hda_intel, MULTIMEDIA, HDMI Audio stub
:(32902:133:32902:4881) pci, iwlwifi, NETWORK, Centrino Advanced-N 6205 AGN
:(4480:59426:6058:8499) pci, sdhci-pci, BASE, MMC/SD Host Controller
:(32902:7171:6058:8654) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7213:6058:8654) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:6058:8654) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:6058:8654) pci, None, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:6058:8654) pci, mei, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(32902:257:6058:8654) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_soul-lv_root / ext4 4096 4096 12901535 10320485 9665125 3276800 2888750 2888750
:/dev/sda6 /boot ext4 1024 1024 495844 406281 380681 128016 127669 127669
:/dev/mapper/vg_soul-lv_home /home ext4 4096 4096 9813151 7913234 7414751 2493680 2440432 2440432
:
Comment 1 Zdeněk Pavlas 2012-09-05 09:50:29 EDT
This has been fixed long ago in -25.

*** This bug has been marked as a duplicate of bug 809469 ***

Note You need to log in before you can comment on or make changes to this bug.