This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 853877 - anaconda ignores keyboard settings
anaconda ignores keyboard settings
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
AcceptedBlocker
: i18n
: 854958 (view as bug list)
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-09-03 04:16 EDT by drago01
Modified: 2012-10-23 09:52 EDT (History)
14 users (show)

See Also:
Fixed In Version: anaconda-18.17-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 09:52:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description drago01 2012-09-03 04:16:46 EDT
Description of problem:

After doing a netinstall with FC18 Alpha TC5 the installed system neither have the selected language (German) nor the selected keyboard layout (german, AT) configured.
Comment 1 Chris Lumens 2012-09-03 22:16:14 EDT
Neither keyboard nor language settings are a part of alpha criteria.
Comment 2 drago01 2012-09-04 02:10:46 EDT
(In reply to comment #1)
> Neither keyboard nor language settings are a part of alpha criteria.

=> Moved to beta blocker.
Comment 3 Vratislav Podzimek 2012-09-05 05:06:32 EDT
Patch for the language part pushed to anaconda git repository. However I have no idea how to tell systemd which keymap it should load after reboot (X configuration should work, because we create a configuration file in xorg.conf.d). Lennart, could you please tell me what file(s) systemd-localed is looking at for configuration?
Comment 4 Vratislav Podzimek 2012-09-07 05:08:03 EDT
*** Bug 854958 has been marked as a duplicate of this bug. ***
Comment 5 Jens Petersen 2012-09-12 06:18:59 EDT
Does this include timezone too or should I file separately for that?
Comment 6 Vratislav Podzimek 2012-09-12 07:06:23 EDT
(In reply to comment #5)
> Does this include timezone too or should I file separately for that?
I believe timezone settings are okay, what problem do you see? If you run 'date', what timezone does it display to you? And is '/etc/localtime' a valid symlink to the timezone you have selected in the installation? If not, please file a separate bug.
Comment 7 Jens Petersen 2012-09-12 21:16:10 EDT
Okay thanks Vratislav - I better recheck then.
Comment 8 Jens Petersen 2012-09-13 06:26:52 EDT
Ok I filed bug 856995 for the timezone issue (reproduced with Alpha RC3).
Comment 9 Lennart Poettering 2012-09-13 14:47:44 EDT
(In reply to comment #3)
> Patch for the language part pushed to anaconda git repository. However I
> have no idea how to tell systemd which keymap it should load after reboot (X
> configuration should work, because we create a configuration file in
> xorg.conf.d). Lennart, could you please tell me what file(s) systemd-localed
> is looking at for configuration?

/etc/vconsole.conf

See vconsole.conf(5) for more information.

I'd recommend simply talking to localed and let it do the necessary conversion from X11 → console keymap. That's what GNOME3 later on does, too. This is documented here:

http://www.freedesktop.org/wiki/Software/systemd/localed
Comment 10 Adam Williamson 2012-09-26 13:09:22 EDT
Discussed at 2012-09-26 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-09-26/f18-beta-blocker-review-1.2012-09-26-16.03.log.txt . Accepted as a Beta blocker (in fact should have been Alpha blocker), as a conditional violation of criterion "Following on from the previous criterion, after firstboot is completed and on subsequent boots, a system installed according to any of the above criteria must boot to a working graphical environment without unintended user intervention. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied" : our usual way of handling keymap issues is to say that they violate this criterion, in the case where you set a root password or an encrypted partition passphrase which uses a character that's typed differently in the chosen keymap vs. the one that is actually (incorrectly) used (usually en-US). We may institute an explicit criterion for this though, in future.
Comment 11 Adam Williamson 2012-10-04 14:42:15 EDT
anaconda team, what's the status of this? pace https://bugzilla.redhat.com/show_bug.cgi?id=858591 , we know anaconda is at least making an effort to write out localization configuration as of beta, but stuffing it up rather badly at present. Is there an attempt to configure the keymap used in consoles on the installed system? Is it expected to be working at present or not?
Comment 12 Vratislav Podzimek 2012-10-04 16:26:41 EDT
(In reply to comment #11)
> anaconda team, what's the status of this? pace
> https://bugzilla.redhat.com/show_bug.cgi?id=858591 , we know anaconda is at
> least making an effort to write out localization configuration as of beta,
> but stuffing it up rather badly at present. Is there an attempt to configure
> the keymap used in consoles on the installed system? Is it expected to be
> working at present or not?
I'm just finishing the patch for writing out console keymap configuration, but I have some troubles with using systemd-localed in the installation environment.
Comment 13 Vratislav Podzimek 2012-10-05 13:44:55 EDT
Patch set sent to anaconda-patches list.
Comment 14 Adam Williamson 2012-10-17 14:50:54 EDT
This was set to MODIFIED on 10-12, but no comment was added, nor was the 'fixed in version' field changed. Has this been committed to anaconda? Has it made it into a release yet? Can someone please clarify?
Comment 15 Vratislav Podzimek 2012-10-17 15:44:36 EDT
(In reply to comment #14)
> This was set to MODIFIED on 10-12, but no comment was added, nor was the
> 'fixed in version' field changed. Has this been committed to anaconda? Has
> it made it into a release yet? Can someone please clarify?
This was part of the 4b98eab34f310c2704ec24b417bdf919c413fa1d commit, that was pushed on 10-12. I'm not sure why this patch was not listed in the bodhi update.
Comment 16 Adam Williamson 2012-10-17 18:59:57 EDT
So this needs testing with 18.17 or higher.
Comment 17 Fedora Update System 2012-10-17 19:07:08 EDT
anaconda-18.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-16295/anaconda-18.17-1.fc18
Comment 18 Fedora Update System 2012-10-17 22:39:34 EDT
anaconda-18.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.18-1.fc18
Comment 19 Fedora Update System 2012-10-18 11:32:07 EDT
Package anaconda-18.18-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.18-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16402/anaconda-18.18-1.fc18
then log in and leave karma (feedback).
Comment 20 Fedora Update System 2012-10-19 21:35:24 EDT
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.19-1.fc18
Comment 21 Kamil Páral 2012-10-23 09:52:57 EDT
I tried with Beta TC6 (anaconda 18.19, DVD and Live) and I received a system with the German language and the German keyboard by default. Closing as fixed.

Note You need to log in before you can comment on or make changes to this bug.