Bug 853913 - [de_DE] dialogs are trimmed in some languages
Summary: [de_DE] dialogs are trimmed in some languages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 856496 (view as bug list)
Depends On:
Blocks: F18Beta-accepted, F18BetaFreezeExcept
TreeView+ depends on / blocked
 
Reported: 2012-09-03 10:11 UTC by Kamil Páral
Modified: 2012-10-11 18:11 UTC (History)
8 users (show)

Fixed In Version: anaconda-18.8-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-10-11 18:11:51 UTC
Type: Bug


Attachments (Terms of Use)
anaconda in german (51.58 KB, image/png)
2012-09-03 10:11 UTC, Kamil Páral
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 853609 0 unspecified CLOSED liveinstaller crashes when selecting german language 2021-02-22 00:41:40 UTC

Internal Links: 853609

Description Kamil Páral 2012-09-03 10:11:49 UTC
Created attachment 609312 [details]
anaconda in german

Description of problem:
The dialogs should force some kind of word-wrapping. For some languages they are just trimmed. See screenshot for German localization.

Version-Release number of selected component (if applicable):
Fedora 18 Alpha TC5
anaconda 18.6.4

How reproducible:
always

Steps to Reproduce:
1. select German
2. hit Continue

Comment 1 Chris Lumens 2012-09-04 15:05:33 UTC
I can fix this, but it's going to require breaking string freeze.

Comment 2 Kamil Páral 2012-09-05 08:02:14 UTC
Chris, what's the fix? 

Will you change just the German translation, i.e. it won't fix any other potentially broken languages?

Or will you change the master English translation by adding newlines, therefore requiring all languages to re-create the translation (which effectively means it will be just in English in Alpha)?

Can't we just force word-wrap on that dialog?

Comment 3 Chris Lumens 2012-09-12 14:01:00 UTC
*** Bug 856496 has been marked as a duplicate of this bug. ***

Comment 4 Chris Lumens 2012-09-12 14:02:41 UTC
There are embedded newlines in the English text, which works well for English but not necessarily for other languages.  I'd like to remove those newlines and instead set word wrap parameters to make the text flow properly.

Comment 5 Chris Lumens 2012-09-12 15:24:17 UTC
Pushed, and will be updating the .pot file on master shortly so translators have maximum time to deal with this change.

Comment 6 Mike FABIAN 2012-09-12 21:27:40 UTC
Will the word wrap work for Japanese and Chinese as well although
there are no spaces in these languages?

Comment 7 Adam Williamson 2012-10-11 18:11:51 UTC
Fixed since anaconda 18.8, I just tested and confirmed that the 'this is beta software!' warning wraps correctly in German and Japanese in Beta TC3.


Note You need to log in before you can comment on or make changes to this bug.