Bug 854732 - (candlepin-ibm) Error during install. IBM jvm was installed however open jdk is needed. No dependency check present.
Error during install. IBM jvm was installed however open jdk is needed. No ...
Status: CLOSED NOTABUG
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.9
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: candlepin-bugs
Eric Sammons
:
Depends On:
Blocks: katello-v2-candlepin 868185
  Show dependency treegraph
 
Reported: 2012-09-05 13:08 EDT by Brett Thurber
Modified: 2015-05-14 12:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 09:19:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug log. (51.09 KB, application/x-gzip)
2012-09-05 13:08 EDT, Brett Thurber
no flags Details

  None (edit)
Description Brett Thurber 2012-09-05 13:08:51 EDT
Created attachment 610098 [details]
Debug log.

Description of problem:
During katello-configure, fails with candlepin error.


Version-Release number of selected component (if applicable):
RHEL 6.2 system registered with the following channels:
RHEL Server Supplementary
RHEL Server Optional
CloudForms 1.x

How reproducible:
Every time.

Steps to Reproduce:
1.RHEL 6.2 system with the following channels registered:
RHEL Server Supplimentary
RHEL Server Optional
Red Hat CloudForms System Engine
Red Hat CloudForms Tools for Server v6
2.  yum install -y katello-all 
3.  run katello-configure
  
Actual results:
katello-configure fails with the following error:

Failed, please check [/var/log/katello/katello-configure/cpsetup.log]
(01:02:27 PM) bthurber: err: /Stage[main]/Apache2/Exec[reload-apache2]: Failed to call refresh: /etc/init.d/httpd reload returned 7 instead of one of [0] at /usr/share/katello/install/puppet/modules/apache2/manifests/init.pp:1

Expected results:
Dependecy check needed for open jdk.

Additional info:
Issue is resolveable by unsubscribing from the following channels:
RHEL Server Supplimentary
RHEL Server Optional
This prevents java-xxx-ibm from being installed overriding open jdk.
Comment 1 Mike McCune 2012-09-05 13:20:57 EDT
It turned out it was actually candlepin that really didn't like the IBM jvm.  He had: java-1.7.0-ibm

it caused issues trying to find install JARs:

# /usr/share/candlepin/cpdb --drop --create
Dropping candlepin database
Creating candlepin database
Loading candlepin schema

########## ERROR ############
Error running command: liquibase --driver=org.postgresql.Driver --classpath=/usr/share/java/postgresql-jdbc.jar:/var/lib/tomcat6/webapps/candlepin/WEB-INF/classes/ --changeLogFile=db/changelog/changelog-create.xml --url=jdbc:postgresql:candlepin --username=candlepin migrate
Status code: 256
Command output: Error: Could not find or load main class liquibase.integration.commandline.Main
Traceback (most recent call last):
  File "/usr/share/candlepin/cpdb", line 126, in <module>
    dbsetup.create()
  File "/usr/share/candlepin/cpdb", line 61, in create
    self._run_liquibase("db/changelog/changelog-create.xml")
  File "/usr/share/candlepin/cpdb", line 91, in _run_liquibase
    self.username,
  File "/usr/share/candlepin/cpdb", line 32, in run_command
    error_out(command, status, output)
  File "/usr/share/candlepin/cpdb", line 40, in error_out
    raise Exception("Error running command")
Exception: Error running command
Comment 2 Lukas Zapletal 2012-09-10 03:25:57 EDT
Looks like CLASSPATH problem, but indeed - if we want to offer IBM JVM support, Candlepin and then Katello must be tested with it.
Comment 3 Mike McCune 2012-09-19 15:26:27 EDT
The workaround for this is to remove the IBM JVM and switch to openjdk
Comment 4 Lukas Zapletal 2012-10-19 05:10:15 EDT
Putting the note in the installation guide then:

Before running katello-configure, make sure you have OpenJDK java installed.

https://fedorahosted.org/katello/wiki/Install?action=diff&version=134&old_version=133
Comment 5 Mike McCune 2012-12-13 18:15:50 EST
FYI for those hit by this bug, the IBM JVM comes from the RHEL Supplemental channel/repo
Comment 6 Cory Scheviak 2013-06-06 09:19:14 EDT
Closing bug because it appears the solution has already been implemented. Can be re-opened if necessary.

Note You need to log in before you can comment on or make changes to this bug.