Bug 854856 - PartitioningError: not enough free space on disks - anaconda crashes when disk space is insufficient, instead of handling it elegantly
PartitioningError: not enough free space on disks - anaconda crashes when dis...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:1d9483a6a65945adfc23d81666e...
: CommonBugs
: 855479 (view as bug list)
Depends On:
Blocks: F18Blocker/F18FinalBlocker F18Alpha-accepted/F18AlphaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-09-06 03:29 EDT by Kamil Páral
Modified: 2013-01-10 01:54 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-28 11:36:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: ifcfg.log (697 bytes, text/plain)
2012-09-06 03:29 EDT, Kamil Páral
no flags Details
File: anaconda-tb (221.64 KB, text/plain)
2012-09-06 03:29 EDT, Kamil Páral
no flags Details
File: environ (758 bytes, text/plain)
2012-09-06 03:29 EDT, Kamil Páral
no flags Details
File: type (9 bytes, text/plain)
2012-09-06 03:29 EDT, Kamil Páral
no flags Details
File: storage.log (78.78 KB, text/plain)
2012-09-06 03:29 EDT, Kamil Páral
no flags Details
File: version (12 bytes, text/plain)
2012-09-06 03:29 EDT, Kamil Páral
no flags Details
File: program.log (31.03 KB, text/plain)
2012-09-06 03:29 EDT, Kamil Páral
no flags Details
File: product (6 bytes, text/plain)
2012-09-06 03:29 EDT, Kamil Páral
no flags Details
File: syslog (73.93 KB, text/plain)
2012-09-06 03:29 EDT, Kamil Páral
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-09-06 03:29 EDT, Kamil Páral
no flags Details
File: anaconda.log (2.40 KB, text/plain)
2012-09-06 03:30 EDT, Kamil Páral
no flags Details
File: release (24 bytes, text/plain)
2012-09-06 03:30 EDT, Kamil Páral
no flags Details
File: description (1.31 KB, text/plain)
2012-09-06 03:30 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-09-06 03:29:34 EDT
Description of problem:


Version-Release number of selected component:
anaconda-18.6.4

Additional info:
libreport version: 2.0.12
cmdline:        initrd=initrd.img  quiet rd.live.check BOOT_IMAGE=vmlinuz 
kernel:         3.6.0-0.rc2.git2.1.fc18.i686
Comment 1 Kamil Páral 2012-09-06 03:29:37 EDT
Created attachment 610188 [details]
File: ifcfg.log
Comment 2 Kamil Páral 2012-09-06 03:29:40 EDT
Created attachment 610189 [details]
File: anaconda-tb
Comment 3 Kamil Páral 2012-09-06 03:29:42 EDT
Created attachment 610190 [details]
File: environ
Comment 4 Kamil Páral 2012-09-06 03:29:44 EDT
Created attachment 610191 [details]
File: type
Comment 5 Kamil Páral 2012-09-06 03:29:46 EDT
Created attachment 610192 [details]
File: storage.log
Comment 6 Kamil Páral 2012-09-06 03:29:48 EDT
Created attachment 610193 [details]
File: version
Comment 7 Kamil Páral 2012-09-06 03:29:51 EDT
Created attachment 610194 [details]
File: program.log
Comment 8 Kamil Páral 2012-09-06 03:29:53 EDT
Created attachment 610195 [details]
File: product
Comment 9 Kamil Páral 2012-09-06 03:29:55 EDT
Created attachment 610196 [details]
File: syslog
Comment 10 Kamil Páral 2012-09-06 03:29:57 EDT
Created attachment 610197 [details]
File: hashmarkername
Comment 11 Kamil Páral 2012-09-06 03:30:00 EDT
Created attachment 610198 [details]
File: anaconda.log
Comment 12 Kamil Páral 2012-09-06 03:30:02 EDT
Created attachment 610199 [details]
File: release
Comment 13 Kamil Páral 2012-09-06 03:30:04 EDT
Created attachment 610200 [details]
File: description
Comment 14 Kamil Páral 2012-09-06 03:31:32 EDT
I created 3.9 GB disk, opened Storage spoke, selected my disk, hit Back and this error appeared.

F18 Alpha TC5 netinst
Comment 15 Kamil Páral 2012-09-06 03:33:04 EDT
Proposing as Alpha blocker:
" The installer must be able to complete an installation using any locally connected storage interface (e.g. PATA, SATA, SCSI etc...) with the default file system "
https://fedoraproject.org/wiki/Fedora_18_Alpha_Release_Criteria
Comment 16 Adam Williamson 2012-09-06 12:16:32 EDT
I'm not sure this is really a bug. I don't believe 3.9GB is enough space for a standard net install. Did you check with F17 to see what happens? I suspect you can't do a standard net install to a 3.9GB disk with F17 either. Though there should be a 'nice' error message, not any kind of crash.
Comment 17 Kamil Páral 2012-09-07 03:28:54 EDT
I tried F17 netinst with the same disk and I can install minimal package set just fine.

But that's not the point of this bug, at least not the intended point (I'm sure some people will complain about this). The installer shouldn't crash and should display a reasonable message. I am able to find and read the crash from the traceback message, but the general users won't be. And it might be quite frequent that someone creates a VM with a too small disk and tries to install Fedora on it.

Of course, this doesn't have to block Alpha exactly, but it should block something.
Comment 18 Chris Lumens 2012-09-07 09:33:39 EDT
Error handling is in the works and should be getting pushed pretty soon.
Comment 19 Adam Williamson 2012-09-07 15:20:57 EDT
I vote -1 blocker; this is annoying if you have a too-small disk, but not really severe enough to block release. I guess it'd be a conditional infringement of "The installer must be able to complete an installation using any locally connected storage interface (e.g. PATA, SATA, SCSI etc...) with the default file system", in the case that the disk is too small, I vote -1 on the basis that the affected case isn't serious enough.
Comment 20 Jóhann B. Guðmundsson 2012-09-07 15:22:56 EDT
-1 Blocker +1 NTH
Comment 21 satellitgo 2012-09-07 15:46:28 EDT
-blocker + NTH
Comment 22 Adam Williamson 2012-09-07 18:46:51 EDT
that's three -1/+1s, so rejecting as blocker, accepting as NTH.
Comment 23 Chris Lumens 2012-09-08 18:30:01 EDT
*** Bug 855479 has been marked as a duplicate of this bug. ***
Comment 24 Kamil Páral 2012-09-10 04:18:25 EDT
Re-proposing as F18 Final Blocker.
Comment 25 Jesse Keating 2012-09-10 19:48:23 EDT
(In reply to comment #14)
> I created 3.9 GB disk, opened Storage spoke, selected my disk, hit Back and
> this error appeared.
> 
> F18 Alpha TC5 netinst

Can you clarify whether you selected software before going into the storage spoke?

I can't reproduce your steps here.
Comment 26 Kamil Páral 2012-09-11 07:22:04 EDT
(In reply to comment #25)
> Can you clarify whether you selected software before going into the storage
> spoke?
> 
> I can't reproduce your steps here.

No I haven't. I went straight to the Storage spoke and back. But If I select minimal install first and go to Storage second, it crashes as well.

F18 Alpha RC2 i686 netinst
Comment 27 Jesse Keating 2012-09-11 12:53:52 EDT
(In reply to comment #26)
> (In reply to comment #25)
> > Can you clarify whether you selected software before going into the storage
> > spoke?
> > 
> > I can't reproduce your steps here.
> 
> No I haven't. I went straight to the Storage spoke and back. But If I select
> minimal install first and go to Storage second, it crashes as well.
> 
> F18 Alpha RC2 i686 netinst

See, that's odd.  Because you haven't selected any software at first, we don't know what size you'll need, so we shouldn't be able to do a size check.

Can you attach a fresh set of logs from doing a direct to storage spoke and back getting the crash with the latest images?  Thanks!
Comment 28 Jesse Keating 2012-09-11 13:07:11 EDT
(In reply to comment #27)
> (In reply to comment #26)
> > (In reply to comment #25)
> > > Can you clarify whether you selected software before going into the storage
> > > spoke?
> > > 
> > > I can't reproduce your steps here.
> > 
> > No I haven't. I went straight to the Storage spoke and back. But If I select
> > minimal install first and go to Storage second, it crashes as well.
> > 
> > F18 Alpha RC2 i686 netinst
> 
> See, that's odd.  Because you haven't selected any software at first, we
> don't know what size you'll need, so we shouldn't be able to do a size check.
> 
> Can you attach a fresh set of logs from doing a direct to storage spoke and
> back getting the crash with the latest images?  Thanks!

Disregard.  I misread the error.  The error is saying that the partitions you've requested won't actually fit in the space you have available on your disks.  Are you removing the existing partitions first?  We know that the error catching is not optimal for Alpha, but this really does look like a case of just requesting partitions that won't fit.
Comment 29 Kamil Páral 2012-09-11 14:15:54 EDT
This is a completely empty disk (just created), just very small. Auto-partitioning requested (I haven't entered the manual partitioning screen). I have 1500 MB RAM assigned to that VM, maybe you try to create 3 GB of swap? Then it wouldn't fit even for minimal install.
Comment 30 David Lehman 2012-09-11 14:26:05 EDT
(In reply to comment #29)
> This is a completely empty disk (just created), just very small.
> Auto-partitioning requested (I haven't entered the manual partitioning
> screen). I have 1500 MB RAM assigned to that VM, maybe you try to create 3
> GB of swap? Then it wouldn't fit even for minimal install.

It is still the case that you will need to use custom partitioning if you have such limited disk space. 10GB should be plenty for automatic partitioning.
Comment 31 Kamil Páral 2012-09-11 15:22:26 EDT
(In reply to comment #30)
> It is still the case that you will need to use custom partitioning if you
> have such limited disk space. 10GB should be plenty for automatic
> partitioning.

Let's say this to the user in a pretty error dialog instead of crashing the installer :-)
Comment 32 David Lehman 2012-09-11 15:41:52 EDT
(In reply to comment #31)
> (In reply to comment #30)
> > It is still the case that you will need to use custom partitioning if you
> > have such limited disk space. 10GB should be plenty for automatic
> > partitioning.
> 
> Let's say this to the user in a pretty error dialog instead of crashing the
> installer :-)

Error handling is waiting for the first post-alpha build. I only wrote that commend because it sounded like you were complaining that we don't modify our automatic partitioning algorithm based on your choice of disk size.
Comment 33 satellitgo 2012-11-23 21:11:53 EST
I see this when trying to install to a 4 GB USB from RC1 desktop live. I get error message after selecting it with autopartition. No message warning of too small a disk. Just that it will not install. 8 GB USB installs correctly. Unable to select non LVM format with just ext4 ( /  )  as swap is not healthy for use with a USB
Comment 34 satellitgo 2012-11-23 21:13:19 EST
(In reply to comment #33)
> I see this when trying to install to a 4 GB USB from RC1 desktop live. I get
> error message after selecting it with autopartition. No message warning of
> too small a disk. Just that it will not install. 8 GB USB installs
> correctly. Unable to select non LVM format with just ext4 ( /  )  as swap is
> not healthy for use with a USB

Note does not crash just will not install
Comment 35 Kamil Páral 2012-11-28 11:36:09 EST
I have tried the original reproducer with F18 Beta and this is fixed, anaconda doesn't crash, it displays "new lv is too large to fit in free space" error, which is more or less understandable. While trying this, it is _extremely easy_ to trigger bug 867770. Also, the whole dialog that states how much space is required and the error dialog should be overhauled, but that's not part of this particular bug. This crash is fixed now.

Note You need to log in before you can comment on or make changes to this bug.