Bug 867770 - anaconda GUI becomes unresponsive
anaconda GUI becomes unresponsive
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 873306 875991 881126 (view as bug list)
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-10-18 05:24 EDT by Kamil Páral
Modified: 2012-12-18 08:15 EST (History)
13 users (show)

See Also:
Fixed In Version: anaconda-18.31-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-13 16:37:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (4.49 KB, text/plain)
2012-10-18 05:25 EDT, Kamil Páral
no flags Details
ifcfg.log (641 bytes, text/plain)
2012-10-18 05:25 EDT, Kamil Páral
no flags Details
packaging.log (2.38 KB, text/plain)
2012-10-18 05:25 EDT, Kamil Páral
no flags Details
program.log (45.76 KB, text/plain)
2012-10-18 05:25 EDT, Kamil Páral
no flags Details
storage.log (144.21 KB, text/plain)
2012-10-18 05:25 EDT, Kamil Páral
no flags Details
syslog (67.40 KB, text/plain)
2012-10-18 05:25 EDT, Kamil Páral
no flags Details
X.log (56.18 KB, text/plain)
2012-10-18 05:25 EDT, Kamil Páral
no flags Details
bug demonstration video (1.34 MB, video/ogg)
2012-10-18 05:40 EDT, Kamil Páral
no flags Details
unresponsive screen (MANUAL PARTITIONING) (100.95 KB, image/png)
2012-12-17 22:49 EST, Reartes Guillermo
no flags Details

  None (edit)
Description Kamil Páral 2012-10-18 05:24:27 EDT
Description of problem:
I have seen this problem many times, but it's hard to reproduce. Sometimes Anaconda GUI becomes unresponsive, you can't click any button, nothing works. But Anaconda does not crash nor it is stuck in a loop. It is just unresponsive.

The last time I saw this, I did this workflow:

1. Click on Partitioning
2. Select Encrypt my system
3. Hit Continue
4. Hit Reclaim space
5. Mark all existing partitions to be deleted, hit Reclaim
6. Hit Continue (now you're back in the main hub)
7. Go to Partitioning again
8. Uncheck Encrypt my system
9. Hit Continue
10. freeze, can't click on anything

Sometimes the GUI unlocks after some time, sometimes it doesn't and it's locked forever. The mouse cursor still changes when I move it over different components (it's a hand icon when moving over the large disk icon), so it's not completely dead.

Version-Release number of selected component (if applicable):
anaconda 18.16
F18 Beta TC4 DVD 64bit

How reproducible:
very scarcely
Comment 1 Kamil Páral 2012-10-18 05:25:01 EDT
Created attachment 629257 [details]
anaconda.log
Comment 2 Kamil Páral 2012-10-18 05:25:06 EDT
Created attachment 629258 [details]
ifcfg.log
Comment 3 Kamil Páral 2012-10-18 05:25:11 EDT
Created attachment 629259 [details]
packaging.log
Comment 4 Kamil Páral 2012-10-18 05:25:15 EDT
Created attachment 629260 [details]
program.log
Comment 5 Kamil Páral 2012-10-18 05:25:18 EDT
Created attachment 629261 [details]
storage.log
Comment 6 Kamil Páral 2012-10-18 05:25:21 EDT
Created attachment 629262 [details]
syslog
Comment 7 Kamil Páral 2012-10-18 05:25:25 EDT
Created attachment 629263 [details]
X.log
Comment 8 Kamil Páral 2012-10-18 05:40:19 EDT
Created attachment 629282 [details]
bug demonstration video

Wow, this one seems 100% reproducible. Attaching video.
Comment 9 Kamil Páral 2012-10-18 05:42:08 EDT
This could be a blocker material.
Comment 10 Martin Sivák 2012-10-18 06:06:45 EDT
Can you retest with more current anaconda? (18.18) We did a big cleanup of GUI threads, locking and similar in 18.17 and fixed couple of small bugs related to it in 18.18.
Comment 11 Kamil Páral 2012-10-23 10:56:16 EDT
This is still happening in anaconda 18.19, exactly the same reproducer.
Comment 12 Chris Lumens 2012-10-23 11:14:35 EDT
I think this is the same as bug 868903, which I've got in post and should be pushing the fix for today.  You can either dupe it to that one, or just watch for anaconda-18.20-1 and verify the fix there.  Whichever you prefer.
Comment 13 Kamil Páral 2012-11-15 04:34:12 EST
It's still broken in anaconda 18.28, exactly the same reproducer.
Comment 14 Kamil Páral 2012-11-15 04:35:54 EST
I would like to know that I've hit this bug many times with many different configurations. The described reproducer is just the one that I've found to break it always.
Comment 15 Vratislav Podzimek 2012-11-15 08:03:21 EST
Anaconda runs one of InstallOptionsXDialog from pyanaconda/ui/gui/spokes/storage.py but for some reason it doesn't get displayed and thus it seems like a hang.
Comment 16 Chris Lumens 2012-11-15 10:03:20 EST
*** Bug 873306 has been marked as a duplicate of this bug. ***
Comment 17 Chris Lumens 2012-11-15 13:32:56 EST
Right.

Here's some more data:

* If you don't run the reclaim dialog in a lightbox, it works fine the next time through.

* The second time through, you can hit the same problem by attempting to display the shopping cart.  I assume the problem would also appear if you could get an error in the info bar and pop up that dialog, too.

* If you pop up the reclaim dialog and hit Cancel instead of Reclaim, the problem does not occur.

* If you pop up the reclaim dialog and mess with the Action drop downs but hit Cancel instead of Reclaim, the problem does occur.
Comment 18 Chris Lumens 2012-11-19 10:31:01 EST
*** Bug 875991 has been marked as a duplicate of this bug. ***
Comment 19 Chris Lumens 2012-11-19 16:22:14 EST
It would appear that this may just be a problem with how dialogs are stacked up on each other.  If you hit the problem when displaying the cart dialog and you know that alt-C closes that dialog (or escape for that matter), you are dropped back into the spoke like you would expect.
Comment 20 Chris Lumens 2012-11-20 16:30:57 EST
Reworked the resize dialog to avoid this problem, at least I hope.  I was able to reproduce this 100% by simply going to the resize dialog, fiddling with the drop downs, and then coming back to the storage spoke.  With my modifications, this is no longer the case.
Comment 21 Kamil Páral 2012-11-28 11:58:09 EST
+1 blocker, it's very easy to trigger this and it is a showstopper, you have to reboot (if you don't know some clever tricks as Chris does).
Comment 22 Chris Lumens 2012-11-28 13:29:16 EST
*** Bug 881126 has been marked as a duplicate of this bug. ***
Comment 23 Paul Wouters 2012-11-28 15:54:37 EST
Similar issue, except I could only select partitions but not do anything with the selection. In the end, Xwindows was responsive but anaconda wasn't
Comment 24 Tim Flink 2012-11-30 12:50:40 EST
It sounds to me like this is triggered if you re-enter the storage spoke after going through the resize process.

If I'm understanding correctly, then I'm +1 blocker
Comment 25 Tim Flink 2012-11-30 16:05:49 EST
(In reply to comment #24)
> It sounds to me like this is triggered if you re-enter the storage spoke
> after going through the resize process.
> 
> If I'm understanding correctly, then I'm +1 blocker

I just realized that there was no criteria violation cited here. While it doesn't hit any single release criteria, this could be considered a conditional violation of several criteria including:

"The installer's custom partitioning mode must be capable of the following: Creating, destroying and assigning mount points to partitions of any specified size using most commonly-used filesystem types ..."

"The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods"

Any thoughts on which criterion is more appropriate here?
Comment 26 Adam Williamson 2012-12-03 13:31:27 EST
Discussed at 2012-12-03 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-12-03/f18final-blocker-review-1.2.2012-12-03-17.25.log.txt .

Accepted as a blocker: we decided to treat this pretty much as a crash in the installer, as that is its effect if you don't know the trick to un-stick it. Enough people have seen this that we consider it a conditional violation of "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above" (or really, any 'the installer must succeed' criterion) in the case where you do any of the things to trigger this bug.
Comment 27 Chris Lumens 2012-12-13 11:03:30 EST
I guess this bug never got attached to an update, but it's been fixes since the version up above.
Comment 28 Kamil Páral 2012-12-13 11:50:52 EST
I have tested with anaconda-18.37.2 and I wasn't able to reproduce this. I *think* I've seen this recently, but I have no idea how I caused it. I'll be sure to reopen this if I see it again. Setting as VERIFIED.
Comment 29 Chris Lumens 2012-12-13 11:52:23 EST
There's also bug 875291 and bug 882374.
Comment 30 Adam Williamson 2012-12-13 16:37:04 EST
Still, if this one is fixed, it's fixed. VERIFIED makes no sense, 18.36 has gone stable already.
Comment 31 Kamil Páral 2012-12-14 04:42:02 EST
(That's because I verified it with 18.37.2, see comment 28)
Comment 32 Adam Williamson 2012-12-14 16:18:57 EST
sure, but it seems silly to imagine that somehow it didn't get fixed when they tried to fix it, but then got accidentally fixed between 18.36 and 18.37.2...
Comment 33 Reartes Guillermo 2012-12-16 08:07:26 EST
I am still experiencing these "unresponsive gui" issue with anaconda 18.37.2, at least in two places: INSTALLATION DESTINATION and MANUAL PARTITIONING.

Is the "unresponsive gui" issue fixed globally or a new bug-report is needed for the ones i am encountering?
Comment 34 Kamil Páral 2012-12-16 11:45:26 EST
Reartes, if you still see the issue, please provide a detailed reproducer here and reopen this bug. Thank you.

Please note, however, that anaconda sometimes "lags" a bit, being unresponsive for 5-30 seconds, while e.g. fetching network metadata or mounting an NFS share. That is not this bug. This bug is about getting stuck permanently (but Esc sometimes help to bring the keyboard/mouse focus back to the application).
Comment 35 Reartes Guillermo 2012-12-17 22:49:06 EST
Created attachment 665257 [details]
unresponsive screen (MANUAL PARTITIONING)

F18 TC3 (18.37.2)

happened in manual partitioning, when i clicked the "n Storage devices selected...".

Hit ESC once and 'Finish Partitioning' which led me to the main hub...

Should this bug-report be opened?
Comment 36 Kamil Páral 2012-12-18 08:15:59 EST
(In reply to comment #35)
Reartes, I think this is probably a different bug. Please open a new bugzilla report against anaconda and attach /tmp/*.log. Thank you.

Note You need to log in before you can comment on or make changes to this bug.