Bug 855284 - hanging gnome session processes cause gdm to think user still has an X session (was: gdm Session selection UI disappearing)
hanging gnome session processes cause gdm to think user still has an X sessio...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
18
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
RejectedBlocker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 04:21 EDT by Jens Petersen
Modified: 2012-10-31 21:59 EDT (History)
9 users (show)

See Also:
Fixed In Version: accountsservice-0.6.25-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-31 21:54:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 684516 None None None 2012-09-20 22:13:12 EDT

  None (edit)
Description Jens Petersen 2012-09-07 04:21:08 EDT
Description of problem:
This is pretty annoying and requires constant rebooting to workaround.
GDM 

Version-Release number of selected component (if applicable):
gdm-3.5.90-1.fc18
gdm-3.5.91-1.fc18

How reproducible:
100%

Steps to Reproduce:
1. Boot f18 to gdm
2. click on user
3. press cancel on password prompt
4. click on user again
  
Actual results:
4. only user icon appears no password input prompt or buttons!

Expected results:
4. to be able to input password with cancel and sign-in buttons

Additional info:
Session selection elements seem to disappear even more frequently:
often after logging out a single time.

All this makes testing quite arduous.
Comment 1 Jens Petersen 2012-09-07 04:25:58 EDT
(In reply to comment #0)
> GDM 

Sorry - forgot to write this ^ sentence!:

GDM regularly loses UI elements for the password prompt
and session chooser.

For session chooser (maybe 90% reproducible)

1. login to gnome from gdm
2. logout again
3. try to login to a different desktop

Actual results:
3. most often Session UI (which was there in 1) is gone

Only workaround I found yet is to reboot.
Comment 2 Jens Petersen 2012-09-07 04:30:34 EDT
This might be related to/same as bug 841755 but little detail available in that bug.
Comment 3 Jens Petersen 2012-09-07 04:47:49 EDT
(In reply to comment #2)
> This might be related to/same as bug 841755

Ugh I meant bug 834483 (reported for 3.5.2).

Actually now I see there is already a report for the password lockup:
bug 853964 so I will change this bug just to cover the Session UI
disappearing.
Comment 4 Ray Strode [halfline] 2012-09-07 11:14:55 EDT
There have been various systemd issues causing this (We hide the sesison list if you're already logged in, since typing your password will just jump back to the logged in session).

They should be fixed with recent versions of systemd/gdm.

A workaround is

 systemctl terminate-user jensp
Comment 5 Jeff Bastian 2012-09-19 08:10:20 EDT
The workaround doesn't work for me:
  [root@localhost ~]# systemctl terminate-user jbastian
  Unknown operation 'terminate-user'.

I have on my system:
  systemd-189-4.fc18.x86_64
  accountsservice-0.6.22-3.fc18.x86_64
  gdm-3.5.91-1.fc18.x86_64

Which version provides the terminate-user command?
Comment 6 Jens Petersen 2012-09-20 06:01:43 EDT
(In reply to comment #4)
> There have been various systemd issues causing this (We hide the sesison
> list if you're already logged in, since typing your password will just jump
> back to the logged in session).
> 
> They should be fixed with recent versions of systemd/gdm.

Which package builds have the fix?

I still see the problem with gdm-3.5.92.1 and systemd-189-3.fc18.

This is very easy to reproduce:
1. login with gdm observing session menu
2. logout of gnome
3. start login again, note sesssion chooser UI now gone

So gdm/gnome-shell thinks the user is still logged in because of leftover processes?

Anyway I will retest again after gnome-3.5.92 hits updates-testing.
Comment 7 Jens Petersen 2012-09-20 06:26:35 EDT
Ok I just tested with gnome-3.5.92 and still the same problem.
Comment 8 Jeff Bastian 2012-09-20 12:49:22 EDT
I also see when I logout that my name is at the bottom of the list with a highlight indicating I'm still logged in, even though I just logged out!

My workaround:
1. Hit CTRL-ALT-F2 to get a shell and login as root
2. pkill -u jbastian
3. systemctl restart gdm.service

And now I get the session menu again.
Comment 9 Jens Petersen 2012-09-20 21:29:41 EDT
Ah I guess Ray meant "loginctl terminate-user <user>".

But like Jeff, even after that, I still need to restart gdm for the session menu to appear.
Comment 10 Jens Petersen 2012-09-21 01:06:04 EDT
This is the loginctl output I see for a zombie session:

$ loginctl session-status 7
7 - petersen (1000)
	   Since: Fri, 21 Sep 2012 13:35:52 +0900; 13min ago
	  Leader: 2074
	    Seat: seat0; vc1
	 Display: :0
	 Service: gdm-password; type x11; class user
	   State: closing
	  CGroup: name=systemd:/user/petersen/7
		  ├ 2230 /usr/bin/pulseaudio --start
		  ├ 2292 /usr/libexec/tracker-miner-fs
		  ├ 2296 /usr/libexec/deja-dup/deja-dup-monitor
		  └ 2298 /usr/libexec/tracker-store
$ 

With Fedora 17 (gnome-3.4) this doesn't happen and there are
no leftover processes after logging out of gnome.
Comment 11 Lennart Poettering 2012-09-21 04:10:55 EDT
Please retest with systemd-190 from F18 (currently in bodhi).
Comment 12 Fedora Update System 2012-09-25 22:03:36 EDT
accountsservice-0.6.25-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/accountsservice-0.6.25-1.fc18
Comment 13 Jeff Bastian 2012-09-26 08:38:15 EDT
Upgrading to systemd-192 did not fix the problem, but the accountsservice-0.6.25-1.fc18 update worked.  I can login/logout and I always get the session menu for the next login.

However, there are some desktop services that are refusing to die when I logout.  I've start Gnome, Xfce, LXDE, xmonad, and awesome multiple times when testing for the gdm session menu, and now I have a bunch of stale, duplicate processes running.

I'm logged out, but these processes are still running as me:

[root@firefly ~]# pgrep -lf -u jmbastia
2660 /usr/libexec/tracker-store
2663 /usr/libexec/tracker-miner-fs
2669 /usr/libexec/deja-dup/deja-dup-monitor
3911 /usr/libexec/tracker-store
3915 /usr/libexec/tracker-miner-fs
3920 /usr/libexec/deja-dup/deja-dup-monitor
4667 /usr/bin/gpg-agent --sh --daemon --write-env-file /home/jmbastia/.cache/gpg-agent-info
4729 /usr/libexec/gvfsd-trash --spawner :1.3 /org/gtk/gvfs/exec_spaw/0
4781 /usr/libexec/deja-dup/deja-dup-monitor
5907 conky -c /home/jmbastia/.xmonad/conky_dzen
6590 /usr/libexec/deja-dup/deja-dup-monitor
6689 /usr/libexec/menu-cached
7321 /usr/bin/pulseaudio --start --log-target=syslog
7329 /usr/libexec/pulse/gconf-helper
7750 /usr/libexec/tracker-store
7765 /usr/libexec/tracker-miner-fs
7771 /usr/libexec/deja-dup/deja-dup-monitor
8950 /usr/libexec/tracker-store
8959 /usr/libexec/tracker-miner-fs
8964 /usr/libexec/deja-dup/deja-dup-monitor
10154 deja-dup --prompt

It looks like the tracker and deja-dup processes are the worst offenders.

And because of the above processes, I have a bunch of active but stale sessions:

[root@firefly ~]# loginctl list-sessions
   SESSION        UID USER             SEAT
         6        500 jmbastia         seat0           
        10        500 jmbastia         seat0           
        13        500 jmbastia         seat0           
        17        500 jmbastia         seat0           
        19        500 jmbastia         seat0           
        21        500 jmbastia         seat0           
        23        500 jmbastia         seat0           
        24         42 gdm              seat0           
        25          0 root             seat0           

9 sessions listed.
Comment 14 Matthias Clasen 2012-09-26 12:02:53 EDT
different issue, not part of this bug
Comment 15 Jan Sedlák 2012-09-26 13:18:18 EDT
To be honest, today I saw the "missing session" issue too, but with KDE. I log on into KDE with gdm, loged out, but "session" button dissapeared.
Comment 16 Adam Williamson 2012-09-26 13:25:04 EDT
Discussed at 2012-09-26 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-09-26/f18-beta-blocker-review-1.2012-09-26-16.03.log.txt . Rejected as a blocker as session selection is not in the criteria, and no-one seemed particularly keen to add it to them. (We are considering this bug as strictly being about session selection; for the login issue described in the initial report, we've accepted https://bugzilla.redhat.com/show_bug.cgi?id=853964 as a blocker).
Comment 17 Jeff Bastian 2012-09-26 15:51:55 EDT
To shorten and clarify my comment 13:
accountsservice-0.6.25-1.fc18 [1] and systemd-192 [2] fixed the problem for me


[1] http://koji.fedoraproject.org/koji/buildinfo?buildID=356409
[2] http://koji.fedoraproject.org/koji/buildinfo?buildID=356374
Comment 18 Fedora Update System 2012-09-26 17:22:19 EDT
Package accountsservice-0.6.25-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing accountsservice-0.6.25-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14851/accountsservice-0.6.25-1.fc18
then log in and leave karma (feedback).
Comment 19 Jens Petersen 2012-10-01 02:31:14 EDT
Thanks - accountsservice-0.6.25 looks to be working well for me.

Note You need to log in before you can comment on or make changes to this bug.