Bug 856242 - spice software cursor jumping to the edges and corners randomly
spice software cursor jumping to the edges and corners randomly
Status: CLOSED DUPLICATE of bug 852841
Product: Fedora
Classification: Fedora
Component: spice-vdagent (Show other bugs)
18
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-09-11 10:46 EDT by David Jaša
Modified: 2012-09-12 09:19 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 856250 856252 (view as bug list)
Environment:
Last Closed: 2012-09-12 09:19:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-09-11 10:46:13 EDT
Description of problem:
spice software cursor jumping to the edges and corners randomly
  * latest 0.12.something from koji doesn't have this bug
  * the bug occurs when I rebuild current fedora's 0.10 in RHEL
==> rebase to 0.12 would fix the thing

Version-Release number of selected component (if applicable):
spice-vdagent-0.10

How reproducible:
always

Steps to Reproduce:
1. grab a window in a VM running spice-vdagent, move it slowly
2.
3.
  
Actual results:
cursor and window jumps sometimes to the edges and back

Expected results:
cursor should move just as mouse moves

Additional info:
F17 (and probably F16) is affected as well making especially gnome-shell unusable because of unwanted Activities triggering so rebase of spice-vdagent there would be also wise.
Comment 1 Kamil Páral 2012-09-11 11:06:23 EDT
I can confirm I see this too. It occurs randomly, but quite frequently. Long-term work in virtual machines is almost impossible, at least in GNOME.
Comment 2 Adam Williamson 2012-09-11 12:35:40 EDT
yeah, I see this too. it's pretty annoying but hasn't really prevented me from testing entirely, so I'd probably call it NTH not blocker. There's also the obvious workaround of using VNC not Spice.
Comment 3 Andre Robatino 2012-09-11 12:36:06 EDT
Is this related to bug 852841? That affects VirtualBox guests (but vbox uses the vesa driver).
Comment 4 Adam Williamson 2012-09-11 14:44:34 EDT
No, vbox doesn't use spice.
Comment 5 Jaroslav Reznik 2012-09-11 14:55:26 EDT
Could be NTH as it's annoying, especially in Gnome Shell. In Plasma it's not as bad as the left top corner is not as sensitive and expose works only with more apps running. But happens sometimes.

Workaround is known.
Comment 6 Tim Flink 2012-09-11 14:58:55 EDT
I'm seeing similar behavior with VNC, as well. It isn't as bad as with spice but still well past the point of being a minor annoyance.

Are we sure that this is limited to F18? I remember hitting the same problem in an F17 VM recently as well.

I'm +1 NTH on this and I think that it's borderline blocker even though virt requirements are beta, not alpha.
Comment 7 kartochka22 2012-09-11 15:09:04 EDT
I am sure it is not spice related, same jumps to corners in spice and vnc, spice tend to be more frequent jumps. More jumps when hover pointer around element boundary, as close button. F17 host, F18 alpha RC2+updates, i7 + intel video.
Comment 8 Adam Williamson 2012-09-11 15:53:52 EDT
actually, I might be wrong there - I thought if a spice-vdagent update fixes it, they can't possibly be the same bug, but I think David's wrong: I did a spice-vdagent update and I still see the bug. So they may in fact be the same.
Comment 9 Adam Williamson 2012-09-11 15:56:10 EDT
Let's just mark this a dupe.

*** This bug has been marked as a duplicate of bug 852841 ***
Comment 10 David Jaša 2012-09-12 05:03:10 EDT
(In reply to comment #8)
> actually, I might be wrong there - I thought if a spice-vdagent update fixes
> it, they can't possibly be the same bug, but I think David's wrong: I did a
> spice-vdagent update and I still see the bug. So they may in fact be the
> same.

Given that I was able to "backport" this bug to RHEL just by rebuilding & using current Fedora package there, this indicates that the same ui bug is caused by two distinct actual bugs - this one being one of them, the other yet to be pinpointed.

If you disagree, feel free to close again.
Comment 11 Hans de Goede 2012-09-12 06:04:33 EDT
Hmm,

I have a feeling the may be related to the special vmware mouse mode of ps/2 mouse emulation. David, can you downgrade to the 0.10 agent again, and when you reproduce this check if the agent is still running ? I think this may be happening when the agent is disconnected. Also check qemu.log wrt agent mouse mode messages please, thanks.

Also to all who are seeing this which version of qemu-kvm & spice-server are you running on the host ?

Regards,

Hans
Comment 12 Kamil Páral 2012-09-12 07:09:03 EDT
(In reply to comment #11)
> Also to all who are seeing this which version of qemu-kvm & spice-server are
> you running on the host ?

qemu-kvm-1.0.1-1.fc17.x86_64
spice-server-0.10.1-5.fc17.x86_64

In my F18 guest spice-vdagentd is running (as reported by systemd and ps).
Comment 13 Hans de Goede 2012-09-12 07:26:13 EDT
Hi,

Me again, 2 more things:
1) Can you try doing: sudo rpm -e --nodeps xorg-x11-drv-vmmouse, and then restarting Xorg ?
2) Another possible culprit could be a usb-tablet, does the vm have a usb-tablet (see lsusb in the guest) ? 

Regards,

Hans
Comment 14 Hans de Goede 2012-09-12 07:26:44 EDT
From: https://bugzilla.redhat.com/show_bug.cgi?id=852841#c8

Created attachment 612060 [details]
Xorg.0.log

ad 1) Didn't help even after reboot.

ad 2) Default VMs in virt-manager have EvTouch tablet assigned. If I remove it and reboot, the issue is still present.
Comment 15 Hans de Goede 2012-09-12 07:28:51 EDT
Ok, since virtualbox users are seeing this too, and some people report downgrading the guest to xorg-server to 1.12.0-2 helps, I'm getting the feeling that this may be a generic xorg bug with absolute input devices.

Can you try disabling / removing the spice-agent, and then re-enabling the usb-tablet, and see if you can reproduce it that way too ?
Comment 16 Kamil Páral 2012-09-12 07:46:09 EDT
I have uninstalled spice-vdagent package, but I still see the issue as long as I have the EvTouch tablet assigned. Once I delete it from the VM configuration and reboot, I no longer see the issue.

But if I install back spice-vdagent, the issue appears again when I don't have the tablet assigned.

So the only way how to fix this issue is to remove spice-vdagent AND remove the tablet. Any other combination breaks it.
Comment 17 David Jaša 2012-09-12 07:50:25 EDT
(In reply to comment #11)
> David, can you downgrade to the 0.10 agent again, and when you 
> reproduce this check if the agent is still running ? I think 
> this may be happening when the agent is disconnected.

Agent is connected, I can successfully do guest <--> client copy & paste or resolution change triggered by client window resize for instance, but the log says this (after I exit session, clear the logs, restart vdagent and start session again):

[root@virt-rhel6 ~]# cat /var/log/spice-vdagentd/spice-vdagentd.log 
GetSessionForUnixProcess failed: Unable to find session for cookie
GetSessionForUnixProcess failed: Unable to find session for cookie
reading unix domain socket: Connection reset by peer, disconnecting 0x7c1130
opening vdagent virtio channel
closed vdagent virtio channel
GetSessionForUnixProcess failed: Unable to find session for cookie
reading unix domain socket: Connection reset by peer, disconnecting 0x7c9b40
opening vdagent virtio channel
closed vdagent virtio channel
opening vdagent virtio channel
Clipboard request from agent which is not in the active session?
<last msg repeated many times>

> Also to all who are seeing this which version of qemu-kvm & spice-server are > you running on the host ?

RHEL 6.4:
qemu-kvm-0.12.1.2-2.312.el6.x86_64
spice-server-0.10.1-10.el6.x86_64

and RHEL 6.3 in RHEV - it's a bit less frequent here but occurs too:
qemu-kvm-rhev-0.12.1.2-2.295.el6.x86_64
spice-server-0.10.1-10.el6.x86_64

(In reply to comment #13)
> Hi,
> 
> Me again, 2 more things:
> 1) Can you try doing: sudo rpm -e --nodeps xorg-x11-drv-vmmouse, and then
> restarting Xorg ?

Yes, I did this and the problem persists:
bash-4.1$ rpm -q spice-vdagent xorg-x11-drv-vmmouse
spice-vdagent-0.10.1-1.el6.x86_64
package xorg-x11-drv-vmmouse is not installed


> 2) Another possible culprit could be a usb-tablet, does the vm have a
> usb-tablet (see lsusb in the guest) ? 

No, the machine has only PS/2 mouse, USB devices are for smartcard and usbredir only.

> 
> Regards,
> 
> Hans
Comment 18 Kamil Páral 2012-09-12 07:51:09 EDT
I might not attend today's blocker bug meeting. My vote is a definite +1 NTH and I'm neutral about blocker status. Only if no one has any strong opinion about it, then I incline to +1 blocker. (That is related to this issue as a whole. If we fix the issue just for vnc/vesa, but not for spice, I'm OK with that and I don't see it as a blocking issue anymore.)
Comment 19 David Jaša 2012-09-12 07:54:17 EDT
(In reply to comment #16)
> I have uninstalled spice-vdagent package, but I still see the issue as long
> as I have the EvTouch tablet assigned. Once I delete it from the VM
> configuration and reboot, I no longer see the issue.
> 
> But if I install back spice-vdagent, the issue appears again when I don't
> have the tablet assigned.
> 
> So the only way how to fix this issue is to remove spice-vdagent AND remove
> the tablet. Any other combination breaks it.

Have you tried updating spice-vdagent to latest .fc18 from koji? It fixed the issue in my f17 VMs.

(also clearing the needinfo on Adam)
Comment 20 David Jaša 2012-09-12 08:06:08 EDT
OK, my bad, after more thorough testing, the issue still persists, it is just less frequent and the mouse now jumps mostly to closest edge so Activities aren't triggered that often.
Comment 21 David Jaša 2012-09-12 08:31:44 EDT
My bad, 2nd time: when I'm patient enough (moving some window very slowly long enough), I can also reproduce in RHEL 6 VM with 0.12, so spice-vdagent 0.10 is definitely not the culprit, it just makes things worse.

(In reply to comment #15)
> Ok, since virtualbox users are seeing this too, and some people report
> downgrading the guest to xorg-server to 1.12.0-2 helps, I'm getting the
> feeling that this may be a generic xorg bug with absolute input devices.
> 
> Can you try disabling / removing the spice-agent, and then re-enabling the
> usb-tablet, and see if you can reproduce it that way too ?

Yes, it occurs with usb-tablet & disabled vdagent, too (in RHEL 6 VM).
Comment 22 Hans de Goede 2012-09-12 09:19:41 EDT
(In reply to comment #21)
> Yes, it occurs with usb-tablet & disabled vdagent, too (in RHEL 6 VM).

How up2date is this RHEL-6 vm / which xorg-server version does it use ?
I'm pretty sure that since this is being seen with both virtualbox & qemu-vnc & qemu-spice, and with
both spice-vdagent and usb-tablets with qemu that this is an xorg bug. So I believe that the initial marking as duplicate of bug 852841 was correct!

*** This bug has been marked as a duplicate of bug 852841 ***

Note You need to log in before you can comment on or make changes to this bug.