Bug 857544 - Install: livecd-tools needs to obsolete rhev-hypervisor*-tools
Install: livecd-tools needs to obsolete rhev-hypervisor*-tools
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.2.0
Unspecified Unspecified
high Severity high
: ---
: 3.2.0
Assigned To: Tim Hildred
ecs-bugs
: Documentation, Reopened
Depends On: 857532 857534
Blocks: 857546 857547
  Show dependency treegraph
 
Reported: 2012-09-14 15:26 EDT by Stephen Gordon
Modified: 2014-03-25 03:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 857534
: 857546 (view as bug list)
Environment:
Last Closed: 2013-06-27 04:59:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2012-09-14 15:26:34 EDT
This will likely be 3.1.0-z, RHEV 3.1 will GA with RHEV-H 6.3 hosts but these will quickly be obsoleted by RHEV-H 6.4 in early 2013. 

Need to take into account that users aren't likely in a hurry to jump to RHEV-H 6.4 so we're probably going to need to keep both the old and new instructions around for at least some period of time.

+++ This bug was initially created as a clone of Bug #857534 +++

Because of this, we need to make some doc updates:

1.  all references to rhevh-iso-to-pxeboot or rhevh-iso-to-disk need to be updated to be livecd-iso-to-*

2.  all places where it says to install rhev-hypervisor-tools or rhev-hypervisor6-tools should be updated to say livecd-tools or ovirt-node-tools (which will pull in livecd-tools).



+++ This bug was initially created as a clone of Bug #857532 +++

Description of problem:
Currently, some of the tools in livecd-tools are repackaged in rhev-hypervisor*tools packages since livecd-tools wasn't shipped.

Now that it is, we should obsolete rhev-hypervisor*tools.



Obsoletes rhev-hypervisor-tools < 2.5.0
Obsoletes rhev-hypervisor6-tools < 6.3
Obsoletes rhev-hypervisor5-tools < 5.9
Comment 1 Stephen Gordon 2012-11-08 10:11:56 EST
Re-opened for 3.2.0 scoping, flags will follow.
Comment 2 Tim Hildred 2013-03-13 03:23:32 EDT
Affects:
Installing the Red Hat Enterprise Virtualization Hypervisor Packages [7525]
Preparing USB Installation Media using rhevh-iso-to-disk [7527]
Comment 3 Tim Hildred 2013-03-13 21:38:20 EDT
According to mburns, we only need to mention livecd-iso-to-*, as RHEV 3.2 requires RHEL 6.4. 

Updated:
Installing the Red Hat Enterprise Virtualization Hypervisor Packages [7525, rev: 383836]
Preparing USB Installation Media using rhevh-iso-to-disk [7527, rev: 383838]

Moving to MODIFIED, will change to ON_QA when I stage.

Note You need to log in before you can comment on or make changes to this bug.