This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 859069 - When doing a minimal install, the root password is not set.
When doing a minimal install, the root password is not set.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
: Reopened
: 854982 862236 (view as bug list)
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-09-20 09:48 EDT by William Brown
Modified: 2013-03-12 10:24 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 10:31:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description William Brown 2012-09-20 09:48:44 EDT
Description of problem:
When a minimal or server install option is selected, the root password is not made a mandatory option to change.

How reproducible:
Always

Steps to Reproduce:
1. Start anaconda
2. Select minimal install
3. Install and reboot
  
Actual results:
You are locked out of your system, since no root password was set. 

Expected results:
You are prompted for the root password. Alternately, steps from "first boot" are run in anaconda to create an alternate user etc.
Comment 1 Chris Lumens 2012-09-20 11:23:52 EDT
The final plan here is that the presence or absence of the firstboot package will make the root password spoke required or not.  However, for now you've just got to know to go into that spoke.  This is already a little bit different post-alpha in that it's moved to the progress bar hub.
Comment 2 Jesse Keating 2012-10-02 13:13:42 EDT
*** Bug 862236 has been marked as a duplicate of this bug. ***
Comment 3 Jesse Keating 2012-10-05 18:31:06 EDT
*** Bug 854982 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2012-10-10 21:05:33 EDT
anaconda-18.15-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.15-1.fc18
Comment 5 Fedora Update System 2012-10-10 22:59:11 EDT
Package anaconda-18.15-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.15-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15903/anaconda-18.15-1.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-10-11 21:07:21 EDT
anaconda-18.16-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.16-1.fc18
Comment 7 Fedora Update System 2012-10-16 23:10:25 EDT
anaconda-18.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.17-1.fc18
Comment 8 Fedora Update System 2012-10-17 22:39:11 EDT
anaconda-18.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.18-1.fc18
Comment 9 Fedora Update System 2012-10-19 21:35:01 EDT
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.19-1.fc18
Comment 10 Kamil Páral 2012-10-23 10:17:15 EDT
With Anaconda 18.19, you have to enter the root password dialog now. You can still disable it, but then it's your conscious choice. Closing as fixed.
Comment 11 Ladislav Jozsa 2012-10-24 06:34:55 EDT
Kamil, you're right that is your conscious choice. However anaconda should at least warn user (if not disallow it in specific cases) that having root password disabled might result in unbootable system which is exactly the case of Minimal install and disabled root password.
Comment 12 Ladislav Jozsa 2012-10-24 06:35:56 EDT
Sorry, not unbootable - but unusable.
Comment 13 Kamil Páral 2012-10-24 10:02:19 EDT
(In reply to comment #11)
Warning in certain cases would be nice, no doubt about it. But I think a separate bug would be more appropriate.
Comment 14 Ladislav Jozsa 2012-10-24 10:31:19 EDT
OK, filed bug 869675, closing this one.

Note You need to log in before you can comment on or make changes to this bug.