Bug 859298 - dracut-cmdline[60] Warning: Option 'KEYTABLE' is deprecated, use 'KEYMAP' instead [Fedora 18 KDE LiveCD Alpha]
dracut-cmdline[60] Warning: Option 'KEYTABLE' is deprecated, use 'KEYMAP' ins...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
: 858963 864356 888949 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 23:38 EDT by xset1980
Modified: 2013-12-19 13:26 EST (History)
22 users (show)

See Also:
Fixed In Version: anaconda-18.11-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 13:26:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (4.62 KB, image/png)
2012-09-20 23:38 EDT, xset1980
no flags Details

  None (edit)
Description xset1980 2012-09-20 23:38:09 EDT
Created attachment 615264 [details]
screenshot

Description of problem:


On the boot process, F18 Alpha LiveCD KDE show the message:

dracut-cmdline[60] Warning: Option 'KEYTABLE' is deprecated, use 'KEYMAP' instead


Version-Release number of selected component (if applicable):

Fedora 18 KDE LiveCD Alpha up to date, kernel 3.6 rc6

How reproducible:

Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Attach screenshot
Comment 1 Harald Hoyer 2012-09-24 10:13:58 EDT
(In reply to comment #0)
> Created attachment 615264 [details]
> screenshot
> 
> Description of problem:
> 
> 
> On the boot process, F18 Alpha LiveCD KDE show the message:
> 
> dracut-cmdline[60] Warning: Option 'KEYTABLE' is deprecated, use 'KEYMAP'
> instead


The kernel command line should use the new syntax then.
Comment 2 Brian Lane 2012-09-24 13:10:16 EDT
livecd-tools and spins don't appear to be setting this. Any idea where it comes from?
Comment 3 xset1980 2012-09-24 21:50:37 EDT
(In reply to comment #2)
> livecd-tools and spins don't appear to be setting this. Any idea where it
> comes from?

No idea, is a LiveCD of Fedora 18 KDE Alpha, fresh install on a Vbox machine.

md5sum:

4ef01dc6ecd8254de615cf1bd8a44879  Fedora-18-Alpha-i686-Live-KDE.iso
Comment 4 xset1980 2012-09-24 21:52:59 EDT
@brian @herald,

if you need to perform some test, tell me, I am at your disposal and my vbox machine too
Comment 5 xset1980 2012-09-25 23:09:54 EDT
Any progress with this bug?
Comment 6 xset1980 2012-09-25 23:13:14 EDT
I can't see any KEYTABLE string on /etc/default/grub or /etc/grub.d/* files
Comment 7 Harald Hoyer 2012-09-26 06:56:23 EDT
Is this with booting the LiveCD, or after _installing_ from the LiveCD and booting without the LiveCD?

If it is after installing, reassign to anaconda.
Comment 8 xset1980 2012-09-27 16:35:24 EDT
(In reply to comment #7)
> Is this with booting the LiveCD, or after _installing_ from the LiveCD and
> booting without the LiveCD?
> 
> If it is after installing, reassign to anaconda.

After installing, booting Fedora 18 Alpha from the HDD, when the system is installed and up to date.
Comment 9 Harald Hoyer 2012-09-28 07:36:25 EDT
Sorry, the error message was wrong.

SYSFONT -> vconsole.font
FONT -> vconsole.font

KEYTABLE -> vconsole.keymap
KEYMAP -> vconsole.keymap

FONT_MAP -> vconsole.font.map
CONTRANS -> vconsole.font.map

FONT_UNIMAP -> vconsole.font.unimap
UNIMAP -> vconsole.font.unimap

UNICODE -> vconsole.font.unicode

EXT_KEYMAP -> vconsole.keymap.ext
Comment 10 Fedora Update System 2012-10-02 10:12:33 EDT
anaconda-18.11-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.11-1.fc18
Comment 11 Fedora Update System 2012-10-02 15:46:56 EDT
Package anaconda-18.11-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.11-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15207/anaconda-18.11-1.fc18
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-10-03 20:57:22 EDT
anaconda-18.12-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.12-1.fc18
Comment 13 Harald Hoyer 2012-10-09 11:45:55 EDT
*** Bug 864356 has been marked as a duplicate of this bug. ***
Comment 14 Bill Nottingham 2012-10-25 23:58:15 EDT
Reopening, something seems wrong here.

vconsole.* are kernel commandline parameters.

KEY* are /etc/sysconfig/i18n paraemters.

According to the vconsole.conf man page, options are:

OPTIONS
       The following options are understood:

       KEYMAP=, KEYMAP_TOGGLE=
           Configures the key mapping table for the keyboard.  KEYMAP=
           defaults to us if not set. The KEYMAP_TOGGLE= can be used to
           configured a second toggle keymap and is by default unset.

       FONT=, FONT_MAP=, FONT_UNIMAP=
           Configures the console font, the console map and the unicode font
           map.

The current code is writing vconsole.* to /etc/sysconfig/i18n (invalid), and KEYMAP to /etc/vconsole.conf (looks right).

I believe it should be writing KEYMAP to both. Sending patch.
Comment 15 Chris Lumens 2013-01-03 16:58:55 EST
*** Bug 888949 has been marked as a duplicate of this bug. ***
Comment 16 oliver 2013-01-17 10:09:57 EST
fedora17 upgrade fedora18 restart
system upgrade (fedora)
show the message

dracut-cmdline[60] warning kernel command line option "KEYTABLE" is deprecated .use 'vconsle.keymap' instead.
dracut-cmdline[60] warning kernel command line option "SYSFONT" is deprecated .use 'vconsle.font' instead.
Comment 17 oliver 2013-01-17 21:00:53 EST
(In reply to comment #16)
> fedora17 upgrade fedora18 restart
> system upgrade (fedora)
> show the message
> 
> dracut-cmdline[60] warning kernel command line option "KEYTABLE" is
> deprecated .use 'vconsle.keymap' instead.
> dracut-cmdline[60] warning kernel command line option "SYSFONT" is
> deprecated .use 'vconsle.font' instead.
Comment 18 takacsk2004 2013-01-17 23:50:13 EST

(In reply to comment #16)
> fedora17 upgrade fedora18 restart
> system upgrade (fedora)
> show the message
> 
> dracut-cmdline[60] warning kernel command line option "KEYTABLE" is
> deprecated .use 'vconsole.keymap' instead.
> dracut-cmdline[60] warning kernel command line option "SYSFONT" is
> deprecated .use 'vconsole.font' instead.

I modified the line "GRUB_CMDLINE_LINUX" in /etc/default/grub according to the warnings and after that I ran "grub2-mkconfig -o /boot/grub2/grub.cfg". These options can be also set in /etc/vconsole.conf. Apparently /etc/default/grub is not updated or created as grub.rpmnew at the upgrade of grub2-tools, which owns it. See also: http://forums.fedoraforum.org/showthread.php?t=287518
Comment 19 info@kobaltwit.be 2013-03-15 13:45:06 EDT
Is bug 858963 a duplicate of this one ?
Comment 20 Harald Hoyer 2013-03-18 05:17:59 EDT
*** Bug 858963 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.