Bug 860031 - headers use G_GNUC_DEPRECATED_FOR which is glib >= 2.26 only
headers use G_GNUC_DEPRECATED_FOR which is glib >= 2.26 only
Status: CLOSED DUPLICATE of bug 842354
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: Christophe Fergeau
Desktop QE
:
Depends On:
Blocks: 854318
  Show dependency treegraph
 
Reported: 2012-09-24 12:49 EDT by Daniel Berrange
Modified: 2012-10-15 16:45 EDT (History)
5 users (show)

See Also:
Fixed In Version: spice-gtk-0.14-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 16:45:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2012-09-24 12:49:35 EDT
Description of problem:
I am attempting to rebuild virt-viewer 0.5.2 against spice-gtk 0.14-1.el6 in order to address bug 854318. Unfortunately the spice-gtk 0.14 header files appear to use the G_GNUC_DEPRECATED_FOR() macros, which is only available in glib >= 2.26.  RHEL-6 onl has version 2.22, leading to fail

https://brewweb.devel.redhat.com//getfile?taskID=4902863&name=build.log


  CC     virt_viewer-virt-viewer-session.o
In file included from /usr/include/spice-client-glib-2.0/spice-client.h:35,
                 from /usr/include/spice-client-gtk-2.0/spice-widget.h:21,
                 from virt-viewer-session-spice.h:28,
                 from virt-viewer-app.c:62:
/usr/include/spice-client-glib-2.0/channel-main.h:84: warning: return type defaults to 'int'
/usr/include/spice-client-glib-2.0/channel-main.h:83: warning: no previous prototype for 'G_GNUC_DEPRECATED_FOR'
/usr/include/spice-client-glib-2.0/channel-main.h: In function 'G_GNUC_DEPRECATED_FOR':
/usr/include/spice-client-glib-2.0/channel-main.h:85: error: expected declaration specifiers before 'G_GNUC_DEPRECATED_FOR'
/usr/include/spice-client-glib-2.0/channel-main.h:87: error: expected declaration specifiers before 'G_GNUC_DEPRECATED_FOR'
/usr/include/spice-client-glib-2.0/channel-main.h:89: error: expected declaration specifiers before 'G_GNUC_DEPRECATED_FOR'


The spice-gtk package has back compatibility support for this via its glib-compat.h header file, but this is broken, because the compat file is being used by the .c files, instead of by the .h files. Thus although spice-gtk itself builds fine, all apps using spice-gtk are fubar.

Version-Release number of selected component (if applicable):
0.14-1.el6

How reproducible:
Always

Steps to Reproduce:
1. Attempt to build any app using spice-gtk
Comment 2 Christophe Fergeau 2012-09-24 13:16:41 EDT
Oops, we forgot to commit http://lists.freedesktop.org/archives/spice-devel/2012-September/010788.html
I'll readd it to spice-gtk tomorrow.
Comment 3 Christophe Fergeau 2012-09-25 04:44:29 EDT
I've pushed a -2 build with this fixed. I've associated the fixes with spice-gtk rebase bug as this is a build regression introduced by the rebase.
Comment 5 Christophe Fergeau 2012-10-15 16:45:42 EDT
This one was addressed as part of the spice-gtk rebase bug (bug #842354) as the regression was caused by the rebase, I forgot there was this more specific bug. I'm marking it as a duplicate even though it would have been nicer to keep track of this with this bug.

*** This bug has been marked as a duplicate of bug 842354 ***

Note You need to log in before you can comment on or make changes to this bug.