Bug 861096 - pymol segfault on system with intel video card
pymol segfault on system with intel video card
Status: CLOSED DUPLICATE of bug 861158
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 09:53 EDT by Alexei Panov
Modified: 2012-09-27 14:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-27 14:28:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg with drm.debug=0x04 (93.00 KB, text/x-log)
2012-09-27 09:53 EDT, Alexei Panov
no flags Details
Crash log (1.17 KB, text/x-log)
2012-09-27 09:54 EDT, Alexei Panov
no flags Details
/var/log/messages (150.31 KB, application/octet-stream)
2012-09-27 09:55 EDT, Alexei Panov
no flags Details
/var/log/Xorg.0.log (25.75 KB, text/x-log)
2012-09-27 09:56 EDT, Alexei Panov
no flags Details

  None (edit)
Description Alexei Panov 2012-09-27 09:53:49 EDT
Created attachment 618083 [details]
dmesg with drm.debug=0x04

Description of problem:
I've run tests from Fedora 18 Intel Test Day.
When I run pymol and I choose Wizard => Demo => Representations pymol is crashing with segfault. On other systems (radeon, nouveau) pymol works as expected.

Version-Release number of selected component (if applicable):
pymol 1.5.0.2-5.20120218svn3982.fc18
xorg-x11-drv-intel 2.20.8-1.fc18

How reproducible:
All time

Steps to Reproduce:
1. boot livecd from Fedora 18 Intel test day
2. install pymol
3. run pymol
4. go to Wizard => Demo => Representations
  
Actual results:
Crash

Expected results:
pymol works as expected

Additional info:
My smolt profile http://www.smolts.org/client/show/pub_e5d536b1-60a7-4b61-a1fb-894653fd5f54
Comment 1 Alexei Panov 2012-09-27 09:54:36 EDT
Created attachment 618084 [details]
Crash log
Comment 2 Alexei Panov 2012-09-27 09:55:28 EDT
Created attachment 618085 [details]
/var/log/messages
Comment 3 Alexei Panov 2012-09-27 09:56:12 EDT
Created attachment 618086 [details]
/var/log/Xorg.0.log
Comment 4 Steve Tyler 2012-09-27 12:38:59 EDT
Cross-reference:
Bug 861158 - [abrt] python-2.7.3-13.fc18: CShaderPrg_Enable: Process /usr/bin/python2.7 was killed by signal 11 (SIGSEGV)
Comment 5 Steve Tyler 2012-09-27 12:48:42 EDT
(In reply to comment #4)
> Cross-reference:
> Bug 861158 - [abrt] python-2.7.3-13.fc18: CShaderPrg_Enable: Process
> /usr/bin/python2.7 was killed by signal 11 (SIGSEGV)

To get abrt to run, you have to install elfutils manually:
Bug 859674 - abrt ccpp plugin should require elfutils
Comment 6 Alexei Panov 2012-09-27 13:15:41 EDT
Maybe you've right, Steve. Thanks for elfutils.
But abrt create a new Bug 861166.
Comment 7 Dave Malcolm 2012-09-27 14:28:50 EDT

*** This bug has been marked as a duplicate of bug 861158 ***

Note You need to log in before you can comment on or make changes to this bug.