This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 86263 - battery applet broken with acpi
battery applet broken with acpi
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-applets (Show other bugs)
1.0
i386 Linux
low Severity high
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
: Triaged
: 86351 (view as bug list)
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-03-18 11:08 EST by Riccardo Casazza
Modified: 2005-10-31 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-03 15:28:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Riccardo Casazza 2003-03-18 11:08:27 EST
Description of problem: Battery applet does not show the right battery status
but always shows "Battery: 0% Low" even if the battery is fully charged. This
happen with acpi. I state in advance that acpi works in fact the right status of
the battery is fully readable in /proc/acpi/battery/0/status


Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. load acpi modules
2. open X
3. See the applet
    
Actual results:
"Battery: 0% Low"

Expected results:
!= "Battery: 0% Low"

Additional info:
Comment 1 Havoc Pennington 2003-07-30 18:32:46 EDT
gnome-applets in rawhide is newer now, fwiw
Comment 2 Kjartan Maraas 2003-08-23 18:09:18 EDT
And the /proc dir has been rearranged so battstat can't find anything on my
machine at least.

[root@localhost kmaraas]# ls /proc/acpi
alarm  button  embedded_controller  fadt  power_resource
asus   dsdt    event                info  sleep

This is what I have. No "battery" nor "ac_adapter". I don't think battstat is
looking for any others. This is the rawhide gnome-applets and kernel.
Comment 3 Alexander Larsson 2003-08-27 06:23:42 EDT
*** Bug 86351 has been marked as a duplicate of this bug. ***
Comment 4 Alexander Larsson 2003-08-27 06:47:31 EDT
kjartan: Was this with gnome-applets 2.3.6?
Comment 5 Kjartan Maraas 2003-08-28 13:38:54 EDT
Sorry, loading the relevant kernel modules gives me /proc/ac_adapter etc, but I
still don't get any battery info from the applet. It shows the red exclamation
mark. This is gnome-applets-2.3.7-1:

[root@localhost root]# ls /proc/acpi
ac_adapter  battery  embedded_controller  info            sleep
alarm       button   event                power_resource  thermal_zone
asus        dsdt     fadt                 processor
[root@localhost root]#

Please tell me what you need to know about the proc files if anything.
Comment 6 Behdad Esfahbod 2004-01-14 15:55:33 EST
I think this is not a bug.  In reply to comment #5, loading module
"battery" would fix the problem.  In reply to first comment, it has
been an old ACPI code in kernel (which has been shipped in RH9).  The
new ACPI code export the data in /proc/acpi/battery/BAT1, which is
where battstat-applet looks for.

Can be closed IMO.

BTW, there is a patch pending in GNOME bugzilla that adds time
estimataion to this applet.  I have patches against Rawhide SRPMS if
anyone is interested here to include them in Rawhide.  Here is the
GNOME bugzilla report:

http://bugzilla.gnome.org/show_bug.cgi?id=125585
Comment 7 Kjartan Maraas 2004-01-16 13:39:06 EST
Yeah. This can definitely be closed. There's a new gnome-applets out
today that will fix some problems with event handling over the last
release so ACPI should be working just fine with battstat now.
Comment 8 Mark McLoughlin 2004-03-03 15:28:23 EST
Cool, closing now

Note You need to log in before you can comment on or make changes to this bug.