Bug 862883 - anaconda crash if existing filesystem is btrfs
anaconda crash if existing filesystem is btrfs
Status: CLOSED DUPLICATE of bug 862742
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 16:06 EDT by Chris Murphy
Modified: 2013-01-10 01:55 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 18:06:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pyhook anaconda crash log tar bz2 (1.68 KB, application/x-bzip)
2012-10-03 16:06 EDT, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2012-10-03 16:06:53 EDT
Created attachment 621123 [details]
pyhook anaconda crash log tar bz2

Description of problem:
If btrfs volume is present, anaconda crashes on launch.

Version-Release number of selected component (if applicable):
F18 Beta TC1
anaconda-18.11-1.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Ensure a disk or partition has a btrfs file system (empty is fine)
2. Launch installer
  
Actual results:
Crash. /var/messages contains:
Oct  3 15:51:51 localhost abrt: detected unhandled Python exception in '/usr/bin/anaconda-cleanup'
Oct  3 15:51:52 localhost anaconda: /sbin/anaconda 18.11

Expected results:
No crash.

Regression results:
If btrfs is not present the problem does not occur. If I format any partition or disk btrfs, and then relaunch anaconda/installer, it crashes.

Additional info:
Testing in a Virtual Box 4.2.0 VM.
Attaching crash logs folder.
Comment 1 Jesse Keating 2012-10-03 18:06:22 EDT
Marking it a dupe of what I think is the same problem, but I'm not bothering to unpack the archive to look at your traceback.

*** This bug has been marked as a duplicate of bug 862742 ***

Note You need to log in before you can comment on or make changes to this bug.