Bug 864670 - QA:Testcase_Services_start - systemctl --all --failed
QA:Testcase_Services_start - systemctl --all --failed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 18:00 EDT by Flóki Pálsson
Modified: 2012-10-17 08:41 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-17 08:41:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Flóki Pálsson 2012-10-09 18:00:17 EDT
Description of problem:
http://fedoraproject.org/wiki/QA:Testcase_Services_start
# systemctl --all --failed
UNIT              LOAD   ACTIVE SUB    JOB DESCRIPTION
firewalld.service loaded failed failed     firewalld - dynamic firewall daemon
libvirtd.service  loaded failed failed     Virtualization daemon
nfs-idmap.service loaded failed failed     NFSv4 ID-name mapping daemon

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.
JOB    = Pending job for the unit.

3 loaded units listed.
To show all installed unit files use 'systemctl list-unit-files'.


Version-Release number of selected component (if applicable):
systemd-194-1.fc18.x86_64

How reproducible:
always 

Steps to Reproduce:
1. # systemctl --all --failed se http://fedoraproject.org/wiki/QA:Testcase_Services_start
2.
3.
  
Actual results:
UNIT              LOAD   ACTIVE SUB    JOB DESCRIPTION
firewalld.service loaded failed failed     firewalld - dynamic firewall daemon
libvirtd.service  loaded failed failed     Virtualization daemon
nfs-idmap.service loaded failed failed     NFSv4 ID-name mapping daemon

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.
JOB    = Pending job for the unit.

3 loaded units listed.
To show all installed unit files use 'systemctl list-unit-files'.


Expected results:
All services should start properly and systemctl reports no failed service 

Additional info:
F18 installed from Fedora-18-Beta-TC2-x86_64-Live-Desktop.iso.
Firstboot did not work.
Comment 1 Bill Nottingham 2012-10-09 22:47:09 EDT
While this will likely have to be split into separate bugs for each service, can you post the output of 'systemctl status' for each of these, so we can see why/how they failed? Thanks!
Comment 2 Flóki Pálsson 2012-10-10 04:22:04 EDT
[root@localhost ~]# systemctl status firewalld.service 
firewalld.service - firewalld - dynamic firewall daemon
	  Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled)
	  Active: failed (Result: exit-code) since Wed, 10 Oct 2012 07:56:53 +0000; 22min ago
	Main PID: 545 (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/firewalld.service

Oct 10 07:56:53 localhost.localdomain systemd[1]: Failed to start firewalld - dynamic firewall daemon.


[root@localhost ~]# systemctl status libvirtd.service
libvirtd.service - Virtualization daemon
	  Loaded: loaded (/usr/lib/systemd/system/libvirtd.service; enabled)
	  Active: failed (Result: exit-code) since Wed, 10 Oct 2012 07:57:18 +0000; 23min ago
	Main PID: 700 (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/libvirtd.service

Oct 10 07:57:18 localhost.localdomain systemd[1]: Starting Virtualization daemon...
Oct 10 07:57:18 localhost.localdomain systemd[1]: Started Virtualization daemon.
Oct 10 07:57:18 localhost.localdomain libvirtd[700]: /usr/sbin/libvirtd: initialization failed


[root@localhost ~]# systemctl status nfs-idmap.service
nfs-idmap.service - NFSv4 ID-name mapping daemon
	  Loaded: loaded (/usr/lib/systemd/system/nfs-idmap.service; disabled)
	  Active: failed (Result: exit-code) since Wed, 10 Oct 2012 07:57:18 +0000; 23min ago
	  CGroup: name=systemd:/system/nfs-idmap.service

Oct 10 07:57:18 localhost.localdomain systemd[1]: Failed to start NFSv4 ID-name mapping daemon.
[root@localhost ~]#
Comment 3 Lennart Poettering 2012-10-12 17:53:41 EDT
Could you please file three individual bugs for this against the respective packages firewalld, libvirtd, nfs-idmap? 

systemd is barely the messenger here, not the culprit.
Comment 4 Flóki Pálsson 2012-10-13 04:23:12 EDT
>Could you please file three individual bugs for this against the respective >packages firewalld, libvirtd, nfs-idmap? 

Bug 866004 - systemctl status firewalld.service - failed
Bug 866005 - systemctl status libvirtd.service - error 
Bug 866006 - systemctl status nfs-idmap.service - failed
Comment 5 Flóki Pálsson 2012-10-13 07:44:15 EDT
Now ok
I reinstalled from Fedora-18-Beta-TC3-x86_64-Live-Desktop.iso
and yum update 
and reboot
# systemctl --all --failed
UNIT LOAD   ACTIVE SUB JOB DESCRIPTION

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.
JOB    = Pending job for the unit.

0 loaded units listed.
To show all installed unit files use 'systemctl list-unit-files'.
[root@localhost ~]#
Comment 6 Lennart Poettering 2012-10-17 08:41:19 EDT
OK; closing then.

Note You need to log in before you can comment on or make changes to this bug.