This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 866563 - '@VERSION@' displayed in exception report, not version string
'@VERSION@' displayed in exception report, not version string
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-kickstart (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 11:55 EDT by Steve Tyler
Modified: 2013-02-07 21:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-07 21:27:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing '@VERSION@', instead of version string (148.54 KB, image/png)
2012-10-15 11:55 EDT, Steve Tyler
no flags Details

  None (edit)
Description Steve Tyler 2012-10-15 11:55:17 EDT
Created attachment 627546 [details]
screenshot showing '@VERSION@', instead of version string

Description of problem:
When an exception is raised in system-config-kickstart, the resulting exception report shows the string '@VERSION@', instead of the version string.

Version-Release number of selected component (if applicable):
system-config-kickstart-2.8.8-2.fc17.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Modify a copy of system-config-kickstart to raise an exception after the exception handler is installed (see below).
2. $ ./system-config-kickstart.TEST
  
Actual results:
See attached screenshot.

Expected results:
Version string is displayed.

Additional info:

Examples:
Bug 689161 - OSError: [Errno 13] Permission denied: '/var/tmp/yum-njd-LrUZic' 
Bug 866442 - AttributeError: 'module' object has no attribute 'Firewall'
Bug 820748 - system-config-kickstart is broken 
Bug 582755 - AttributeError: 'NoneType' object has no attribute 'contains' 

Patch to raise exception in system-config-kickstart:
$ diff -u /usr/bin/system-config-kickstart system-config-kickstart.TEST
--- /usr/bin/system-config-kickstart	2012-01-14 16:57:54.000000000 -0800
+++ system-config-kickstart.TEST	2012-10-15 08:42:15.636075606 -0700
@@ -102,4 +102,5 @@
     handler = ExceptionHandler(config, GraphicalIntf(), ExceptionDump)
     handler.install(ksGui)
 
+    import foo
     ksGui.run()
Comment 1 Vratislav Podzimek 2012-10-16 04:26:21 EDT
(In reply to comment #0)
> Created attachment 627546 [details]
> screenshot showing '@VERSION@', instead of version string
> 
> Description of problem:
> When an exception is raised in system-config-kickstart, the resulting
> exception report shows the string '@VERSION@', instead of the version string.
This looks like a autotools macro. How did you get the copy of system-config-kickstart? I guess you have just copied the tree from the sources, right?
Comment 2 Steve Tyler 2012-10-16 06:30:49 EDT
From a suitable working directory:

$ cp -ip `which system-config-kickstart` system-config-kickstart.TEST
$ ./system-config-kickstart.TEST

That seems to work ...
Comment 3 Vratislav Podzimek 2012-10-16 06:43:15 EDT
(In reply to comment #2)
> From a suitable working directory:
> 
> $ cp -ip `which system-config-kickstart` system-config-kickstart.TEST
> $ ./system-config-kickstart.TEST
> 
> That seems to work ...
Closing this as NOTABUG then.
Comment 4 Steve Tyler 2012-10-16 07:00:33 EDT
The exception reports shown in the examples in Comment 0 have '@VERSION@' instead of an actual version string. That is indeed a bug. Using a modified system-config-kickstart.TEST is a reproducer.

I reran the same reproducer from /usr/bin/ and got the same results:
$ /usr/bin/system-config-kickstart.TEST

Can you suggest a better reproducer?

$ diff -u /usr/bin/system-config-kickstart /usr/bin/system-config-kickstart.TEST
--- /usr/bin/system-config-kickstart	2012-01-14 16:57:54.000000000 -0800
+++ /usr/bin/system-config-kickstart.TEST	2012-10-16 03:49:52.972743543 -0700
@@ -102,4 +102,5 @@
     handler = ExceptionHandler(config, GraphicalIntf(), ExceptionDump)
     handler.install(ksGui)
 
+    import foo
     ksGui.run()
Comment 5 Steve Tyler 2012-10-16 07:14:29 EDT
And the bug has been present for some time:

Example 1:

Bug 582755 - AttributeError: 'NoneType' object has no attribute 'contains' 

 Andrew Jamison 2010-04-15 14:07:01 EDT

The following was filed automatically by system-config-kickstart:
system-config-kickstart @VERSION@ exception report
Traceback (most recent call last):

Example 2:

Bug 689161 - OSError: [Errno 13] Permission denied: '/var/tmp/yum-njd-LrUZic' 

 Nathan 2011-03-19 20:58:59 EDT

The following was filed automatically by system-config-kickstart:
system-config-kickstart @VERSION@ exception report
Traceback (most recent call last):
Comment 6 Steve Tyler 2012-10-16 07:18:30 EDT
Example 3:

Bug 512458 - test bug 

 Chris Lumens 2009-07-17 15:08:52 EDT

The following was filed automatically by system-config-kickstart:
system-config-kickstart @VERSION@ exception report
Traceback (most recent call last):
Comment 7 Vratislav Podzimek 2012-10-16 07:20:36 EDT
Okay, I understand it now and will look at it.
Comment 8 Steve Tyler 2012-10-16 07:45:35 EDT
(In reply to comment #7)
> Okay, I understand it now and will look at it.

Thanks.

BTW, fault injection by source modification is used in some QA test cases:

QA:Testcase Libreport anaconda
https://fedoraproject.org/wiki/QA:Testcase_Libreport_anaconda
Comment 9 Chris Lumens 2012-11-12 10:50:11 EST
Fixed on master, but it is likely to be quite a while before I can do a new build for master or an update for F17.  anaconda is keeping me busy.
Comment 10 Fedora Update System 2013-02-01 11:58:09 EST
system-config-kickstart-2.9.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/system-config-kickstart-2.9.0-1.fc18
Comment 11 Fedora Update System 2013-02-01 23:29:12 EST
Package system-config-kickstart-2.9.0-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-kickstart-2.9.0-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1856/system-config-kickstart-2.9.0-1.fc18
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-02-07 21:27:17 EST
system-config-kickstart-2.9.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.