Bug 867134 - User Portal - auto-connect selected only works once per browser session
User Portal - auto-connect selected only works once per browser session
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.2.0
Assigned To: Frantisek Kobzik
Jiri Belka
virt
: ZStream
: 915604 918175 (view as bug list)
Depends On:
Blocks: 887865 915537 918175 919171
  Show dependency treegraph
 
Reported: 2012-10-16 16:45 EDT by Vimal Patel
Modified: 2015-09-22 09 EDT (History)
16 users (show)

See Also:
Fixed In Version: sf13.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 887865 918175 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vimal Patel 2012-10-16 16:45:35 EDT
Description of problem:
Auto-Connect feature of RHEVM 3.1 only works once per browser session.  If the user logs out and tries to reconnect with Auto-Connect selected, the remote-viewer window is not automatically brought up as expected, the user needs to close the browser and bring up a new instance before it works.

*Tested on  the following clients:
Firefox on RHEL 5.9 & IE 9 on Windows 7


Version-Release number of selected component (if applicable):
RHEVM 3.1 si20

How reproducible:
100%

Steps to Reproduce:
1.  Go to the user portal, where the user only has one VM that is up, have the Connect Automatically checkbox selected, and login.
2.  Logout and repeat.
  
Actual results:
Only the first time the user has the connect automatically checkbox selected, does it work, after that the remote-viewer window is not automatically brought up.

Expected results:
Remote-Viewer window is brought up every time.

Additional info:
Comment 2 Frantisek Kobzik 2012-10-26 10:41:56 EDT
In gerrit: http://gerrit.ovirt.org/#/c/8851/
Comment 3 Frantisek Kobzik 2012-10-30 04:09:41 EDT
Merged upstream: c40388e36d1b094bd93f1ace07e7fc2c5c60da40
Comment 6 Jiri Belka 2013-01-23 04:33:19 EST
OK, sf3.
Comment 7 Vaclav Ehrlich 2013-03-06 06:31:18 EST
On RHEVM 3.2 sf9 is not working. 
Client RHEL 6.4 64b
Guest WinXP 32b

This bug should re-open.
Comment 8 Jiri Belka 2013-03-06 06:57:39 EST
Works correctly on sf9 (RHEL6.4 64bit FF17, WinXP 32bit IE8).

Please double check your RHEVM version and type exact steps. Thanks.
Comment 9 Jiri Belka 2013-03-06 08:03:49 EST
The issue is related to Extended view with one VM, this is supported for auto-connect.

I tested this with WinXP IE8 = works, W2K8 64bit IE8 = does not even open first console, W7 32bit IE9 = opens only once, W2K12 IE10 = opens only once, RHEL6.4 FF17 = opens only once.
Comment 10 Michal Skrivanek 2013-03-06 09:20:09 EST
*** Bug 918175 has been marked as a duplicate of this bug. ***
Comment 12 Vimal Patel 2013-04-15 14:31:50 EDT
Verified that auto-connect from the user portal works multiple times per browser session for RHEVM 3.2 sf13.1
* Tested with IE 10, Windows 7 x86_64
* Tested with FF ESR 10.0.12, RHEL6.4, x86_64
Comment 13 Frantisek Kobzik 2013-05-02 04:49:23 EDT
*** Bug 915604 has been marked as a duplicate of this bug. ***
Comment 14 Itamar Heim 2013-06-11 04:35:01 EDT
3.2 has been released
Comment 15 Itamar Heim 2013-06-11 04:35:01 EDT
3.2 has been released
Comment 16 Itamar Heim 2013-06-11 04:35:07 EDT
3.2 has been released
Comment 17 Itamar Heim 2013-06-11 04:43:55 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.