This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 867332 - /usr/sbin/groupmems is not setuid root
/usr/sbin/groupmems is not setuid root
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
6.3
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Peter Schiffer
Iveta Wiedermann
: ManPageChange, Patch
Depends On:
Blocks: 878467 886216
  Show dependency treegraph
 
Reported: 2012-10-17 06:35 EDT by Alain D D Williams
Modified: 2013-02-21 05:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: groupmems(8) manual page was missing information about setuid right of groupmems binary Consequence: incomplete documentation Fix: clarify setuid right of groupmems binary in the groupmems(8) manual page Result: complete documentation
Story Points: ---
Clone Of:
: 878467 1292820 (view as bug list)
Environment:
Last Closed: 2013-02-21 05:54:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Manual page patch (631 bytes, patch)
2012-11-19 14:04 EST, Tomas Mraz
no flags Details | Diff

  None (edit)
Description Alain D D Williams 2012-10-17 06:35:22 EDT
Description of problem:

Using groupmems a user should be able to change who is a member of his primary group. For this it needs to be setuid root.

The man page says ''The groupmems executable should be in mode 2770 as user root and in group groups.''

Version-Release number of selected component (if applicable):

RedHat enterprise 6 - groupmems was not in RHE5.

Either it should be made setuid root (and its SElinux label changed to system_u:object_r:groupadd_exec_t:s0) or the manual page changed to say that it is only for use by root.
Comment 1 Tomas Mraz 2012-10-17 06:42:43 EDT
As this seriously affects system security policies we cannot change the permissions in already released major version of Red Hat Enterprise Linux. We could change it in the next major version though.

Of course changing the manpage in RHEL6 is possible.
Comment 4 Alain D D Williams 2012-11-19 12:23:26 EST
If you do change the man page, please add a comment that it will be fixed (ie made suid root) in RHEL7. Ie accept that you are different from what it should be but not for ever --- try to prevent divergence between the different distros.

People need to be warned if it is likely to change in the future.
Comment 5 Tomas Mraz 2012-11-19 13:48:54 EST
We still did not decide whether we want the groupmems to be setuid in Red Hat Enterprise Linux 7.
Comment 6 Tomas Mraz 2012-11-19 14:04:02 EST
Created attachment 647951 [details]
Manual page patch

The manual page patch for RHEL-6.4 update.
Comment 13 errata-xmlrpc 2013-02-21 05:54:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0464.html

Note You need to log in before you can comment on or make changes to this bug.