Bug 868530 - Delay and cpu spike in file open/save dialogs
Delay and cpu spike in file open/save dialogs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Triaged
: 863452 872896 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-20 12:38 EDT by nucleo
Modified: 2012-12-11 19:21 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-11 19:21:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.xsession-errors (25.80 KB, text/plain)
2012-10-30 11:26 EDT, Martin Kho
no flags Details

  None (edit)
Description nucleo 2012-10-20 12:38:00 EDT
Description of problem:
Ther are about 5 seconds delay in opening file open/save windows and in Dolphin starting.

Version-Release number of selected component (if applicable):
kde-workspace-4.9.2-3.fc18

How reproducible:
This delay happens when running live image Fedora-18-Beta-TC3-i686-Live-KDE.iso on my PC and notebook but not in virtual machine.

Steps to Reproduce:
1. Boot from live image.
2. Try to start Dolphin or open/save windows in any KDE apps.
  
Actual results:
There is several second delay before windows opened.

Expected results:
No delay.

Additional info:
udisks2 takes about 30-40% COU and dolphin about 60% CPU when delay happens.
No such delay with open/save windows in non-KDE apps, for example in Firefox.
Comment 1 nucleo 2012-10-20 13:10:02 EDT
I mean udisksd process takes 30-40% CPU.
Comment 2 Cole Robinson 2012-10-21 15:14:17 EDT
*** Bug 863452 has been marked as a duplicate of this bug. ***
Comment 3 Martin Kho 2012-10-23 09:35:23 EDT
Hi,

I'm not sure Bug 863452 (comment #2) is a dupe of this one. virt-manager isn't a kde app and the delay is much more excessive (more than 1 minute or some times for ever). The delay that I see in eg Dolphin is not more than a few seconds.

Martin Kho
Comment 4 Lukáš Tinkl 2012-10-23 11:12:10 EDT
So far I can't reproduce it with F18 Live CD on either bare metal or in VirtualBox...
Comment 5 nucleo 2012-10-23 11:17:30 EDT
If this can help, I have partitions with ext3, ext4 and ntfs filesystems.
Comment 6 Martin Kho 2012-10-23 12:23:11 EDT
I too am using bare metal (second disk). 
Tested:
Right click on a folder - other then the one that is selected - in dolpin takes a fraction of a second to open the menu. Actually, it takes a while before the blue selection bar moves to the selected folder.

Martin Kho
Comment 7 nucleo 2012-10-23 12:28:12 EDT
ext3,ext4,ntfs partitions are on my notebook but the most notable delay is on PC where I have 3 ext3 partitions, 4 ext4, and one ntfs.
Comment 8 Daniel Vrátil 2012-10-24 15:53:59 EDT
I tracked the issue down to Solid::Backends::UDisks::UDisksDevice::icon() - the method calls prop("DevicePresentationIconName") to retrieve icon name from cache - however for some devices the value does not seem to be present in the cache so the whole cache is invalidated and all devices enumerated again - given that the method is called from KFilePlacesItem::data() (i.e. by a model), it's called several times during single mouse-hover causing blocking a high load on the udisksd side (especially when a slow devices, like NFS shares or slow USB sticks is present).

Simply returning KIcon() for Qt::DecorationRole in KFilePlacesItem::data() keeps the udisksd asleep and thus makes the problem go away. 

What I described above is problem mainly in the open/save dialog. Dolphin caches the icon so it only queries Solid on start up - yet modifying the icon() method in Solid backend to just return an empty string makes Dolphin start a little bit faster (the difference can be bigger if slow devices are present).

I will try to fix it on the open/save dialog side so that the dialog caches the values like Dolphin does. 

Lukas, since it still impacts application start time, do you think this is fixable in the Solid UDisks backend? Can Solid cache "DevicePresentationIconName" for empty icons, so that devices without icon don't invalidate the entire cache?
Comment 9 Kevin Kofler 2012-10-24 19:16:56 EDT
I guess the secret there is to distinguish between a non-null empty string and a null string, which Qt doesn't encourage doing these days, but which would solve the problem of caching an empty string.
Comment 10 Martin Kho 2012-10-25 05:15:58 EDT
Hi,

May be a very stupid question. In Fedora 17 - same machine on the first disk - I don't see any delay's when opening file windows. Both fc18 and fc17 have kde 4.9.2 installed. Isn't the only difference udisks(2)?


Martin Kho
Comment 11 Daniel Vrátil 2012-10-25 05:54:12 EDT
AFAIK on FC17 Solid uses udisks1, where you can simply query a single device. On F18 Solid uses udisks2 which can only enumerate all present devices. Obviously that takes much more time and thus the delay and CPU spikes.



Anyway, I pushed the fix [0] to kdelibs just a moment ago, so this should be OK in KDE 4.9.3. Should I backport it to current Fedora kdelibs?

[0] https://git.reviewboard.kde.org/r/107030/
Comment 12 Kevin Kofler 2012-10-25 10:39:17 EDT
Yes please. (But we'll still want Solid optimized, too.)
Comment 13 Fedora Update System 2012-10-25 12:48:40 EDT
kdelibs-4.9.2-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kdelibs-4.9.2-7.fc18
Comment 14 nucleo 2012-10-25 12:56:41 EDT
Nothing changed after installing kdelibs-4.9.2-7.fc18.i686, still the same delays in dolphin starting, and file dialogs, udisksd takes 35% CPU, dolphin 60% CPU.
Comment 15 Lukáš Tinkl 2012-10-25 13:18:00 EDT
Make sure you at least relogin to your session. How do the open/save dialogs behave, any better?
Comment 16 nucleo 2012-10-25 13:20:23 EDT
I installed new kdelibs in 3 runlevel and then started KDE. No any changes, delay the same long as was before.
Comment 17 Martin Kho 2012-10-26 05:56:28 EDT
Hi,

Updated kdelibs(-common), rebooted and tried to open the file window (file -> Open ,,,) in kmail. The delay is still there. The same in dolpin (right click on a folder). So for me, the 'fix' is not a fix. Sorry.

Martin Kho
Comment 18 Fedora Update System 2012-10-26 15:43:33 EDT
Package kdelibs-4.9.2-7.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kdelibs-4.9.2-7.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16975/kdelibs-4.9.2-7.fc18
then log in and leave karma (feedback).
Comment 19 Martin Kho 2012-10-27 16:27:21 EDT
Hi,

Can this issue have to do with the different partition types (primary vs secondary)? I have no idea how udisks2 handles these, though. This idea came up when I was fiddleing a bit with grub2-mkconfig/install. In dmesg I got lots of the following 'errors':

[  461.368759] hfs: can't find a HFS filesystem on dev sda4.
[  462.180278] EXT4-fs (sdb4): unable to read superblock
[  462.189584] EXT4-fs (sdb4): unable to read superblock
[  462.198587] EXT4-fs (sdb4): unable to read superblock
[  462.206788] isofs_fill_super: bread failed, dev=sdb4, iso_blknum=16, block=32
[  462.215863] REISERFS warning (device sdb4): sh-2006 read_super_block: bread failed (dev sdb4, block 8, size 1024)
[  462.215871] REISERFS warning (device sdb4): sh-2006 read_super_block: bread failed (dev sdb4, block 64, size 1024)
[  462.215874] REISERFS warning (device sdb4): sh-2021 reiserfs_fill_super: can not find reiserfs on sdb4
[  462.224301] XFS (sdb4): bad magic number
[  462.224306] XFS (sdb4): SB validate failed
[  462.238379] FAT-fs (sdb4): bogus number of reserved sectors
[  462.238384] FAT-fs (sdb4): Can't find a valid FAT filesystem
[  462.248070] FAT-fs (sdb4): bogus number of reserved sectors
[  462.248076] FAT-fs (sdb4): Can't find a valid FAT filesystem
[  462.256997] MINIX-fs: unable to read superblock
[  462.264971] attempt to access beyond end of device
[  462.264976] sdb4: rw=0, want=3, limit=2
[  462.264980] hfs: unable to find HFS+ superblock
[  462.272954] You didn't specify the type of your ufs filesystem

Because I have on both disks more than 4 partitions, is sd{a|b}4 a 'link' to an extended partition. May be this can be a clue why nucleo and I - we both have more than 4 partitions - experience the delay and Lukáš doesn't. I also didn't see the delays in a VM (just 1 partition).

Any thought on this?

Martin Kho
Comment 20 Martin Kho 2012-10-28 08:46:39 EDT
Hi,

I've run the commamd: strace kdialog  --getopenfilename ~ > kdialog.strace 2>&1. In the output file (> 12 MB!) there are a lots of:

"recvfrom(6, 0xXXXXXXX, 4096, 0, 0, 0)   = -1 EAGAIN (Resource temporarily unavailable)"

were XXXXXXX = 10675f4 or 1d625f4

HTH

Martin Kho

Btw. If you need the complete output I can upload it gzip'd
Comment 21 Lukáš Tinkl 2012-10-29 06:55:17 EDT
Please note this fix will need another patch to libsolid which I'm working on currently, Dan's patch should fix CPU load in the File dialog.
Comment 22 Fedora Update System 2012-10-30 07:59:40 EDT
kdelibs-4.9.2-9.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kdelibs-4.9.2-9.fc18
Comment 23 Martin Kho 2012-10-30 10:46:52 EDT
Hi,

Sorry but no joy. After update rebooted.

when I run at the command prompt:

[martin@localhost ~]$ kdialog --getopenfilename ~
got invalid reply for cache: "Drive"
got invalid reply for cache: "Drive"
got invalid reply for cache: "Drive"
got invalid reply for cache: "Drive"
got invalid reply for cache: "Drive"
got invalid reply for cache: "Drive"
got invalid reply for cache: "Drive"
got invalid reply for cache: "Drive"
got invalid reply for cache: "Drive"
got invalid reply for cache: "Drive"
got invalid reply for cache: "Drive"
got invalid reply for cache: "Drive"
got invalid reply for cache: "DeviceNumber"
got invalid reply for cache: "Device"
got invalid reply for cache: "DeviceNumber"
got invalid reply for cache: "Device"

Martin Kho
Comment 24 Martin Kho 2012-10-30 11:26:36 EDT
Created attachment 635661 [details]
.xsession-errors

Hi,

Tried with a newly created user. Still the same errors. I've attached .xsession-errors. May be usefull.

Martin Kho
Comment 25 Lukáš Tinkl 2012-10-31 06:31:27 EDT
Those are not errors but rather debug output, you can disregard them. I am more interested in knowing whether this build improves the CPU load when starting apps like Dolphin and/or showing the File dialogs.
Comment 26 Martin Kho 2012-10-31 06:51:02 EDT
Hi Lukáš,

Sorry I wasn't clear in comment #23. The updated version of kdelibs didn't solve the issue for me. Still the delays. When I right click on a folder in Dolphin in top I see:

 PID USER      PR  NI  VIRT  RES  SHR S  %CPU %MEM    TIME+  COMMAND
1274 martin    20   0  679m  43m  30m S  38.2  1.1   0:18.61 dolphin
 917 root      20   0  343m 4064 2952 S  13.5  0.1   0:08.21 udisksd

and file open in kmail:
 1284 martin    20   0 2101m  79m  42m S  43.4  2.0   0:06.19 kmail
  917 root      20   0  343m 4064 2952 S  13.9  0.1   0:08.64 udisksd

HTH,

Martin Kho

[martin@localhost ~]$ rpm -q kdelibs
kdelibs-4.9.2-9.fc18.x86_64
Comment 27 Rex Dieter 2012-10-31 07:35:07 EDT
For me, file dialogs hit udisksd once, subsequent uses don't and are faster.
Comment 28 Martin Kho 2012-10-31 08:38:37 EDT
Hi,

I don't see what Rex sees :-(
I'v retried everything with a fresh Fedora 18 Beta TC6. Updated with all the latest packages (kdelibs-4.9.2-9.fc18.x86_64 was included). Also did run yum disto-sync.

Started dolpin and the command 'top -b -p <pid of dolpin>, <pid of udiskd>':
I right clicked three times on different folders (output below)

Does Rex's comment mean that my 'good old' core2duo 1,86 GHz desktop pc is getting too old to run the current kde version? I hope not :-)


Martin Kho

top - 08:23:07 up 6 min,  3 users,  load average: 0.15, 0.28, 0.16
<snip>
  PID USER      PR  NI  VIRT  RES  SHR S  %CPU %MEM    TIME+  COMMAND
 1503 martin    20   0  743m  53m  40m S   0.0  1.4   0:02.10 dolphin
 1167 root      20   0  349m 7132 3788 S   0.0  0.2   0:04.39 udisksd
<snip>
  PID USER      PR  NI  VIRT  RES  SHR S  %CPU %MEM    TIME+  COMMAND
 1503 martin    20   0  745m  55m  40m R  22.3  1.4   0:02.77 dolphin
 1167 root      20   0  349m 7132 3788 S   1.3  0.2   0:04.43 udisksd
<snip>
  PID USER      PR  NI  VIRT  RES  SHR S  %CPU %MEM    TIME+  COMMAND
 1503 martin    20   0  749m  56m  42m R  32.9  1.4   0:03.76 dolphin
 1167 root      20   0  349m 7132 3788 S  11.6  0.2   0:04.78 udisksd
<snip>
  PID USER      PR  NI  VIRT  RES  SHR S  %CPU %MEM    TIME+  COMMAND
 1503 martin    20   0  750m  56m  42m R  36.3  1.4   0:04.85 dolphin
 1167 root      20   0  349m 7132 3788 S  13.0  0.2   0:05.17 udisksd
<snip>
  PID USER      PR  NI  VIRT  RES  SHR S  %CPU %MEM    TIME+  COMMAND
 1503 martin    20   0  749m  56m  42m R  27.3  1.4   0:05.67 dolphin
 1167 root      20   0  349m 7132 3788 S   6.7  0.2   0:05.37 udisksd
<snip>
  PID USER      PR  NI  VIRT  RES  SHR S  %CPU %MEM    TIME+  COMMAND
 1503 martin    20   0  749m  56m  42m R  13.0  1.4   0:06.06 dolphin
 1167 root      20   0  349m 7132 3788 S   6.3  0.2   0:05.56 udisksd
<snip>
  PID USER      PR  NI  VIRT  RES  SHR S  %CPU %MEM    TIME+  COMMAND
 1503 martin    20   0  749m  56m  42m R   2.7  1.4   0:06.14 dolphin
 1167 root      20   0  349m 7132 3788 S   0.0  0.2   0:05.56 udisksd
Comment 29 Lukáš Tinkl 2012-10-31 08:45:04 EDT
Roughly the same CPU here, no lag at all, filedialogs query udisksd only once
Comment 30 Martin Kho 2012-10-31 08:57:58 EDT
Hi,

Stupid question number two ;-) When I run konqueror --profile filemanagement and right click on a folder the menu opens immediatly. Why this difference between Dolphin and Konqueror? Btw. 'File open' in konqueror also shows the delay.

Martin Kho
Comment 31 Lukáš Tinkl 2012-10-31 11:50:54 EDT
Different code, different behavior :)
Comment 32 Daniel Vrátil 2012-10-31 12:47:56 EDT
There is a serious bottleneck in Dolphin, which constructs a whole PlacesItemModel every time you open a context menu.
Comment 33 Kevin Kofler 2012-10-31 14:54:19 EDT
Uhm, can we please NOT spam debug output from kdelibs? And especially not in a patch supposed to improve performance!
Comment 34 Martin Kho 2012-11-09 14:36:32 EST
Hi,

As you can see I love asking stupid questions :-) Here I've another one in response to comment #32. Dan says there is a 'serious bottleneck". But in Fedora 17 - which also has kde 4.9.2 - I don't see these delays. Does Dolphin create in the F17 KDE version the 'whole PlacesItemModel evertime you open a context menu'? If so, then the delays have to come from the combination with udisks2 - which is not in FC17?

Martin Kho
Comment 35 Rex Dieter 2012-11-09 15:08:40 EST
Fedora 17's kde (still) uses udisks(1)
Fedora 18 (and newer) kde uses udisks2
Comment 36 Martin Kho 2012-11-09 16:48:51 EST
Hi Rex,

Yes, thats exactly why I asked. That is 'the' difference between kde 4.9.2 in Fedora 17 and Fedora 18 and not Dolpin's way of constructing the places? Or is Dolpin in fedora 17 using an other routine, then in Fedora 18?

Martin Kho
Comment 37 Martin Kho 2012-11-10 15:12:57 EST
Hi,

That's funny :-) My original issue with opening files in virt-manager - comment #2 [1] - does no longer exist. Wha I can see is that virt-manager uses a different file browser. No idea what made that one working.

Martin Kho

Btw. the 'mainstream' file browser - as used by konqueror / kmail etc. - still show the delays.

[1] Bug 863452
Comment 38 Daniel Vrátil 2012-11-29 13:17:27 EST
Guys, can you please test this [0] build of kdelibs? It should fix opening the KFileDialog and Gwenview (it does not fix Dolphin, but if the patch for KFileDialog works, it's gonna work for Dolphin too).

Please also verify that there are no CPU spikes from udisks2d when moving mouse over the devices in Places panel and/or when resizing the file dialog.


[0] http://koji.fedoraproject.org/koji/taskinfo?taskID=4741045
Comment 39 nucleo 2012-11-29 13:37:22 EST
(In reply to comment #38)
> Guys, can you please test this [0] build of kdelibs? It should fix opening
> the KFileDialog and Gwenview (it does not fix Dolphin, but if the patch for
> KFileDialog works, it's gonna work for Dolphin too).
> 
> Please also verify that there are no CPU spikes from udisks2d when moving
> mouse over the devices in Places panel and/or when resizing the file dialog.
> 
> 
> [0] http://koji.fedoraproject.org/koji/taskinfo?taskID=4741045

Open file dialog in kwrite opens first time immediately but all of disks are missing next 10 seconds when udisksd takes 30% kwrite 65%, then all disks are shown. When trying to open file dialog second time it appears with about 10 seconds delay with the same CPU usage by udisksd and kwrite.
Comment 40 nucleo 2012-11-29 13:40:28 EST
Similar behavior in gwenview. Resizing of windows is slow when disks already shown, takes about two seconds.
Comment 41 Rex Dieter 2012-11-29 13:42:33 EST
For me, there's a short cpu hit on the first kfiledialog open, then it's fast on subsequent opens.   not spikes witnessed for mouseover of folders/partions in "Places" or on resize.

though I don't have any extra disks or foreign (non-linux) partitions on this particular box either...
Comment 42 Martin Kho 2012-11-29 14:21:48 EST
Hi,

It looks much better. KFileDialog opens without cpu and udisk2 spikes. Gwenview opens immediatly, udisk2 using 2 - 3% cpu. There seems also to be an positive effect on dolphin. The fisrt time it behaves like to be expected. Opening Dolphin a second, third time etc. bring back the delays/spikes.

For me it looks promising.

Martin Kho
Comment 43 Przemysław Palacz 2012-11-29 20:36:39 EST
Hey,

After updating to kdelibs*-4.9.3-6, Dolphin and KFileDialog starts faster but they don't show disks any more because D-Bus is disconnected.

Exact error message:
Failed enumerating UDisks2 objects: "org.freedesktop.DBus.Error.Disconnected" 
"Not connected to D-Bus server"

After downgrading everything works as before.
Comment 44 Martin Kho 2012-11-30 05:30:13 EST
Hi,

Hum, yes same here what's been said in comment #43 :-( I didn't notice because I never use "Recently Accessed" and "Search For", so I hide them.

Martin Kho
Comment 45 Lukáš Tinkl 2012-11-30 06:56:57 EST
Guys, tried rebooting after upgrading kdelibs?
Comment 46 nucleo 2012-11-30 06:59:33 EST
I installed kdelibs before starting KDE.
Comment 47 Martin Kho 2012-11-30 07:33:36 EST
Hi Lukáš

Yes, right after the update rebooted. Today rebooted from fc17 -> fc18. Not only dolpin faces the d-bus disconnect message.

[/usr/bin/nepomukservicestub] Failed enumerating UDisks2 objects: "org.freedesktop.DBus.Error.Disconnected" 
 "Not connected to D-Bus server"

abrt-applet: dbus error: The maximum number of active connections for UID 1000 has been reached
abrt-applet: Can't connect to system dbus

Martin Kho
Comment 48 Daniel Vrátil 2012-12-01 12:30:36 EST
I did some more changes in the udisks2 backend, can you please test it again? The build is here: http://koji.fedoraproject.org/koji/taskinfo?taskID=4746936

Please make sure you reboot before testing. You should see performance gain in the KFileDialog, Gwenview and even Dolphin.

The previous patch was making plenty of new connections, but I somehow forgot to close the connections when no longer needed, causing the "Maximum number of active connections reader" error :)
Comment 49 nucleo 2012-12-01 12:51:29 EST
Looks like kdelibs-4.9.3-7.fc18 finally improved dolphin, gwenview and file dialog, also no delay in window resizing and disks context menus, no high CPU usage.
The only thing that I noticed is that when I opened file dialog in kwrite first time there are not shown disks but after less then second all disks appeared. All disks are shown when file dialog opened second time. All disks are shown without delay in dolphin  after starting but maybe less then second delay in gwenview.
Comment 50 nucleo 2012-12-01 12:54:07 EST
Disks not appeared after I again tried to open file dialog in kwrite. But When I tried to open it again after kwrite restart disks was shown.
Comment 51 nucleo 2012-12-01 13:08:49 EST
So disks randomly may not appear.

Here .xsession-errors when disks are shown:

Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop7" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop6" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop5" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop4" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop3" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop2" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop1" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop0" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sdb1" 
Creating backend for device "/org/freedesktop/UDisks2/drives/SAMSUNG_HD204UI_XXXXXXXXXXXXXX" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop7" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda5" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop6" 
Creating backend for device "/org/freedesktop/UDisks2/drives/SAMSUNG_HD501LJ_XXXXXXXXXXXXXX" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop5" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop4" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda4" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop3" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda3" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop2" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop1" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop0" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sdb1" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda2" 
Creating backend for device "/org/freedesktop/UDisks2/drives/SAMSUNG_HD204UI_XXXXXXXXXXXXXX" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda1" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sr0" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda5" 
Creating backend for device "/org/freedesktop/UDisks2/drives/_NEC_DVD_RW_ND_4550A" 
Creating backend for device "/org/freedesktop/UDisks2/drives/SAMSUNG_HD501LJ_XXXXXXXXXXXXXX" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda4" 
kwrite(2342) KSambaSharePrivate::testparmParamValue: We got some errors while running testparm "Load smb config files from /etc/samba/smb.conf
Loaded services file OK.
ERROR: cache directory /var/cache/samba does not exist
" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda7" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda3" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda2" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sdc" 
Creating backend for device "/org/freedesktop/UDisks2/drives/SAMSUNG_HD642JJ" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda1" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sdb2" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sr0" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sdb" 
Creating backend for device "/org/freedesktop/UDisks2/drives/_NEC_DVD_RW_ND_4550A" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda7" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda6" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sdc" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sdc1" 
Creating backend for device "/org/freedesktop/UDisks2/drives/SAMSUNG_HD642JJ_XXXXXXXXXXXXXX" 
got invalid reply for cache: "Drive" 
got invalid reply for cache: "Drive" 
got invalid reply for cache: "Drive" 
got invalid reply for cache: "Drive" 
got invalid reply for cache: "Drive" 
got invalid reply for cache: "Drive" 
got invalid reply for cache: "Drive" 
got invalid reply for cache: "Drive" 
got invalid reply for cache: "Drive" 
got invalid reply for cache: "Drive" 
got invalid reply for cache: "Drive" 
got invalid reply for cache: "Drive" 
got invalid reply for cache: "Drive" 
got invalid reply for cache: "Drive" 
got invalid reply for cache: "Drive" 
got invalid reply for cache: "Drive" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sdb2" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sdb" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda6" 
got invalid reply for cache: "DeviceNumber" 
got invalid reply for cache: "Device" 
got invalid reply for cache: "DeviceNumber" 
got invalid reply for cache: "Device" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sdc1" 
got invalid reply for cache: "DeviceNumber" 
got invalid reply for cache: "Device" 
got invalid reply for cache: "DeviceNumber" 
got invalid reply for cache: "Device" 
got invalid reply for cache: "DeviceNumber" 
got invalid reply for cache: "Device" 
got invalid reply for cache: "DeviceNumber" 
got invalid reply for cache: "Device" 
got invalid reply for cache: "DeviceNumber" 
got invalid reply for cache: "Device" 
got invalid reply for cache: "DeviceNumber" 


There are a lot of "got invalid reply for cache" messages.



This is all what was in .xsession-errors when disks was not shown:

Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop7" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop6" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop5" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop4" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop3" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop2" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop1" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop0" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sdb1" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop7" 
Creating backend for device "/org/freedesktop/UDisks2/drives/SAMSUNG_HD204UI_XXXXXXXXXXXXXX" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop6" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop5" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop4" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop3" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop2" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop1" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/loop0" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sdb1" 
Creating backend for device "/org/freedesktop/UDisks2/drives/SAMSUNG_HD204UI_XXXXXXXXXXXXXX" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda5" 
Creating backend for device "/org/freedesktop/UDisks2/drives/SAMSUNG_HD501LJ_XXXXXXXXXXXXXX" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda4" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda3" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda2" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda1" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sr0" 
Creating backend for device "/org/freedesktop/UDisks2/drives/_NEC_DVD_RW_ND_4550A" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda7" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sdc" 
Creating backend for device "/org/freedesktop/UDisks2/drives/SAMSUNG_HD642JJ_XXXXXXXXXXXXXX" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sdb2" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sdb" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sda6" 
Creating backend for device "/org/freedesktop/UDisks2/block_devices/sdc1" 
kwrite(2354) KSambaSharePrivate::testparmParamValue: We got some errors while running testparm "Load smb config files from /etc/samba/smb.conf
Loaded services file OK.
ERROR: cache directory /var/cache/samba does not exist
"
Comment 52 Daniel Vrátil 2012-12-01 15:42:21 EST
Thanks to lot for testing. To explain a bit, the short delay in displaying the devices in Gwenview and the file dialog is because the devices are being loaded asynchronously in order not to block the UI. However the devices are cached for the application lifetime, therefore re-opening the file dialog only touches the cache (no dbus communication, no udisks2 queries), so the devices appear immediately.

So far Dolphin uses synchronous approach and loads the devices during start, thus they seem to appear immediately (at the cost of slower start). Do you think the Dolphin start up time is acceptable, or does it block too long? I'm asking because if it's ok NOT to use the async cache for Dolphin, it would make it much much easier to get all the code into upstream kdelibs.

I'll look on why devices sometimes don't appear (I was unable to reproduce this yet).
Comment 53 nucleo 2012-12-01 16:09:05 EST
Dolphin time starting with kdelibs-4.9.3-7.fc18 looks like the same as in Fedora 17.

There are two problems with kdelibs-4.9.3-7.fc18 and removable USB disks.
First problem common to file dialog, dolphin and gwenview is that removable disk remains in disks list in all apps and in device notifier after removing.
Second problem only in file dialog and gwenview is removable disk shown three times (first with filesystem label, second with vendor name, third "removable media" with disk size), no such problem in Dolphin.
Looks like both problems not present in kdelibs-4.9.3-4.fc18.
Comment 54 nucleo 2012-12-01 16:10:24 EST
And I forgot that after USB mounting in file dialog yet one item shown with no name.
Comment 55 Przemysław Palacz 2012-12-01 20:35:43 EST
For me mounting removable drives works great (I can see correct drive label) but after safely removing usb drive and then removing it from usb port, it disappears from Dolphin's devices list but I can still see it in Device notifier plasma widget.

The second problem with current version I've is after clicking on unmounted device in for example Dolphin I get this error:

An error occurred while accessing 'Home', the system responded: The device is already mounted: Device /dev/sde1 is already mounted at `/run/media/przemal/my_disk_label'.

Disk gets mounted I can access it by going to above path but I can't access it by clicking on the Dolphin's devices list because of the mentioned error. Of course after restarting Dolphin, mentioned device is visible as mounted and everything works as expected.

On the freshly created account I was able to mount the first drive without any problems but I got stock with the above error on the second and the next one.

Besides that great improvement over previous builds.

In my opinion Dolphin's start time is the same/very similar as on F17.

PS. It would be awesome to make it start faster because it adds nice touch to the overall user experience.
Comment 56 nucleo 2012-12-01 20:42:12 EST
Dolphin shows one item for removable disk with filesystem label, three items (or four after mounting) are shown only in file dialog and in gwenview.
Comment 57 Przemysław Palacz 2012-12-01 20:57:14 EST
I don't see any repeated items for the same removable device either in Dolphin, Gwenview or KFileDialog on my config.
I only managed to get an empty disk items in Gwenview but that's only after clicking on unmounted disk for the fist time.

Almost forgot to include debug output from terminal to the disk mount problem I described:
...
"/org/freedesktop/UDisks2/jobs/3" has new interfaces: ("org.freedesktop.UDisks2.Job") 
Creating backend for device "/org/freedesktop/UDisks2/jobs/3" 
got invalid reply for cache: "Drive" 
got invalid reply for cache: "Drive" 
got invalid reply for cache: "Drive" 
got invalid reply for cache: "Drive" 
Created invalid Device for udi "" 
got invalid reply for cache: "Drive" 
got invalid reply for cache: "Drive" 
"/org/freedesktop/UDisks2/jobs/3" lost interfaces: ("org.freedesktop.UDisks2.Job")
...
Comment 58 Lukáš Tinkl 2012-12-03 10:42:09 EST
*** Bug 872896 has been marked as a duplicate of this bug. ***
Comment 59 Ngo Than 2012-12-04 09:01:37 EST
i tested the lastest solid backend patch and can verify the fix, it's now included in kdelibs-4.9.4-1.fc18.

thanks to Lukáš and Dan for the fix!
Comment 60 Lukáš Tinkl 2012-12-04 09:27:30 EST
For those who want to test the build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4754965
Comment 61 Martin Kho 2012-12-05 04:12:04 EST
Hi,

I'm totally happy :-) For me everything works excellent now. No delays, spikes or whatever other strange behaviour.

Again, excellent work and thanks,

Martin Kho
Comment 62 Ngo Than 2012-12-05 05:21:56 EST
> Hi,
> 
> I'm totally happy :-) For me everything works excellent now. No delays,
> spikes or whatever other strange behaviour.
> 
> Again, excellent work and thanks,
> 
> Martin Kho

Could you please test the new build? it fixes a bad regression in previous version. thanks

http://koji.fedoraproject.org/koji/buildinfo?buildID=370843
http://koji.fedoraproject.org/koji/buildinfo?buildID=370918
Comment 63 Martin Kho 2012-12-05 06:25:54 EST
Hi Ngo Than,

I'd like to but I get:

Error: Package: kde-baseapps-4.9.4-1.fc18.x86_64 (/kde-baseapps-4.9.4-1.fc18.x86_64)
           Requires: kde-runtime >= 4.9.4
           Installed: kde-runtime-4.9.3-1.fc18.x86_64 (@updates-testing)
               kde-runtime = 4.9.3-1.fc18

kde-4.9.4 is not yes pushed, isn't it? Just wait for 4.9.4?

Martin Kho

N.B. 'bad regression'? How could I've missed that?
Comment 64 nucleo 2012-12-05 06:41:10 EST
With kde-baseapps-4.9.4-1.fc18.i686 and kdelibs-4.9.4-2.fc18.i686 no delay in Dolphin and Gwenview starting, file dialog opening, no problems with resizing and disks context menus. Now file dialog opens first time with all disks.  Removable disk appears/disappears in disks list as it should.
Comment 65 nucleo 2012-12-05 19:54:14 EST
Everything works fine if update only kdelibs-4.9.4-2.fc18
https://koji.fedoraproject.org/koji/buildinfo?buildID=370843
Comment 66 Martin Kho 2012-12-06 03:25:27 EST
Hi,

Confirmed. Only updating kdelibs-4.9.4-2.fc18 works.

Thanks,

Martin Kho
Comment 67 John Rosich 2012-12-06 08:34:33 EST
The delay issues mentioned in this and related bugs have been resolved with the latest kde revisions (4.9.90.xx).

Thanks to all who made it happen!.

John

PS1 For the record, we're running fully updated "rawhide" on our machines.

PSS2 FWIW, looks like we still need the 4.9.90.xx version of 'kcalc' ('kdeutils' won't install) and 'kdegames'.

jr
Comment 68 Fedora Update System 2012-12-10 18:54:18 EST
PyQt-3.18.1-14.fc18, analitza-4.9.4-1.fc18, ark-4.9.4-1.fc18, blinken-4.9.4-1.fc18, cantor-4.9.4-1.fc18, dragon-4.9.4-1.fc18, filelight-4.9.4-1.fc18, gwenview-4.9.4-1.fc18, jovie-4.9.4-1.fc18, juk-4.9.4-1.fc18, kaccessible-4.9.4-1.fc18, kactivities-4.9.4-1.fc18, kalgebra-4.9.4-1.fc18, kalzium-4.9.4-1.fc18, kamera-4.9.4-1.fc18, kanagram-4.9.4-1.fc18, kate-4.9.4-1.fc18, kbruch-4.9.4-1.fc18, kcalc-4.9.4-1.fc18, kcharselect-4.9.4-1.fc18, kcolorchooser-4.9.4-1.fc18, kde-base-artwork-4.9.4-1.fc18, kde-baseapps-4.9.4-2.fc18, kde-l10n-4.9.4-1.fc18, kde-runtime-4.9.4-1.fc18, kde-wallpapers-4.9.4-1.fc18, kde-workspace-4.9.4-2.fc18, kdeaccessibility-4.9.4-1.fc18, kdeadmin-4.9.4-1.fc18, kdeartwork-4.9.4-1.fc18, kdebindings-4.9.4-1.fc18, kdeedu-4.9.4-1.fc18, kdegames-4.9.4-1.fc18, kdegraphics-4.9.4-1.fc18, kdegraphics-mobipocket-4.9.4-1.fc18, kdegraphics-strigi-analyzer-4.9.4-1.fc18, kdegraphics-thumbnailers-4.9.4-1.fc18, kdelibs-4.9.4-4.fc18, kdemultimedia-4.9.4-1.fc18, kdenetwork-4.9.4-2.fc18, kdepim-4.9.4-1.fc18, kdepim-runtime-4.9.4-1.fc18, kdepimlibs-4.9.4-1.fc18, kdeplasma-addons-4.9.4-1.fc18, kdesdk-4.9.4-1.fc18, kdetoys-4.9.4-1.fc18, kdeutils-4.9.4-1.fc18, kdf-4.9.4-1.fc18, kfloppy-4.9.4-1.fc18, kgamma-4.9.4-1.fc18, kgeography-4.9.4-1.fc18, kgpg-4.9.4-1.fc18, khangman-4.9.4-1.fc18, kig-4.9.4-1.fc18, kimono-4.9.4-1.fc18, kiten-4.9.4-1.fc18, klettres-4.9.4-1.fc18, kmag-4.9.4-1.fc18, kmix-4.9.4-1.fc18, kmousetool-4.9.4-1.fc18, kmouth-4.9.4-1.fc18, kmplot-4.9.4-1.fc18, kolourpaint-4.9.4-1.fc18, konsole-4.9.4-1.fc18, kremotecontrol-4.9.4-1.fc18, kross-interpreters-4.9.4-1.fc18, kruler-4.9.4-1.fc18, ksaneplugin-4.9.4-1.fc18, kscd-4.9.4-1.fc18, ksnapshot-4.9.4-1.fc18, kstars-4.9.4-1.fc18, ktimer-4.9.4-1.fc18, ktouch-4.9.4-1.fc18, kturtle-4.9.4-1.fc18, kwallet-4.9.4-1.fc18, kwordquiz-4.9.4-1.fc18, libkcddb-4.9.4-1.fc18, libkcompactdisc-4.9.4-1.fc18, libkdcraw-4.9.4-1.fc18, libkdeedu-4.9.4-1.fc18, libkexiv2-4.9.4-1.fc18, libkipi-4.9.4-1.fc18, libksane-4.9.4-1.fc18, marble-4.9.4-1.fc18, nepomuk-core-4.9.4-2.fc18, okular-4.9.4-1.fc18, oxygen-icon-theme-4.9.4-1.fc18, pairs-4.9.4-1.fc18, parley-4.9.4-1.fc18, pykde4-4.9.4-2.fc18, qyoto-4.9.4-1.fc18, rocs-4.9.4-1.fc18, ruby-korundum-4.9.4-1.fc18, ruby-qt-4.9.4-1.fc18, smokegen-4.9.4-1.fc18, smokekde-4.9.4-1.fc18, smokeqt-4.9.4-1.fc18, step-4.9.4-1.fc18, superkaramba-4.9.4-1.fc18, svgpart-4.9.4-1.fc18, sweeper-4.9.4-1.fc18, sip-4.14.2-1.fc18, PyQt4-4.9.6-1.fc18, veusz-1.16-2.fc18, sems-1.4.3-4.fc18.1, qscintilla-2.6.2-3.fc18, qgis-1.8.0-10.fc18, python-poppler-qt4-0.16.2-5.fc18, PyQwt-5.2.0-19.fc18.2, PyKDE-3.16.6-11.fc18, calibre-0.9.8-1.fc18, avogadro-1.0.3-12.fc18.1, audiocd-kio-4.9.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-20061/veusz-1.16-2.fc18,sems-1.4.3-4.fc18.1,qscintilla-2.6.2-3.fc18,qgis-1.8.0-10.fc18,python-poppler-qt4-0.16.2-5.fc18,PyQwt-5.2.0-19.fc18.2,PyKDE-3.16.6-11.fc18,calibre-0.9.8-1.fc18,avogadro-1.0.3-12.fc18.1,audiocd-kio-4.9.4-1.fc18,sip-4.14.2-1.fc18,PyQt4-4.9.6-1.fc18,PyQt-3.18.1-14.fc18,analitza-4.9.4-1.fc18,ark-4.9.4-1.fc18,blinken-4.9.4-1.fc18,cantor-4.9.4-1.fc18,dragon-4.9.4-1.fc18,filelight-4.9.4-1.fc18,gwenview-4.9.4-1.fc18,jovie-4.9.4-1.fc18,juk-4.9.4-1.fc18,kaccessible-4.9.4-1.fc18,kactivities-4.9.4-1.fc18,kalgebra-4.9.4-1.fc18,kalzium-4.9.4-1.fc18,kamera-4.9.4-1.fc18,kanagram-4.9.4-1.fc18,kate-4.9.4-1.fc18,kbruch-4.9.4-1.fc18,kcalc-4.9.4-1.fc18,kcharselect-4.9.4-1.fc18,kcolorchooser-4.9.4-1.fc18,kde-base-artwork-4.9.4-1.fc18,kde-baseapps-4.9.4-2.fc18,kde-l10n-4.9.4-1.fc18,kde-runtime-4.9.4-1.fc18,kde-wallpapers-4.9.4-1.fc18,kde-workspace-4.9.4-2.fc18,kdeaccessibility-4.9.4-1.fc18,kdeadmin-4.9.4-1.fc18,kdeartwork-4.9.4-1.fc18,kdebindings-4.9.4-1.fc18,kdeedu-4.9.4-1.fc18,kdegames-4.9.4-1.fc18,kdegraphics-4.9.4-1.fc18,kdegraphics-mobipocket-4.9.4-1.fc18,kdegraphics-strigi-analyzer-4.9.4-1.fc18,kdegraphics-thumbnailers-4.9.4-1.fc18,kdelibs-4.9.4-4.fc18,kdemultimedia-4.9.4-1.fc18,kdenetwork-4.9.4-2.fc18,kdepim-4.9.4-1.fc18,kdepim-runtime-4.9.4-1.fc18,kdepimlibs-4.9.4-1.fc18,kdeplasma-addons-4.9.4-1.fc18,kdesdk-4.9.4-1.fc18,kdetoys-4.9.4-1.fc18,kdeutils-4.9.4-1.fc18,kdf-4.9.4-1.fc18,kfloppy-4.9.4-1.fc18,kgamma-4.9.4-1.fc18,kgeography-4.9.4-1.fc18,kgpg-4.9.4-1.fc18,khangman-4.9.4-1.fc18,kig-4.9.4-1.fc18,kimono-4.9.4-1.fc18,kiten-4.9.4-1.fc18,klettres-4.9.4-1.fc18,kmag-4.9.4-1.fc18,kmix-4.9.4-1.fc18,kmousetool-4.9.4-1.fc18,kmouth-4.9.4-1.fc18,kmplot-4.9.4-1.fc18,kolourpaint-4.9.4-1.fc18,konsole-4.9.4-1.fc18,kremotecontrol-4.9.4-1.fc18,kross-interpreters-4.9.4-1.fc18,kruler-4.9.4-1.fc18,ksaneplugin-4.9.4-1.fc18,kscd-4.9.4-1.fc18,ksnapshot-4.9.4-1.fc18,kstars-4.9.4-1.fc18,ktimer-4.9.4-1.fc18,ktouch-4.9.4-1.fc18,kturtle-4.9.4-1.fc18,kwallet-4.9.4-1.fc18,kwordquiz-4.9.4-1.fc18,libkcddb-4.9.4-1.fc18,libkcompactdisc-4.9.4-1.fc18,libkdcraw-4.9.4-1.fc18,libkdeedu-4.9.4-1.fc18,libkexiv2-4.9.4-1.fc18,libkipi-4.9.4-1.fc18,libksane-4.9.4-1.fc18,marble-4.9.4-1.fc18,nepomuk-core-4.9.4-2.fc18,okular-4.9.4-1.fc18,oxygen-icon-theme-4.9.4-1.fc18,pairs-4.9.4-1.fc18,parley-4.9.4-1.fc18,pykde4-4.9.4-2.fc18,qyoto-4.9.4-1.fc18,rocs-4.9.4-1.fc18,ruby-korundum-4.9.4-1.fc18,ruby-qt-4.9.4-1.fc18,smokegen-4.9.4-1.fc18,smokekde-4.9.4-1.fc18,smokeqt-4.9.4-1.fc18,step-4.9.4-1.fc18,superkaramba-4.9.4-1.fc18,svgpart-4.9.4-1.fc18,sweeper-4.9.4-1.fc18
Comment 69 Fedora Update System 2012-12-11 19:21:08 EST
PyQt-3.18.1-14.fc18, analitza-4.9.4-1.fc18, ark-4.9.4-1.fc18, blinken-4.9.4-1.fc18, cantor-4.9.4-1.fc18, dragon-4.9.4-1.fc18, filelight-4.9.4-1.fc18, gwenview-4.9.4-1.fc18, jovie-4.9.4-1.fc18, juk-4.9.4-1.fc18, kaccessible-4.9.4-1.fc18, kactivities-4.9.4-1.fc18, kalgebra-4.9.4-1.fc18, kalzium-4.9.4-1.fc18, kamera-4.9.4-1.fc18, kanagram-4.9.4-1.fc18, kate-4.9.4-1.fc18, kbruch-4.9.4-1.fc18, kcalc-4.9.4-1.fc18, kcharselect-4.9.4-1.fc18, kcolorchooser-4.9.4-1.fc18, kde-base-artwork-4.9.4-1.fc18, kde-baseapps-4.9.4-2.fc18, kde-l10n-4.9.4-1.fc18, kde-runtime-4.9.4-1.fc18, kde-wallpapers-4.9.4-1.fc18, kde-workspace-4.9.4-2.fc18, kdeaccessibility-4.9.4-1.fc18, kdeadmin-4.9.4-1.fc18, kdeartwork-4.9.4-1.fc18, kdebindings-4.9.4-1.fc18, kdeedu-4.9.4-1.fc18, kdegames-4.9.4-1.fc18, kdegraphics-4.9.4-1.fc18, kdegraphics-mobipocket-4.9.4-1.fc18, kdegraphics-strigi-analyzer-4.9.4-1.fc18, kdegraphics-thumbnailers-4.9.4-1.fc18, kdelibs-4.9.4-4.fc18, kdemultimedia-4.9.4-1.fc18, kdenetwork-4.9.4-2.fc18, kdepim-4.9.4-1.fc18, kdepim-runtime-4.9.4-1.fc18, kdepimlibs-4.9.4-1.fc18, kdeplasma-addons-4.9.4-1.fc18, kdesdk-4.9.4-1.fc18, kdetoys-4.9.4-1.fc18, kdeutils-4.9.4-1.fc18, kdf-4.9.4-1.fc18, kfloppy-4.9.4-1.fc18, kgamma-4.9.4-1.fc18, kgeography-4.9.4-1.fc18, kgpg-4.9.4-1.fc18, khangman-4.9.4-1.fc18, kig-4.9.4-1.fc18, kimono-4.9.4-1.fc18, kiten-4.9.4-1.fc18, klettres-4.9.4-1.fc18, kmag-4.9.4-1.fc18, kmix-4.9.4-1.fc18, kmousetool-4.9.4-1.fc18, kmouth-4.9.4-1.fc18, kmplot-4.9.4-1.fc18, kolourpaint-4.9.4-1.fc18, konsole-4.9.4-1.fc18, kremotecontrol-4.9.4-1.fc18, kross-interpreters-4.9.4-1.fc18, kruler-4.9.4-1.fc18, ksaneplugin-4.9.4-1.fc18, kscd-4.9.4-1.fc18, ksnapshot-4.9.4-1.fc18, kstars-4.9.4-1.fc18, ktimer-4.9.4-1.fc18, ktouch-4.9.4-1.fc18, kturtle-4.9.4-1.fc18, kwallet-4.9.4-1.fc18, kwordquiz-4.9.4-1.fc18, libkcddb-4.9.4-1.fc18, libkcompactdisc-4.9.4-1.fc18, libkdcraw-4.9.4-1.fc18, libkdeedu-4.9.4-1.fc18, libkexiv2-4.9.4-1.fc18, libkipi-4.9.4-1.fc18, libksane-4.9.4-1.fc18, marble-4.9.4-1.fc18, nepomuk-core-4.9.4-2.fc18, okular-4.9.4-1.fc18, oxygen-icon-theme-4.9.4-1.fc18, pairs-4.9.4-1.fc18, parley-4.9.4-1.fc18, pykde4-4.9.4-2.fc18, qyoto-4.9.4-1.fc18, rocs-4.9.4-1.fc18, ruby-korundum-4.9.4-1.fc18, ruby-qt-4.9.4-1.fc18, smokegen-4.9.4-1.fc18, smokekde-4.9.4-1.fc18, smokeqt-4.9.4-1.fc18, step-4.9.4-1.fc18, superkaramba-4.9.4-1.fc18, svgpart-4.9.4-1.fc18, sweeper-4.9.4-1.fc18, sip-4.14.2-1.fc18, PyQt4-4.9.6-1.fc18, veusz-1.16-2.fc18, sems-1.4.3-4.fc18.1, qscintilla-2.6.2-3.fc18, qgis-1.8.0-10.fc18, python-poppler-qt4-0.16.2-5.fc18, PyQwt-5.2.0-19.fc18.2, PyKDE-3.16.6-11.fc18, calibre-0.9.8-1.fc18, avogadro-1.0.3-12.fc18.1, audiocd-kio-4.9.4-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.