Bug 868903 - GUI freezes if repartitioning is attempted
GUI freezes if repartitioning is attempted
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 08:31 EDT by Ladislav Jozsa
Modified: 2013-03-12 10:26 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-18.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 00:40:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (4.31 KB, text/x-log)
2012-10-22 08:31 EDT, Ladislav Jozsa
no flags Details
ifcfg.log (641 bytes, text/x-log)
2012-10-22 08:31 EDT, Ladislav Jozsa
no flags Details
packaging.log (2.38 KB, text/plain)
2012-10-22 08:32 EDT, Ladislav Jozsa
no flags Details
program.log (31.84 KB, text/plain)
2012-10-22 08:33 EDT, Ladislav Jozsa
no flags Details
storage.log (92.00 KB, text/plain)
2012-10-22 08:33 EDT, Ladislav Jozsa
no flags Details
X.log (53.22 KB, text/plain)
2012-10-22 08:34 EDT, Ladislav Jozsa
no flags Details

  None (edit)
Description Ladislav Jozsa 2012-10-22 08:31:03 EDT
Created attachment 631459 [details]
anaconda.log

Description of problem:
I have found another bug which might be related to bug 864926. This time GUI freezes after selection of automatic partitioning, reclaiming all space by deleting previous partitions and attempt to change the partitioning again.

Version-Release number of selected component (if applicable):
anaconda 18.19

How reproducible:
always

Steps to Reproduce:
1. Select automatic partitioning on a system with previous Fedora install
2. Don't tick 'I don't need help...' 
3. Click on Reclaim space button
4. Delete all existing partitions, reclaim space
5. Don't tick 'Let me customize partitions...' and continue
6. In the main menu, select the partitioning again
7. Click Continue button in the next screen
  
Actual results:
GUI freezes after second attempt of partitioning disk.

Expected results:
GUI should not freeze

Additional info:
Comment 1 Ladislav Jozsa 2012-10-22 08:31:30 EDT
Created attachment 631460 [details]
ifcfg.log
Comment 2 Ladislav Jozsa 2012-10-22 08:32:09 EDT
Created attachment 631463 [details]
packaging.log
Comment 3 Ladislav Jozsa 2012-10-22 08:33:08 EDT
Created attachment 631464 [details]
program.log
Comment 4 Ladislav Jozsa 2012-10-22 08:33:33 EDT
Created attachment 631465 [details]
storage.log
Comment 5 Ladislav Jozsa 2012-10-22 08:34:07 EDT
Created attachment 631466 [details]
X.log
Comment 6 Chris Lumens 2012-10-22 10:28:18 EDT
Looks like the proper dialog is being displayed, but is not popping up to the front for some reason.  It could be non-modal, or set to appear below, or perhaps there is a threading problem.
Comment 7 Chris Lumens 2012-10-22 15:50:36 EDT
Ah, I see it now.  Mailing out a patch shortly.
Comment 8 Reartes Guillermo 2012-10-23 12:34:51 EDT
In my case, i reproduced it in a similar way:

The guest has 3 disks. All of them have preexisting partitions.

0. Enter STORAGE: INSTALLATION DESTINATION

1. Select the third disks, AUTOMATIC PARTITIONING, just 'reclaim space'

2. Set the ACTION field of each partition (SWAP, SW RAID) to DELETE and 'reclaim space'

3. In the next INSTALLATION OPTIONS (which is pretty strange, since i expected it to go back to the MAIN HUB, since i already given the directives to AUTOMATIC PARTITIONING). So, just press 'Continue'

4. Enter STORAGE: INSTALLATION DESTINATION again.

5. Select the second disks (and deselect the previously selected third disk), AUTOMATIC PARTITIONING

6. Set the ACTION field of each partition (SWAP, SW RAID) to DELETE

7. In the next INSTALLATION OPTIONS just press 'Continue' (See comment in 3.)

8. Enter STORAGE: INSTALLATION DESTINATION again.

6. Select third disk again, and press Continue', Anaconda gets STUCK.

At this point, pressing ESC frees anaconda. However, changing the disks selected does not change the outcome. Every time 'continue' is pressed, anaconda gets stuck.

I also tried updates image from 864128 (comment #17) but it was the same.
Comment 9 Chris Lumens 2012-10-23 13:13:02 EDT
> I also tried updates image from 864128 (comment #17) but it was the same.

Right, if you read what I said in that comment, I explicitly stated that updates image would do nothing for the underlying cause.  All I'm after with that updates image is whether or not the delete confirmation dialog gets destroyed properly.
Comment 10 Adam Williamson 2012-11-23 00:40:53 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(please note clumens' comment in #9, this is about the display of the dialog.)

Note You need to log in before you can comment on or make changes to this bug.