Bug 869300 - edit-node raises stack trace
edit-node raises stack trace
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: livecd-tools (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Brian Lane
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 10:12 EDT by Fabian Deutsch
Modified: 2013-02-21 08:17 EST (History)
10 users (show)

See Also:
Fixed In Version: livecd-tools-13.4.3-1
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 08:17:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
don't pass --comp to mksquashfs if compression is None (882 bytes, patch)
2012-10-23 14:40 EDT, Brian Lane
no flags Details | Diff

  None (edit)
Description Fabian Deutsch 2012-10-23 10:12:23 EDT
Description of problem:
A current edit-node version raises a stack traces and fails to edit a node image.

Version-Release number of selected component (if applicable):
RHEL 6
livecd-tools-13.4.2-2.el6.x86_64

How reproducible:
Always


Steps to Reproduce:
1. sudo python edit-node.latest --repo plugin.repo --install ovirt-autotesting-sysvinit rhev-hypervisor6-6.4-20121015.1.auto346.el6.devel.iso
2.
3.
  
Actual results:
Raises stacktrace:
Cleaning Up Yum Configuration
done
Running Minimizer
[]
Creating Manifests
Copying Manifests
Editing Complete
Traceback (most recent call last):
  File "edit-node.latest", line 1512, in <module>
    sys.exit(main())
  File "edit-node.latest", line 1496, in main
    editor.package(output)
  File "/usr/lib/python2.6/site-packages/imgcreate/creator.py", line 766, in package
    self._stage_final_image()
  File "/usr/lib/python2.6/site-packages/imgcreate/live.py", line 321, in _stage_final_image
    create_image_minimizer(self.__isodir + "/LiveOS/osmin.img", self._image, self.compress_type)
  File "/usr/lib/python2.6/site-packages/imgcreate/fs.py", line 619, in create_image_minimizer
    mksquashfs(cowloop.lofile, path, compress_type)
  File "/usr/lib/python2.6/site-packages/imgcreate/fs.py", line 53, in mksquashfs
    ret = subprocess.call(args)
  File "/usr/lib64/python2.6/subprocess.py", line 478, in call
    p = Popen(*popenargs, **kwargs)
  File "/usr/lib64/python2.6/subprocess.py", line 639, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.6/subprocess.py", line 1228, in _execute_child
    raise child_exception
TypeError: execv() arg 2 must contain only strings

Expected results:
Image can be edited

Additional info:
Comment 3 Brian Lane 2012-10-23 14:40:35 EDT
Created attachment 632298 [details]
don't pass --comp to mksquashfs if compression is None

Give this a try.
Comment 5 Fabian Deutsch 2012-10-25 06:17:09 EDT
Is there a release with the patch above yet?
Comment 8 haiyang,dong 2012-11-29 01:07:19 EST
This bug was blocked by Bug 809085, waiting for that bug fixed to verify
this one
Comment 9 haiyang,dong 2013-01-22 01:48:24 EST
Test version:
livecd-tools-13.4.3-1.el6

[root@rhevm-ic-105-206 rhev-hypervisor]# edit-livecd rhevh-6.4-20130116.3.0.el6.iso 
rhevh-6.4-20130116.3.0.el6.iso
Launching shell. Exit to continue.
----------------------------------
[root@rhevm-ic-105-206 /]# exit
exit
e2fsck 1.41.12 (17-May-2010)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
_rhevh-6.4-20130: 12175/81920 files (1.0% non-contiguous), 99336/327680 blocks
e2image 1.41.12 (17-May-2010)
resize2fs 1.41.12 (17-May-2010)
Resizing the filesystem on /var/tmp/edit-liveos-_E13uu/ex/ext3fs.img to 95414 (4k) blocks.
The filesystem on /var/tmp/edit-liveos-_E13uu/ex/ext3fs.img is now 95414 blocks long.

e2fsck 1.41.12 (17-May-2010)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
_rhevh-6.4-20130: 12175/24576 files (1.0% non-contiguous), 95414/95414 blocks
e2fsck 1.41.12 (17-May-2010)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
_rhevh-6.4-20130: 12175/24576 files (1.0% non-contiguous), 95414/95414 blocks
e2image 1.41.12 (17-May-2010)
resize2fs 1.41.12 (17-May-2010)
Resizing the filesystem on /var/tmp/edit-liveos-_E13uu/ex/ext3fs.img to 327680 (4k) blocks.
The filesystem on /var/tmp/edit-liveos-_E13uu/ex/ext3fs.img is now 327680 blocks long.

e2fsck 1.41.12 (17-May-2010)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
_rhevh-6.4-20130: 12175/81920 files (1.0% non-contiguous), 99336/327680 blocks
e2fsck 1.41.12 (17-May-2010)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
_rhevh-6.4-20130: 12175/81920 files (1.0% non-contiguous), 99336/327680 blocks
e2image 1.41.12 (17-May-2010)
resize2fs 1.41.12 (17-May-2010)
Resizing the filesystem on /dev/mapper/imgcreate-10456-4939 to 95414 (4k) blocks.
The filesystem on /dev/mapper/imgcreate-10456-4939 is now 95414 blocks long.

e2fsck 1.41.12 (17-May-2010)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
_rhevh-6.4-20130: 12175/24576 files (1.0% non-contiguous), 95414/95414 blocks
Parallel mksquashfs: Using 1 processor
Creating 4.0 filesystem on /var/tmp/edit-liveos-_E13uu/iso/LiveOS/osmin.img, block size 131072.
[===================================================================|] 3/3 100%
Exportable Squashfs 4.0 filesystem, data block size 131072
	compressed data, compressed metadata, compressed fragments
	duplicates are removed
Filesystem size 2.49 Kbytes (0.00 Mbytes)
	0.67% of uncompressed filesystem size (372.20 Kbytes)
Inode table size 61 bytes (0.06 Kbytes)
	78.21% of uncompressed inode table size (78 bytes)
Directory table size 23 bytes (0.02 Kbytes)
	85.19% of uncompressed directory table size (27 bytes)
Number of duplicate files found 0
Number of inodes 2
Number of files 1
Number of fragments 0
Number of symbolic links  0
Number of device nodes 0
Number of fifo nodes 0
Number of socket nodes 0
Number of directories 1
Number of ids (unique uids + gids) 1
Number of uids 1
	root (0)
Number of gids 1
	root (0)
Parallel mksquashfs: Using 1 processor
Creating 4.0 filesystem on /var/tmp/edit-liveos-_E13uu/iso/LiveOS/squashfs.img, block size 131072.
[===========================================================/] 10240/10240 100%
Exportable Squashfs 4.0 filesystem, data block size 131072
	compressed data, compressed metadata, compressed fragments
	duplicates are removed
Filesystem size 124589.99 Kbytes (121.67 Mbytes)
	9.51% of uncompressed filesystem size (1310760.28 Kbytes)
Inode table size 8504 bytes (8.30 Kbytes)
	20.70% of uncompressed inode table size (41092 bytes)
Directory table size 50 bytes (0.05 Kbytes)
	86.21% of uncompressed directory table size (58 bytes)
Number of duplicate files found 0
Number of inodes 3
Number of files 1
Number of fragments 0
Number of symbolic links  0
Number of device nodes 0
Number of fifo nodes 0
Number of socket nodes 0
Number of directories 2
Number of ids (unique uids + gids) 1
Number of uids 1
	root (0)
Number of gids 1
	root (0)
I: -input-charset not specified, using utf-8 (detected in locale settings)
Using LIVEC000.;1 for  /var/tmp/edit-liveos-_E13uu/iso/LiveOS/livecd-iso-to-pxeboot (livecd-iso-to-disk)
Using MANIF000.BZ2;1 for  /var/tmp/edit-liveos-_E13uu/iso/isolinux/manifest-dir.txt.bz2 (manifest-deps.txt.bz2)
Using MANIF000.TXT;1 for  /var/tmp/edit-liveos-_E13uu/iso/isolinux/manifest-srpm.txt (manifest-rpm.txt)
Using MANIF001.BZ2;1 for  /var/tmp/edit-liveos-_E13uu/iso/isolinux/manifest-deps.txt.bz2 (manifest-owns.txt.bz2)
Using MANIF001.TXT;1 for  /var/tmp/edit-liveos-_E13uu/iso/isolinux/manifest-rpm.txt (manifest-license.txt)
Using MANIF002.BZ2;1 for  /var/tmp/edit-liveos-_E13uu/iso/isolinux/manifest-owns.txt.bz2 (manifest-file.txt.bz2)
Size of boot image is 4 sectors -> No emulation
Size of boot image is 58896 sectors -> No emulation
  5.46% done, estimate finish Tue Jan 22 14:40:32 2013
 10.93% done, estimate finish Tue Jan 22 14:40:32 2013
 16.39% done, estimate finish Tue Jan 22 14:40:32 2013
 21.86% done, estimate finish Tue Jan 22 14:40:32 2013
 27.31% done, estimate finish Tue Jan 22 14:40:32 2013
 32.78% done, estimate finish Tue Jan 22 14:40:32 2013
 38.24% done, estimate finish Tue Jan 22 14:40:32 2013
 43.71% done, estimate finish Tue Jan 22 14:40:32 2013
 49.16% done, estimate finish Tue Jan 22 14:40:32 2013
 54.63% done, estimate finish Tue Jan 22 14:40:32 2013
 60.08% done, estimate finish Tue Jan 22 14:40:32 2013
 65.55% done, estimate finish Tue Jan 22 14:40:32 2013
 71.01% done, estimate finish Tue Jan 22 14:40:32 2013
 76.48% done, estimate finish Tue Jan 22 14:40:32 2013
 81.93% done, estimate finish Tue Jan 22 14:40:32 2013
 87.39% done, estimate finish Tue Jan 22 14:40:32 2013
 92.86% done, estimate finish Tue Jan 22 14:40:32 2013
 98.31% done, estimate finish Tue Jan 22 14:40:32 2013
Total translation table size: 2048
Total rockridge attributes bytes: 3698
Total directory bytes: 10830
Path table size(bytes): 64
Max brk space used 1b000
91548 extents written (178 MB)
Inserting md5sum into iso image...
md5 = edf03fa55db8840b0a78590a29a82229
Inserting fragment md5sums into iso image...
fragmd5 = 1b18dbe1919918ca22ba154999dd4b2ed9ce762e7f127ae31b16248aefbd
frags = 20
Setting supported flag to 0
[root@rhevm-ic-105-206 rhev-hypervisor]# ls
rhevh-6.4-20130116.3.0.el6.iso              
rhevh-6.4-20130116.3.0.el6.iso.edited.iso

so this bug has been fixed,change the status into "VERIFIED".
Comment 11 errata-xmlrpc 2013-02-21 08:17:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0542.html

Note You need to log in before you can comment on or make changes to this bug.